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Note1: When you work with GoDaddy, you will have two sets of usernames and passwords. 

One to log into GoDaddy. The second is needed to use an FTP client, such as FileZilla. If you 

use the GoDaddy File Manager, you will not need the second set of usernames and 

passwords.  

Note2: The FTP or cPanel username is automatically assigned. It looks like: lm5p8o1bzk2r. 

You cannot change it. But you can change your FTP password in the cPanel Settings panel. 

GoDaddy File Manager 
The www.godaddy.com File Manager is a temporary way to upload your files to your website. 

It is easy to understand and requires no setup once you set up your domain and hosting. But 

in the end, it is harder to use, because you must log in and enter your username and 

password, then navigate to Hosting, go to the cPanel, then go to your folder, and click on the 

Upload icon, then browse to your local folder… This process is time consuming. 

 

Later you will want to use an FTP (File Transfer Protocol) client which is usually built into your 

editor. For instance, you can directly FTP from VS Code (if you set up a JSON file), FileZilla, 

Dreamweaver and Notepad++ and your editor will remember your password and folder 

paths.  
 

Below are the pictorial directions for the GoDaddy File Manager: 

• Log in to www.GoDaddy.com 

Enter your cPanel Username; it will look something like: io58wikzfxyr 

Enter the cPanel Password. 

If you have not already written these down, go to Hosting in GoDaddy to locate your 

Username. You can also set or change your password there. Note the GoDaddy 

Username may be JaneDoe, but the cPanel Username is an automatically generated 12-

character code for security reasons. 

• Navigate to Hosting and/or the cPanel – your screen may vary. 

Click the square, 9-dot Links button, and then click Hosting. (Your screen may vary) 

http://www.godaddy.com/
http://www.godaddy.com/


 
Navigate to the cPanel (Your screen may vary)  

(Note also use cPanel Settings to change your password.) 
 

 
 

Or you may see the following. You can click on the File Manager link, which may be easier than  the FTP 

Manager link. But I usually just go straight to the [cPanel Admin] link and then choose the File Manager. 

Notice how you can view your FTP or cPanel credentials on this screen. 

 



 
 

Click on the Blue Globe to expand public_html. That is where your site files are stored. 

 
 

Click the Upload icon to Browse to your newly created index.htm file (on your local drive) 

and upload it to replace the GoDaddy home.htm placeholder file. Your new index.htm file has a 

higher priority than home.htm, so it will open by default. Below is what you will see after you 

upload your index.htm and resume.htm. Click + Folder icon to create your images folder. 



 
 

After unloading your files, type your domain address in the browser URL address bar and your 

new index.htm file should open. 

 
 

On the top Nav bar are additional options for to Rename, View, and go Up One Level (to go 

from your images folder to your main folder) …  Do not use Edit or HTML Editor. Edit on your 

local computer. That way, you can test before going live and you always have a local backup. 
In the end, your public_html folder will have these files in it: 

 

images (folder) 

  index.htm 

  contact.htm 

  contactsent.htm 

  newsletter.htm 

  portfolio.htm 

  resume.htm 

  yoursitename.css 

 

  



Troubleshooting files that do not display, using GoDaddy File Manager 

A. Home page does not come up 
  1  Is your home page file named: index.htm or index.html? (only use one of those two names) 

 index.htm must be spelled correctly and in all lower case. 

  2  Can you see your uploaded index.htm when you browse to the public_html folder? 

 

B. Images do not display 
  1 Did you click the + Folder option to create an images folder inside the public_html folder? 

  2 Can you see your uploaded picture.jpg when you browse to the online images folder? 

  3 Is your uploaded picture.jpg spelled exactly the same way in your html file as it is online? 

(The spelling is case sensitive!)  <img src="images/picture.jpg” alt=”photo of…”> 

  



FileZilla 
V 2022/09/07, by Professor Floyd Jay Winters 

 

FileZilla is a free download for FTP. See https://filezilla-project.org/  

Once you enter your Domain Name, Username, Password, and Port (usually 21) FileZilla will remember 

your credentials. Browse to your local folder, then once connected, browse to your Remote folder (often 

public_html). Just drag from the Local folder to the Remote folder to upload your file(s). And all you 

have to do is click the Quickconnect dropdown the next time you use FileZilla. 

 

 
  

https://filezilla-project.org/


VS CODE 
Unfortunately, an FTP client is not built into VS Code. But you can add an FTP Extension. See below: 

It is a bit more difficult to set up FTP with VS Code. And there are two other drawbacks. Passwords tend 

to be visible when you view the config file. Also, files tend to be automatically uploaded on save. I prefer 

to only upload when I have the bugs worked out. But fortunately, there is an "autosave": false setting. 

 

FTP (uploading your files to your web server) See FTP Config file below 
https://www.youtube.com/watch?v=3jB2vdZb-_s  (2:38) FTP Simple Nice and short 

https://www.youtube.com/watch?v=Kgi5CLN_OF0  (6:27) cPanel settings, but use path /public_htm 

https://www.youtube.com/watch?v=G1R5H6pnOyc  (9:21) FTP Simple 

https://www.youtube.com/watch?v=9L1ciOkHSAQ&t=1540s  (38:03) FTP Simple Upgraded 

NOTE: After installing FTP-Simple, Extensions icon (4 squares) on the left Activity Bar, click FTP-Simple 

again and look at the FTP-Simple options. 

https://www.youtube.com/watch?v=RPBT01tg0DY&t=184s (5:32) FTP Sync shown with cPanel 

Uploads are set to automatic on save, but can be done manually: 

 Right-click on filename tab at top of window > Choose ftp-simple: Save – Upload to FTP Server 

 Follow the prompts at the top of the screen.  

 

VS Code extensions use a JSON file. 

 

JSON files 

A .json file is a Javascript config file (JavaScript Object Notation)  

Ex: settings.json for storing desired font-size and color theme, emmet settings… 

Set through File > Preferences. View:  

tap [F1] > Type Preferences: Open Settings (JSON) 

Ex: launch.json tells vs code what browser to open for page preview 

 To see launch.json: View > Command Palette or tap [F1] > Type launch  

Ex: ftp-simple-temp.json stores ftp domain name, username and password... 

 

FTP Config file 
Click Extensions icon (4 squares) on the left Activity Bar.  

Search for FTP-Simple and click [Install] 

Then tap [F1] > Type FTP-Simple and choose Config - FTP connection setting to open the ftp-simple-

temp.json template  

  1 [ 

  2   { 

  3       "name": "Sample-Name of local host or web server", 

  4       "host": "ftp.URLDomainName.com", or "host": "IP address", (Get IP address from cPanel) 

  5       "port": 21, or "port": 22, (FTP is port 21. SFTP is 22). 

  6       "type": "ftp", or "type": "sftp", 

  7       "username": "Your FTP USERNAME",  (It may be assigned in cPanel) 

  8       "password": "Your FTP PASSWORD", 

  9       "path": "/",  or "path": "/public_html", 

https://www.youtube.com/watch?v=3jB2vdZb-_s
https://www.youtube.com/watch?v=Kgi5CLN_OF0
https://www.youtube.com/watch?v=G1R5H6pnOyc
https://www.youtube.com/watch?v=9L1ciOkHSAQ&t=1540s
https://www.youtube.com/watch?v=RPBT01tg0DY&t=184s


10       "autosave": true, or "autosave": false, (I prefer to save when ready) 

11       "confirm": true or "confirm": false (I do not mind confirming) 

12    } 

13 ] 

Note: Quotes above are not curly quotes “These are curly quotes Do Not Use”  "These are not curly 

quotes" 

Note: Autosave will automatically upload to the server in the above configuration. 

Note: To set up multiple sites: Copy lines 2 to 12. Add a , after line 12. Paste and modify copied code. 

 

A. File > Preferences > Settings > Extensions > FTP-Simple > Remote Workspace: C:\websites\foldername 

(You may have to close and reopen VS Code for settings to take effect and download files or right-click 

Explorer: ftp-simple: Download in working directory from FTP server) 

B. BETTER to set up local directory: https://www.youtube.com/watch?v=9L1ciOkHSAQ&t=1468s 

(@24:28) 

As per above video, add the following to set a local path (after adding a comma at the end of line 11)” 

12        "project": "c:/websites/Website1/" 

Make local file code changes, then [Ctrl] [Shift] S – to start Save to Server 

  or right-click the file in the Explorer > choose ftp-simple: Save upload to FTP server 

To Upload: (After creating the Config file, see above)  

View > Command Palette or tap [F1] > Type FTP-Simple and choose Save: Upload to Server 

After setup, it should upload automatically on Save.  

When done uploading, click Output (on bottom) and select FTP Simple from dropdown to confirm 

Tap [F1] > Type FTP-Simple remote and choose Remote directory open to workspace  

(you can use this to open one of multiple domains that you may have configured) 

    and choose your domain name and then click to choose your current directory 

OR Choose Terminal from top menu > New Terminal > choose FTP-simple under Output/Tasks on 

bottom 

All your files will appear on the left side if you click the Explorer icon (upper right corner of Activity Bar).  

To Open: You can now click a file on the left to open and edit. Or click File > Open Or click Go > Go to File 

VS Code blocks saving a file to prevent overwriting changes that have been made outside of the editor. 

 

When Done: View > Command Palette or tap [F1] > Type FTP-Simple > choose Close all FTP connections 

  

https://www.youtube.com/watch?v=9L1ciOkHSAQ&t=1468s


Downloading the Notepad ++ Plugin Manager and NppFTP 
V 2018/10/03, by Professor Floyd Jay Winters 

YOUR SCREEN MAY VARY 

 

1. Download Notepad ++ 

See: https://notepad-plus-plus.org/ and click on [Download] link 

BUT if you have a 64bit system (Click Windows > System Information) 

choose the easier Notepad++ Installer 64-bit x64 and click Run when prompted 

  

2. Download and install the Plugin Manager 

The link we used to download the Plugin Manager was: 

https://github.com/bruderstein/nppPluginManager/releases  

We used: PluginManager_v1.4.12_x64.zip and saved it to the Downloads folder. 

3. Right click to Extract the zip file from Download folder. 

4. Open the new PluginManager Folder, then open the plugin subfolder, and copy 

PluginManager.dll 

Paste it in C:\Program Files\Notepad++\plugins 

 
 

5. Open the updater folder and copy gpup.exe 

Paste it in C:\Program Files\Notepad++\updater 
 

https://notepad-plus-plus.org/
https://notepad-plus-plus.org/repository/7.x/7.5.8/npp.7.5.8.Installer.x64.exe
https://github.com/bruderstein/nppPluginManager/releases


6. Restart Notepad++ and choose Plugin Manager > Show Plugin Manager 

 
7. Select NppFTP and click [Install] 

 
 

8. Restart Notepad++ and choose NppFTP > Show NppFTP Window. 

 
A NppFTP window will appear on the right side of the screen. 

 

9. Click on the Settings icon (the gear, the last icon). 

Chose Profile Settings 

 
 

10. Enter your cPanel Username; it will look something like: io58wikzfxyr 

Enter the cPanel Password. 

If you have not already written these down, go to Hosting in GoDaddy to locate your 

Username. You can also set or change your password there. Note the GoDaddy 

Username may be JaneDoe, but the cPanel Username is an automatically generated 12-

character code for security reasons. 



 
 

11. Click the blue connect icon in the upper left-hand corner of the NppFTP window (first icon). 

12. Choose your website from the connect icon dropdown. 

13. Open the file you want to upload. 

14. Click the green arrow upload icon in the NppFTP window in the upper right-hand corner to 

upload the selected file to your online host. 

 
 


