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In this project, you will create an Invoice database with the following features: 

 Four tables: Invoice, Invoice Details, Employees, Products. 

 Primary keys, such as such as EmployeeID that link corresponding records in the tables. 

 Default Values and Field Size Limits and Formats 

 Data validation 

 You will use the Form Wizard to create an invoice form  

 You will use the Query Wizard to create a query that calculates price times quantity 

 You then use the result of the query in a report you create using the Report Wizard 

 

Background Terms: 

 A Database is a collection of related objects that store, manage, manipulate, and retrieve 

information. A database can also be referred to as a collection of related tables that are 

linked by key fields, such as EmployeeID or InvoiceNumber.  

 Database objects are tables, queries, forms, reports, and macros. 

 Relationships are basically links that join tables based on key fields such as EmployeeID 

or InvoiceNumber.  

 Tables store the data in records (rows) and fields (columns). 

 Queries perform an action with the data in the tables, such as finding certain specific data 

based on criteria. The results of a query can then serve as a source of data for a report. 

 Forms are used for easily entering, displaying, and editing data. 

 Reports are a printed form of data formatted and organized to your specifications. 

 Macros are actions that you can use to automate tasks. 

 

The first form is shown below (a good form has one record on one screen in Columnar layout): 

mailto:winterf@scf.edu
http://faculty.scf.edu/winterf/0ClassFolders/1570Office/1GradingCriteria/Access_GradingCriteria.htm


 
 

The finished report is shown below (a good report shows multiple records in Tabular layout): 

 
 

Step 1: Create the Invoices Database   (Go to Top) 

 Start Access 

 Select Blank Database 

 Name the database Invoices.accdb 



 
 

Next, select where the file will be saved. 

 Click the folder icon to the right of the File Name 

The File New Database dialog box opens. 

 

Possible Problem: Unlike Microsoft Word and Excel, you can NOT resave or rename an Access 

database file while in Access. So pay special attention to what you name your file and 

specifically what folder or what drive you save it in. If you need to modify the file name or 

location, you can copy it, move it, or rename it in the Windows Explorer, but not in Access. 

 



 
 Browse to the desired folder and click OK 

The File New Database dialog box closes. 

 

 Creating Tables  (Go to Top) 

Tables store the actual data in a database. Typically, each set of related data is stored in a 

separate table. For instance you would have an Employees table for all of your employees 

and a Products table for all of your products. 

 Click Create 

The newly created database opens in Table Datasheet View. 

 Click View in the Views group of the Datasheet tab 

 Select Design View 

 

 
 



The Save As dialog box opens. 

 Type in the Table Name Employees 

 
 Click OK 

The Employees table within the Invoices database opens in Design view: 

 
By default, Access sets the first field as the Primary Key, names it ID and uses the AutoNumber 

data type.  

A Primary key is unique identifying field by which a table can be searched, sorted, or linked to 

another table. Example: an EmployeeID or ProductID. 

A Foreign key is a corresponding key field in another table that identifies records that are linked 

through the primary key. Example: a foreign EmployeeID key field in an Invoices table that links 

to employee information in the Employee table which has the Primary EmployeeID key field. 

 Change the name of the Primary Key field from ID to EmpID 

 Click in the Data Type column, click the list arrow, and select Text 



 
 Type in the Description 3 Characters – Employees Initials 

 In the EmpID Field Properties, enter 3 for the Field size and > for the Format 

 
 Enter LastName, FirstName, Address, City, State, Zip, and Degree 

 Assign each the Text data type 

Text comes up as the default data type for each subsequent field. 

 For the State field, enter the Description: 2 character abbreviation 

 In the State Field Properties, enter 2 for the Field size, > for the Format, and “VA” for the 

Default Value 

 After Degree, the next field is MOSCertified and has the Yes/No data type and the 



description: Microsoft Office Specialist Certified 

 Enter HireDate with the Date/Time data type 

 Enter BaseSalary with the Number data type 

 Enter Phone with the Text data type and the description: Home Phone 

 Enter Comments with the Memo data type 

 

Using the steps above create a Products table that includes the following fields: 

ProductID, ProductName, ProductDescription, and Price. 

 

Using the steps above create an Invoice table that includes the following fields: 

InvoiceID, InvoiceDate, and EmployeeID. 

 

Using the steps above create an InvoiceDetails table that includes the following fields: 

InvoiceID, ProductID, and Quantity. 

 

 Using the Lookup Wizard   (Go to Top) 

When you create your tables, use the Lookup Wizard for foreign key fields like EmployeeID 

and ProductID so that dropdowns will allow for quick data entry. In the end you will have a 

One-to-Many Relationship. There is one unique Primary EmployeeID key field in the 

Employee table that is related to many foreign EmployeeIDs key fields in the Invoices table. In 

other words, one employee can have many sales. 

 

In table Design View, choose the Lookup Wizard for the Data Type: 

 
 



 
 

 



 
 

 
 



 
 

 Setting Relationships   (Go to Top) 

After you define your tables and set up your Lookup Wizard, you must finish setting up your 

relationships. Relationships refer to how related tables in a database are linked or joined 

together by key fields (such as EmployeeID) to avoid data redundancy, to provide for easier data 

entry, to ensure data consistency, and to avoid potential errors.  

 

Choose Database Tools tab > Relationships. Right-click on the line connecting related tables 

through their key fields to enforce Referential Integrity to make sure there are no Invoice Detail 

records without matching Invoices (you cannot have children without parents). 

 

 
 

Possible problem: If there is not line connecting the EmployeeIDs from the Employees table 

and the Invoices table: drag the EmpID Primary key from the Employees table to the 

EmployeesID Foreign key in the Invoices table. 

 



 
 

When done your relationships should look like this, with each many table having a 1-to-Many 

(1 to ∞) Relationship with the other tables (1 employee can have many sales): 

 
 

If your Lookup Wizard and 1-to-Many Relationships are set correctly, data entry with your 

tables becomes much easier and more powerful with dropdowns: 

 
 

 



Using the steps above use the Lookup Wizard to link the InvoiceDetails table to the Products 

table through ProductID. 

 

Once you have set up your Relationships properly and used the Lookup Wizard to link to related 

tables it is much easier to create good forms and subforms for data entry.  

 

 Creating Forms   (Go to Top) 

A Form is used to enter, edit and delete information stored in a table. Forms are more attractive 

and easier to use than tables. We will build two forms. The first is a basic Employees form. The 

second is an Invoice form with a Subform (an itemized detail form within a main form). 

 

 Click More Forms in the Forms group on the Create tab 

 Select Form Wizard 

 
 If necessary, click the dropdown arrow next to the Tables/Queries box and select the 

Employees table. 

 Click the [ > ] button to move EmpID, LastName, FirstName, Address, City, State, Zip, 

Phone, and Comments to the Selected Fields list 



 
 Click Next 

 
 Leave Columnar selected and click Next 

Note: a good form has one record on one screen in Columnar layout 

 Choose a style and click Next 

 Name the form Employees of Your Company Name and click Finish 

The new form opens in Form view: 



 
 

 Building Queries   (Go to Top) 

A Query can be used to find and arrange specific information and do on the fly calculations. We 

will create two queries. First we will create a simple Employees Query to list only Employee 

names and addresses.  

 

 Click Query Wizard in the Other group on the Create tab 

 
 

The New Query dialog box opens: 



 
 With Simple Query Wizard highlighted, click OK 

The Simple Query Wizard dialog box opens. 

 
 If necessary, choose Table: Employees from the drop-down Tables/Queries list 

 Click [ > ] with EmpID highlighted to move it to the Selected Fields list 

 Repeat for LastName, FirstName, Address, City, State, and Zip 

 Click Finish 

The new Employees query opens in Datasheet view: 



 
 Click View in the Results group on the Home tab 

The Employees query opens in Design view: 

 
 In the Criteria row for State, enter “FL” 

 
 

 Click Run in the group on the Design tab 

 
Only records having a State value of FL are included in the results: 



 
 

Now let’s create a Query that computes Price times Quantity that we can then use in a Product 

Sales by Employee Report. 

 Click Query Wizard in the Other group on the Create tab 

 Select Simple Query Wizard 

 Choose Table: Invoices from the drop-down Tables/Queries list 

 
 

 With InvoiceID highlighted in the Available Fields list, click the single arrow  to move 

it to the Selected Fields list 



 
 

 Select the Products table from the Tables/Queries list 

 Add ProductName and Price to the Selected Fields list 

 From the InvoiceDetails table and add Quantity to the Selected Fields list 

 
 Click Next 

The dialog box offers the choice between including every field from every record or a 

summary with simple calculations. 

 
 Select Summary 

Summary Options becomes available. 

 Click Summary Options 



 

 
 

The Summary Options dialog box opens. 

 Check the Sum box for the Quantity field; then click OK 

 
 

 Click Next after the Summary Options dialog box closes 

 Change the title of the query to PriceXQtyQuery 

 Select Modify the query design. 

 



 Click Finish 

The query opens in Design view. You can rearrange the tables so the relationship lines 

are more easily seen and resize the grid columns to show the entire contents: 

 
 In the Field line of the first empty column of the design grid enter 

TotalPrice: Price*Quantity 

and tap Enter 

 

 
 Click the Run button in the Results group on the Design tab 

The query displays in Datasheet view with the newly calculated field: 



 
 Save and close the query 

 

 Creating Reports   (Go to Top) 

Reports are used to display the information from a table or the results form a query in the 

desired field order, showing only the desired fields. Let’s create a report based on our 

PriceXQtyQuery. 

 

 Select Report Wizard in the Reports group on the Create tab 

 
 The Report Wizard dialog box opens 

 In the Employees table, add EmpID to the Selected Fields list 

 
 From the Invoices table, add InvoiceID and InvoiceDate to the Selected Fields list 

 From the new PriceXQtyQuery, add ProductName, Sum of Quantity, and TotalPrice 



 
 Group level by EmpID 

 
 

 Sort by InvoiceDate 



 
 Click the Summary Options button 

 Check the Sum box for TotalPrice and click OK 

 
 Choose Stepped layout and Landscape orientation 



 
 Select a Style (Note: Microsoft Office 2007 has a bug that may push the Grand Total or 

Sum(TotalPrice) summary off to the far right of the page so that it may not be viewable. 

If one style does not work try another. It is because of this bug that we must print this 

report in Landscape instead of Portrait. We can resize the report with and height later.) 

 
 Name the report Product Sales by Employee, select Modify the report’s design, and click 

Finish 

The report opens in Design view: 



 
The Report Wizard generates a basic report that you can customize for your specific company. 

(Note the Microsoft Office 2007 bug pushed =Sum(TotalPrice) off to the far right of the page 

so that it would not be viewable in Portrait view.) In the following steps, you add your company 

name to the Report Header, rename the Sum of Quantity label, line up the totals, and move the 

page number. 

 Hover the pointer over the vertical ruler near the bottom of the Report Header and drag 

the bottom edge of the Report Header to make it big enough for the company name 

 Click and drag the report title down to make room for the company name 

 
 

Possible problem: When you try to click and drag the label, after you click it you cannot drag it, 

you can only edit the text. 

Solution: Do not release the mouse button after clicking the label. Click and drag in one step. 

 Click the Label tool in the Controls group on the Design tab 

 
 

 Drag a new label above the title 



 
 Type in your company name and then click in an empty area of the report 

 Click the label to select it 

 Use the tools in the Font group to format the company name 

 
 

 In the EmpID Footer, select the “Summary for” text box and delete it 

 Click TotalPrice in the Detail section 

 Press and hold the [Shift] key and click =Sum(TotalPrice) in the EmpID footer and 

Report footer 

The three total fields are highlighted 

 
 Click the Align Right tool in the Control Alignment group on the Arrange tab 



 
The three total fields are now aligned on their right edge. 

 
 Open the Property Sheet, if necessary, by clicking Property Sheet in the Tools group on 

the Design tab 

 
 With the three total fields still highlighted, set the Format to Currency 

 



 

 In the Properties Sheet, adjust the Page Number field in the Page Footer and change its  

Width and Left properties to the best settings. 

 

 Open the report in Report View (Home tab > View > Report View) 

Note 1: A good report shows multiple records on one page in Tabular layout. 

Note 2: Notice that it displays both Subtotals for each employee and a Grand Total for 

everyone. 

Note 3: Notice the spaces in the headers, as in Invoice Date and Product Name (instead of 

InvoiceDate and ProductName). These spaces are added in Design View. Also in Design 

View the column widths were adjusted to give the best presentation. 

 

 
 

 

 


