
Dynamic Web Templates

In the last chapter, we started creating an identity for your website. Keeping those branding
elements consistent from page to page is helped by the use of an external stylesheet. But a
stylesheet cannot prevent changes to the page caused by adding or removing content.

This is where templates come into play. A template provides the common HTML used on
all of your website’s pages. Templates can be divided into three types. The first is little more
than a reference page that you save under a new name to create your new pages. Many of the
commercial templates you can buy are of this type.

The second type is a server-side template where content is inserted into sections of a web
page when the browser requests the page. You see this type of templating in content manage-
ment systems. Master pages are a variation of the server-side templates we will be covering in
Chapter 13.

The third type of template is a Dynamic Web Template (DWT). When you use a DWT areas
of the page that need to remain unchanged from one page to another are locked. At the same
time, your content areas can be edited without worrying about breaking the common sections
of your page. Unlike the other two types of templates, no processing or specific technology on
the server is required. This means you can use a DWT in any hosting environment, even those
that do not support scripting.

DWT Overview
DWTs started out as Dreamweaver Web Templates but proved to be so useful that other com-
panies jumped on the design-time template bandwagon. The first Microsoft web program to
support them was FrontPage 2003.

What Does a DWT Do? 
Often, when you create a web page, many areas of the page will not change from one page 
to the next. Generally, these include the masthead, footer, and primary navigation menu.

This is where a DWT comes in—with locked areas that will stay the same from page to
page within your site and editable regions where the individual page content will go. When
you create a DWT, the entire page is locked. Then, you select the areas on the page that will
change from page to page and mark them as Editable Regions. 

233

C H A P T E R  9



One of the primary benefits to using a DWT is consistency between the pages on your
site. When you apply the DWT to a page or create a new page using the DWT, you cannot
accidentally change, move, or break the parts you want to remain the same throughout 
your site.

This safety net is only one of the benefits of a DWT. Another benefit comes when you want
to make a global change such as adding another section to your menu or updating copyright or
contact information. With a DWT, any change made to the locked regions of the template will
be propagated to every page that uses that template.

If, for example, all the pages were marked with “copyright 2006”, and it is now 2007, you
can make the change to “copyright 2006-2007” with a simple edit of the template. Once you
save the template, all the pages will be updated.

In the preceding example, you may think, “What is the big deal? Using Find and Replace
will do the same thing, so why bother with a template?” The copyright example is a minor
change, but you can make far more substantial changes to your site without directly touching
the code of a single HTML page. Assume, for example, that your site is using a two-column
layout with a top navigation bar, and you now decide that you want to move the navigation to
a side column. Or maybe you have decided to add a third column for Google AdWords, other
sponsorship, or advertising information. You would make the necessary changes to your
DWT; then, when you save, all of your pages will be updated to reflect your new additions 
or subtractions.

■Caution DWTs are strictly a design-time feature. When you make a change to your DWT, you must
republish every page that uses it.

Creating the DWT
I will be using the page we created in Chapter 8 to create the DWT; you can follow along with
the same page or use one of your own.

The first step in creating a DWT is to open the page you will be converting to a DWT in
Expression Web. Then go to File ➤ Save As, and select DWT from the drop-down menu as
shown in Figure 9-1. 

Use your site name for the DWT to help you distinguish one DWT from another. Here, I
saved it as few-site.dwt. I recommend saving it in a new folder called Templates. While it does
not matter to Expression Web where you save your DWTs, putting your templates in a Tem-
plates folder will make it easier to keep track of your templates as your site grows. Normally, I
would tell you to use lowercase folder names, but in this case, I use the uppercase “T,” because
Dreamweaver always uses a capital T for the template folder, and Expression DWTs should
work in Dreamweaver. DWTs are design-time tool and do their updates in Expression Web. As
a result, it is not necessary to upload your DWTs.

After you have saved the file as a DWT, code for an editable region called doctitle will be
added to the <head> section. In Code view, your page looks like Figure 9-2.
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Figure 9-1. The open page you will be converting to a DWT

Figure 9-2. Only one editable region for the page title is created by default.

This is the only editable region inserted in a new DWT at the time it is created. In order to
use your new DWT, you must add more editable regions in the <body> section of the page. You
should also add one or more editable regions in the <head> section.
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Adding Editable Regions
Our next step will be to add an editable region to the <body> area of the page where our page
name or <h1> will go. The easiest way to do this is to highlight the area you want to be editable.
In our few-site.dwt, that would be the main content section below the menu. Select all the
content that you will be replacing on your pages in the main section. Next, right-click and
select Manage Editable Regions, as shown in Figure 9-3.

Figure 9-3. Select Manage Editable Regions to add content regions.

This brings up the Editable Regions dialog box (see Figure 9-4), which adds the editable
region code to your web page.

Here’s a bit of information on each section:

• Region name: Give a bit of thought to the naming convention you decide to use. Using a
consistent naming convention will make it easier for you to move from one template to
another in the future.

• Other regions on this page: This section shows you the names of other regions on the page.
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Figure 9-4. Type in the name for your region to activate the Add button.

You can only add editable regions when you have highlighted a section in Design view. 
You can remove regions at any time from this dialog box, which can also be launched

from the menus by using Format ➤ Dynamic Web Template ➤ Manage Editable Regions.
If you are not sure where an editable region is on your page, select the region name to

activate the Go To button, which highlights the editable region on your page. 
Whenever your cursor is in an editable region, that region will be outlined in orange, and

the region name will appear at the top left of the region. In Figure 9-5, you can see that I have
added an additional editable region to the left-side column. 

Figure 9-5. Editable regions will always be outlined in orange by default.
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The regions in the DWT are now as follows:

• doctitle: Surrounds the <title> element

• sidecol: A side column, which in this layout is on the left (the orange outline is difficult
to see in this image)

• content: The main content section

Exercise 9-1. Creating Editable Regions in the Body Region

In this exercise, you will create editable regions in the body section of your DWT:

1. If you have not done so, open the page that you wish to turn into a DWT, and select File ➤ Save As and then
select Dynamic Web Template (*.dwt) from the Type drop-down menu. Click the Save button.

2. Next, look at your web page, and decide which elements on the page will change from one page to the next
within your site. There should be at least two sections of the page that you will want to change:

• The page name or section of the masthead that tells the visitor about the contents of the web page

• The main content area, where the content unique to each page will be placed

• Possibly additional areas of the page you want to make editable, if you have a multiple column layout

3. Once you have decided where your editable regions should be placed for each region, highlight the first area
to become part of your DWT’s editable regions in Design view.

4. Right-click the highlighted area, and select Manage Editable Regions.

5. Type in the name of your choice—make sure it is descriptive so when you are creating new pages in the
future, you will know what should go in each editable region.

6. Click the Add button. Once you see your new region in the “Other Regions on this Page” area, close the
dialog box.

7. Repeat steps 3 to 6 for each of editable regions you wish to add to your DWT.

8. Save your DWT.

You now have a DWT that can be used on your website to keep the look and feel consistent among pages.

Editable Regions in the <head> Section
So far, all of the editable regions we have added were in the visible part of the web page. This is
because in Expression Web, there is no WYSIWYG way to add editable regions in the <head>
section of the page other than the default doctitle region; see Figure 9-6.
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Figure 9-6. More that one editable region in the head section of the page is a good idea.

The default doctitle editable region surrounds the <title> element, which means that
any <meta> elements, page-level styles, or scripts must be in that same editable region. Notice
in Figure 9-6 that the stylesheet link is below the doctitle editable region. This can prevent
page-level styles from being applied under CSS rules of inheritance. To ensure that your page
level styles maintain their priority, you need to add another editable region below the
stylesheet link in the <head> section of your page.

Exercise 9-2. Adding an Editable Region to the Head Section

The only way to add editable regions for <meta> elements or page-level scripts and styles is to copy and paste
the template code and manually change the name of the editable region. Use the following steps to add an
editable region to the head section of our example:

1. Add a metadescription to the page before creating your new editable region by right-clicking anywhere on
your page and using the Page Properties dialog box, shown in Figure 9-7.

Figure 9-7. Add your site meta-tags to the DWT before you add editable regions in the
<head> section.
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2. Check to make sure that when Expression Web added your <meta> tags they were put where you want
them to be. You also will need to decide whether or not you want two separate editable regions, one for
<meta> elements and another for style and script blocks. Whether you have one region or two is a matter of
personal preference. If you choose to have separate regions, you can put the <meta> elements between the
<title> and the stylesheet link. My preference is two separate regions, so I’ve put the <meta> elements in
with the <title> element and have only one additional editable region in the <head>.

3. Highlight all the code starting with <!-- #BeginEditable "doctitle" --> through <!--
#EndEditable --> paste it just above the </head> element. Next, in the new copy, replace the <title>
and <meta> elements with an HTML comment using the keyboard shortcut of Ctrl + / (or using the menus:
Edit ➤ Code View ➤ Insert Comment) as a placeholder. Then, double-click doctitle to rename the second
editable region instance headblock.

4. In Figure 9-8, you can see the headblock region that was just created.

Figure 9-8. A <head> section with two editable regions

Your Editable Regions dialog box should now look like the one shown in Figure 9-9.

Figure 9-9. Complete list of available editable regions

5. Save your DWT.
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Now that you have created a DWT, the next step is to attach the DWT to web pages that
your visitors can view. DWTs will display when you use Preview in Browser from Expression
Web but usually do not display if you try to view the page on your live site.

Attaching DWTs to Your Web Pages
A DWT must be attached to your web pages before the DWT can manage the common content
and the look and feel of your site. In Exercise 9-3, you will attach the DWT you created in the
previous exercise to existing pages, and in Exercise 9-4, you will create new pages directly from
the DWT.

We will begin with attaching a DWT to an existing page.

Exercise 9-3. Applying a DWT to an Existing Page

In the last chapter, we created new, empty HTML pages when our menu was created. We will use one of those
pages to apply the DWT you created in Exercise 9-2 to an existing page with no content:

1. Open the about.html page that you created in Chapter 8. The page will be without a title or content, as
shown in Figure 9-10.

Figure 9-10. Pages created using the Edit Hyperlink dialog box have no content.

2. To attach a DWT to an existing page, you use Format ➤ Dynamic Web Template ➤ Attach Template to page,
which will bring up the Attach Dynamic Web Template dialog box, shown in Figure 9-11; choose the tem-
plate created in Exercise 9-2. Click Open or double-click the DWT you want to attach.
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Figure 9-11. Select the template you want to apply to your page.

3. Selecting the template may bring up the warning shown in Figure 9-12 if you have a doctype or server-
side scripting in the page you are applying the DWT to. If all you have is a doctype, it is safe to ignore the
warning. If you have server-side script, make sure you have a backup of the page, since in some cases,
server-side scripting may be removed when applying a DWT.

Figure 9-12. Applying a DWT to a page can remove scripting or other <head> elements.

4. Expression Web will also notify you that the page is being updated, as shown in Figure 9-13.

Figure 9-13. Whether the warning appears or not, you should always get the processing box.

5. Save your page.

You page should now look just like the original DWT, since there was no content on the page to replace the default
editable region content.
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Once you have attached your DWT, you will be able to replace the content inside of the
editable regions, outlined in orange, but you will not be able to change the content outside of
your editable region. Instead, as shown in Figure 9-14, your cursor will indicate that the region
is not editable.

Figure 9-14. The following symbol will appear when you are over a locked portion 
of the template:

Make sure that you replace the default template content with content that is appropriate
for the page.

■Note You can also apply a DWT to an existing page by dragging and dropping the DWT file on to an
existing page.

Exercise 9-4. Creating New Pages from Your  DWTs

To create a new page from the DWT, use one of the following methods:

1. Use File ➤ New ➤ Create from Dynamic Web Template, as shown in Figure 9-15, and save the file in the
location of your choice.

Figure 9-15. Creating new pages with a DWT that is already attached.
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2. Or, you can start with a new blank page, created by double-clicking the new page icon, as shown in
Figure 9-16.

Figure 9-16. Double-clicking the new page icon will create an HTML page.

a. Double-click the new page icon on the format tool, which opens an empty blank page. Save it with 
your file name in the location of your choice before you go any further. Save the page with a name that
reflects the contents you will be adding to the page. By saving the file before you add the DWT, your
image and other file location references will be correct when the DWT is applied.

b. Drag the DWT from the file list, and drop it on the opened page to apply the template to the page and
give you a dialog box that tells you the page was updated, as shown in Figure 9-17.

c. Save again before you begin adding content.

Figure 9-17. The links.html page now has the DWT applied.

3. The final method for creating a new page using an existing DWT is to open a new blank page and use 
Format ➤ Dynamic Web Template ➤ Attach Dynamic Web Template, which will apply the template to the
open blank page. This will give you the same dialog box as the drag method (see step 2).
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Attaching a DWT to an Existing Page
In many cases, you will have an existing page or site that you will want to use with a DWT. In
this section, we will apply the DWT to an existing page on the site, one that already has sec-
tions of the page duplicated in our template.

Before making a major change to your site, you may want to back up the entire site by
publishing it to a new location on your hard drive. Even if you have a complete site back-up
before you start to convert any existing page with content, make a copy or save the page with 
a new name so that you have an easily accessible backup of the file if you make an error while
converting it.

Preparing an Existing Page for a DWT
We will use the structural.html page from the earlier chapters to demonstrate how to apply 
a DWT to an existing page that already has a masthead and other styles applied. Follow these
steps to prepare the page for the DWT:

1. Start with a back-up of your structural.html page, as shown in Figure 9-18.

Figure 9-18. Remove the content that is contained in the template’s locked regions.

2. Now that you have a copy, open the file you want to convert. (In your real web site, you
would use the original web page, not the copy.) You will need to remove any content
that is duplicated in the locked regions of the template or move it to other sections of
the page. Otherwise, you will end up with a page that looks like Figure 9-19.
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Figure 9-19. Notice the menu is duplicated as is the copyright information from the footer.

As you can see in Figure 9-19, the masthead and other areas were repeated inside our
main content area. The repeated sections look a bit different, because they do not 
contain all of the same format information. Since an ID is only to be used once on the
page, Expression Web has renamed the duplicate divs by adding a “0” after the ID, as
illustrated in Figure 9-20, where masthead div was renamed footer0.

Figure 9-20. Duplicate IDs are not allowed, so Expression Web will add a number to 
prevent duplication.

Notice that the areas locked by the template are highlighted in yellow in Code view. If
you have form fields or other items with a name attribute, those too will be changed by
adding a “0.”
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3. To avoid this problem, before you apply the DWT remove the original footer div com-
pletely, click the section that needs to be removed, select the <p> from the Quick Tag
bar, and press the Delete key.

4. If you need to keep the content of an element such as a div while removing the div con-
tainer, select it from the Quick Tag bar, as shown in Figure 9-21, and select Remove Tag.

Figure 9-21. You can remove the HTML tag without deleting the contents from the 
Quick Tag bar.

5. Repeat steps 3 and 4 with any of the remaining divs you are replacing with content
from your DWT. Save your page.

Applying a DWT to a Page with Content
Now that the page has the content that will be replaced by locked regions in the DWT, it is
time to apply the DWT. Your page should look like the one shown in Figure 9-22.

Figure 9-22. Content in the <head> section will be replaced.
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■Note All style and scripting in the <head> section will be replaced, which is another reason to make a
backup before you apply your DWT.

Use the following steps to apply your DWT to a page with existing content:

1. To attach a DWT to an existing page with content you can employ the same methods
used to apply one to a new page. Whether you drag the template from the folder list
and drop it on the open page or use Format ➤ Dynamic Web Template ➤ Attach Tem-
plate to page, if there is more than one editable region within the body of the DWT,
Expression Web will select the first editable region in the body section for your content.
If that is not where you want the content to go, you will need to tell Expression Web
where to place the body content, as shown in Figure 9-23.

Figure 9-23. Use the Modify button to change the default Editable Region to the region 
of your choice.

■Note This may also bring up the warning shown in Figure 9-12 if you have a doctype or server-side
scripting in the page. The same advice applies: if it is a doctype, it is safe to ignore the warning. If you have
server-side script, make sure you have a backup of the page, since in some cases, server-side scripting may
not be compatible with a DWT.

2. By default, Expression Web selects the first editable region in the body of the page as
the place to put all the content. In this case, it has picked the side column region as the
default, but you would not want to have the entire page contents in the sidebar. At this
stage, there is no way to choose what part of the text will go into which region. You can
only choose one region to place all the body text into. Use the Modify button to select
the content region, as shown in Figure 9-24.
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Figure 9-24. Generally, you should choose your main content area when you first apply
your template.

3. Since the majority of the content should go into the main content region, we will need
to change from the default to the one we wish to use by selecting it from the New
Region drop-down menu.

Moving Content Between Editable Regions
Now that the template is applied, the page in Design view has all of the content in the main
editable region and should look like the one shown in Figure 9-25.

Figure 9-25. The page <title> and <meta> elements were moved like the page contents to an
editable region in the DWT.
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The <meta> and <title> elements were preserved when the DWT was applied, but the
style blocks in the <head> section were replaced by the template styles. If you have page-level
styles that you need to keep, make sure that you have a backup before you apply the DWT.

Notice that the editable regions that were not mapped to the body content have the same
text as in the DWT. To move the content to appropriate places, use normal editing procedures
such as cut and paste. Make sure that you get all the HTML tags when you move them around.

■Tip To avoid the possibility that an editable region will collapse and make it difficult to add content 
to that region, make sure that there is at least a nonbreaking space (&nbsp;) or comment inside every
editable region.

After the Template Has Been Applied
Once you have moved your page content to the appropriate editable regions, the page will
look like the one shown in Figure 9-26 when viewed in a browser.

Figure 9-26. Your page now matches your new site design and will be updated when changes are
made to your DWT.
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Editing a DWT
Once you have a DWT, there will be occasions where you will need to change some of the
locked areas. One typical reason is to add or remove items from the navigation area. When we
created our DWTs, only some of the links would take users to real pages; others were just place-
holders in the menu. In the next exercise, real links will be added.

Editing a DWT is no different than editing any other page with one slight caveat—only
changes outside the editable areas will be updated on the pages attached to the DWT.

Exercise 9-5. Updating Pages Attached to a DWT

In this exercise, we will edit the links in the DWT’s menu and update all the pages attached to the DWT using the
following steps:

1. The menu in our DWT still has null links. Now that we have created pages for the rest of our website, we
can update the links. To update links, open the DWT, and edit it as you would any HTML page. In this case,
we would be adding real links to the menu, as shown in Figure 9-27.

Figure 9-27. Edit the DWT as you would any HTML file.

2. Once you have made the changes to the DWT, save it. This time, instead of the update confirmation prompt,
you will receive a dialog box, shown in Figure 9-28, telling you how many pages are attached to the DWT
and asking if you would like to update them.
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Figure 9-28. You will have visual confirmation of the number of pages to be updated.

3. To apply the updates, click Yes. If you have more changes you wish to make to the DWT, you can click No to
wait to apply the changes until you have completed the ones to your DWT.

Once you have applied the pages you will get a notice that files have been updated, as shown in Figure 9-29. If,
for some reason, a file could not be updated, you will be notified of that as well.

Figure 9-29. The number in the updated pages notification should match those in Figure 9-28.

If the number of pages in Figures 9-28 and 9-29 do not match, place a check mark in the Show Log box to find
out what pages did not update.

Detaching a Page from a DWT
At times, you may not want to update a page attached to a DWT to reflect changes to your
template; pages that are being archived and replaced with updated information would be one
such case. To avoid accidentally updating those pages in the future, you should detach the
page from your DWT. When you detach a page from its template, the look and feel remain the
same; only the template mark-up is removed which prevents it from being updated to reflect
changes to the DWT.

With the page to be detached open, select Format ➤ Dynamic Web Templates ➤ Detach
from Dynamic Web Template to detach the page so that the entire page becomes editable
again, as shown in Figure 9-30.
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Figure 9-30. Detaching a template is a one-step operation.

When your page is viewed in either Design view or your browser, the page should look
exactly the same as it did when attached to the template. The only difference is that it will no
longer be updated when changes are made to the DWT.

Changing the Attached DWT 
There will be occasions when you will want to change the DWT that is attached to your web
page, perhaps in the case of a major redesign from one type of layout to another. For the
purpose of showing you how to change the DWT that your page is using, I’ve created a sec-
ond DWT with an additional editable region named ads. The content region name is now
maincontent. This DWT was saved as few-site3.dwt. If you want to follow along, you can
either add another editable region to your existing template or download few-site3.dwt
from http://foundationsofexpressionweb.com/exercises/chapter9.

Follow these steps to change the DWT attached to your page:

1. Begin with the page shown in Figure 9-26. Drag the new DWT from the Folder List, and
drop it on the open page in Design view. Since there is already a DWT applied to the
structural-bak.html page and the editable regions do not match exactly, we are pre-
sented with the opportunity to determine where the content of each region should go,
as shown in Figure 9-31. As when you initially applied the first DWT, by default, Expres-
sion Web will put the unmatched content in the first editable region inside the body
element.
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■Note You can also change the DWT attached to your page by using Format ➤ Dynamic Web Template ➤
Attach.

Figure 9-31. Use the Modify button to remap the current content section.

2. Using the Modify button will allow you to choose the correct editable region to move
your content to in the new DWT.

3. Expression Web will update your page when you click the OK button.

Once the template change has been completed, you will see the update confirmation box
shown in Figure 9-23. With the new DWT applied, our page now looks like the one shown in
Figure 9-32.

Figure 9-32. The new region for advertisements or notices is ready for content.
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Summary
Dynamic Web Templates (DWTs) are one of the features in Expression Web that will help you
manage your website and keep a consistent look and feel throughout it. The primary advan-
tage of using DWTs is that they are server independent, so they can be used on a wide variety
of servers without regard to which, if any, server-side processing is available to you.

DWTs present a slight disadvantage when compared to templates processed by the server,
since you have to upload all the files that are changed when you edit your DWT, but if you use
the synchronize button when you publish, Expression Web will ensure that all changed pages
are published.

In the next chapter, we will add interactivity to our website by creating forms.
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