
Taking Your First Steps

Before you begin you must create a local website.
In this chapter, you will get started by creating a local website and a home page for your

site. Along the way, you will be learning the menus and features in Expression Web that will
make working on your site easier.

Creating a Local Website
Before you create a single web page in Expression Web, you need to create a local website.
Otherwise, Expression Web cannot manage links among your web pages and items you link to
in your web pages. To begin, you will create a new one-page website. The best way to do this is
from the File menu.

File Menu
In the File menu, you have all the normal functions you expect to see on any Windows program
with some others that are specific to Expression Web (see Figure 2-1).

Figure 2-1. The File menu contains web-specific options in addition to the standard Windows 
file options. 25
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There are several items of special interest to you on the File menu:

• New: Choose the type of new web page or local website you want to create.

• Preview in Browser: See what your page will look like to your visitors and not just in
Expression Web.

• Publish: Move your web pages from your local computer to your web host.

New
Create new websites and new pages with the New option (see Figure 2-2).

Figure 2-2. The New option is the one that you will use to create your first website.

To create a local website, you would use File ➤ New ➤ Web Site. For now, you will be
concerned only with the New Page and New Web Site options. Later in this book, you will be
using the New CSS options. The first exercise in Expression Web is to create a local website
(see Exercise 2-1).

■Caution Always work in a local website, never on just an individual web page in your site!

WHY A LOCAL WEBSITE IS NECESSARY

A website is a collection of pages with interrelated links. One of the strengths of Expression Web is the ability
to manage those links, but it cannot manage links in a vacuum. When you create and use a local website to
hold your web files, Expression Web will maintain metadata showing how the files are related to each other.
This means that you will be able to move files from one folder to another and let Expression Web manage the
relative file paths so you can organize your files and folders to match the needs of your site.
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Exercise 2-1. Creating a New Site and Page

In this exercise, you will create a new website and a web page.

Creating a New Site

1. Create a new blank website using the File ➤ New ➤ Web Site option, as shown in Figure 2-3.

2. In the dialog box that appears, select the Empty Web Site option from the center column.

Figure 2-3. General website choices include a one-page website, an empty website, and the
option to import a website from the Internet or another location on your hard drive.

■Note You should change the location where your new site will be created by either typing in the file path
or using the Browse button to go to the folder you want to create your new site in. Once you are in the folder,
add the name of the new website to the end of the file path in the dialog box.

3. After you change your site location and name, click the OK button. You will see the site appear in the Folder
List task pane (see Figure 2-4).

Figure 2-4. The file path to your newly created website will appear at the top of your 
Folder List.
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Creating a New Web Page

1. Click File ➤ New ➤ HTML to create a single new web page. I recommend using Split view whenever you
are working on your web pages so that you can see how Expression Web is writing your code.

■Note Do not select File ➤ New ➤ Page, as shown in Figure 2-2. This opens the dialog box to the Page
tab, shown in Figure 2-3, instead of the Web Site tab. You will examine the Page tab options later.

A page will be created with the code, as shown in Figure 2-5.

Figure 2-5. The default web page created by Expression Web

2. Right-click the Design view section of the document window, and select Page Properties. The default page
name will be Untitled with a number that will increment with each new page, as shown in Figure 2-6. Change
the page title to My Home Page, which I used in my example, or the name of your choice if you prefer.

Figure 2-6. The Page Properties dialog allows you to add a page title and other elements 
in one place.
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The page description is displayed by some search engines when your page is returned in response to a
search, while keywords may help other search engines categorize your pages. If you choose to use these
elements, keep the text to less than 200 characters.

3. Add one line of text in Design view that says, “This is my first web page using Expression Web.”

■Note Your web host will have a default document name, usually index.html or index.htm, which will
be served when a person types in your domain name.

4. Use File ➤ Save to bring up the Save As dialog box, shown in Figure 2-7. By default, Expression Web will
name the file using the page title, replacing the spaces with underscores.

5. Change the name by typing over it in the “File name” field. For the exercises in this book, I will be using
index.html as the default page. If your host uses a different name, please substitute it whenever you 
see index.html.

Figure 2-7. The Save As dialog box will appear when your page has not been previously saved.

6. Your folder list should now include index.html. The final step in this exercise is to use F12 to preview your
page in your default browser.
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FILE AND FOLDER NAMING

The name of a file or folder is determined, in part, by the type of server you are using. Linux or other Unix-
based servers make up the majority of production web servers and backbone servers such as the Domain
Name System (DNS), which resolves domain names, and gateway computers, which manage the connection
between you and your ISP’s connection. These servers are case sensitive and, unless you are on a closed
intranet, your request for a web page will certainly pass through a Linux server somewhere between your
computer and the hosting web server.

You should always have a page with the name your host uses as its default in every folder on your site.
Otherwise your visitor may get a list of all the files in your directory.

Use Meaningful File and Folder Names

Not only does using about_us.html or green-tank-shirt.html make it easier for you to know what 
is on which page of your site, but meaningful names can help your site fare better in search engines.

While Windows servers are not case sensitive, XHTML and XML are, so you might as well start with
good practices. My recommendation is to use all lowercase letters in file names and to use hyphens to sepa-
rate words as needed.

Do Not Use Spaces

Because Linux servers will break a URL at a space, most web servers and browsers encode a space as %20,
but this is not foolproof. To be safe, never use spaces in your file names. Unix-based web servers and e-mail
clients will break the URL at a space, which can cause your links to return a 404 (file not found) error.

HTM vs. HTML

What is the difference between the file extensions .htm and .html? The fact that both exist is a legacy from
DOS, which had a limitation on file names of 8.3, that is, an eight-character file name plus a three-character
file extension. Since DOS and by extension Windows 3.11 or lower could not understand the four-character
.html extension, people using DOS or Windows who wanted to be able to edit or create web pages needed
to use .htm.

Viewing pages with the .html extension was not typically an issue, since DOS browsers would drop
anything after the first three characters.

It does not matter which extension you use, but pick one and be consistent.

Pick a Case

How many separate pages are there in the following list?

• AboutUs.html

• Aboutus.html

• ABOUTUS.HTML

• aboutus.HTML

• aboutus.html
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The answer depends on what type of server we are on. On Windows, there is one file, but on a Linux
server, there are five—each and every one of these files is different. If the browser requests aboutus.html
and only ABOUTUS.html resides on the server, your visitor will get a 404 error. Since we are working on
Windows with Expression Web, which is not case sensitive, it is smart to pick one naming convention and
stick to it.

I recommend using all lowercase. Because XHTML is case sensitive, you will be working with lowercase
element names (required) and lowercase attributes (also required), so you might as well continue the theme
with lowercase values.

If you happen to come from a programming background where camel case (multiple words run together
with the first letter of each inner word capitalized like multipleWords) is the norm, go ahead and continue
to use camel case, but make sure you are consistent.

Be Consistent in Your Naming Conventions

Being consistent in your naming conventions means more than being consistent with the case of your file
and folder names. It also means keeping the names of folders and pages you will create in more than one
website the same; don’t use images in one and pictures in another. I like to name the primary stylesheet
for a website with the site name. For example, if I am searching for a specific stylesheet, I can tell at a glance
that foundationewd.css is the stylesheet for foundationewd.com and not have to guess to which web-
site site.css or style1.css belongs.

By the same token, I will know that a page named contact-us.aspx is a contact page while
faq/sales.html will have the frequently asked questions page for sales.

The road to 404 errors is paved with inconsistencies.

■Note You should never work on web pages in Expression Web outside of a website, or your links may not
resolve correctly when you move or add files to your website.

Preview in Browser
No matter how good or bad a page looks in Expression Web’s Design view, it may not look the
same when viewed in the browser. If the browser is standards compliant, your page should
appear the same as in Design view, but we all know that no browser is 100 percent compliant.
Every browser has one or more display quirks. In part, these quirks exist because the W3C
specification is not detailed in every instance. For example, to determine the width of a con-
tainer, should the width include the amount of padding, the thickness of the border and
margin, or just the content? This decision was left to the browser makers. Needless to say, the
browser makers did not all choose the same method; as a result, it is always best to test in a
real web browser.

To preview in your default web browser at your default browser settings, all you need to
do is use F12. By using the Preview in Browser fly-out menu (found in the File menu), you
have many more choices, as shown in Figure 2-8.
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Figure 2-8. Expression Web lets you choose the browser and resolution for viewing.

Expression Web will always look for Internet Explorer and will add it to your preview list
when it is not the default browser. Since my default browser is Firefox, I see Internet Explorer
listed as a separate option. Although I have Opera installed on my system, it is not my default
browser, so Expression Web did not add it to my browser list. Other browsers you have installed
will need to be installed using the Edit Browser List option (shown in Figure 2-9) at the bottom
of the fly-out menu.

Figure 2-9. Make sure that you have the major browsers for your operating system installed, and
add them to your preview list.

Adding browsers is as simple as clicking the Add button, following the dialog box prompts,
and navigating to the location of the browser.exe file to add the browser to your list.

Window Size

You may have noticed that when you choose to preview in one or multiple browsers, you can
also select from common screen resolutions for previewing your pages. Your web pages may
look different when viewed at different screen resolutions, but your site still needs to look
good regardless of the browser size.
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I would recommend that you preview at 800×600 and 1024×768. Very few people are using
640×480.

To preview in a browser locally, you may need to save your web page before it will be dis-
played. As long as you have not closed the page in Expression Web, you may still use Edit ➤
Undo or Ctrl+Z to undo your page changes up to the last 30 changes since your page was
opened.

ABOUT BROWSERS

While Design view gives you a good representation of what your page will look like according to the doctype
stated in the code (the default is XHTML 1.0 Transitional) full stylesheet support, no browser available is 
100 percent standards compliant. For that reason you should get in the habit of using F12 to preview your
web pages locally in your default web browser.

Testing in Multiple Browsers

At minimum, you should have the default browser for your operating system. Since you are using a web edi-
tor that runs only on Windows XP or Windows Vista, you have either Internet Explorer 6 or 7 installed. This will
be your default browser unless you have changed it. If possible, you should have both, since only those using
Windows XP with Service Pack 2 or later and Vista will be able to use Internet Explorer 7. Older versions of
Windows will be limited to Internet Explorer 6.

Running both versions of Internet Explorer requires two separate computers or a Virtual PC with another
Windows operating system installed. Unfortunately, unless you have access to more than one computer or
can run Virtual PC, you will be able to test in only one version of Internet Explorer. You can download Virtual
PC free from Microsoft at http://www.microsoft.com/windows/virtualpc/default.mspx.

Better yet download and install one or more of the following browsers:

• Firefox: http://www.mozilla.com/firefox/

• Opera: http://www.opera.com/

• Netscape: http://browser.netscape.com/

Users of Firefox, Mozilla, Opera, and Netscape tend to update to the latest version, so you do not typi-
cally need to install older versions of those browsers.

This will allow you to preview in multiple browsers, since you will not know what browser your visitor will
be using. If possible view your pages from a Mac using Safari in addition to the browsers listed previously.

Publish
A website that never makes it to the Web will not accomplish your goal. Since publishing is
such an important part of creating web pages, I will cover this topic in detail once you are
ready to publish pages.

You will want to publish the single page you created. Since you may not have published 
a web page before in any web editor, I will cover File Transfer Protocol (FTP) and FrontPage
Server Extensions (FPSE) publishing before going any further.
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To begin the process of transferring the web pages you create locally to a production
server, you use File ➤ Publish Site. This launches the Remote Web Site Properties dialog box,
shown in Figure 2-10. Your commercial web host should have provided you with the informa-
tion you need to publish your website to your web space. If you are using the web space
provided by your ISP, please check their FAQs before you begin the publishing process.

Figure 2-10. Choose the publishing method supported by your web host.

Remote Web Site Properties

The first thing you will notice in Figure 2-10 is that there is a variety of options you can use to
publish your site. They are as follows:

• FrontPage Server Extensions (or SharePoint Services)

• WebDav

• FTP

• File System

Most web designers will use standard FTP as their publishing method. I recommend
using the built-in FTP client to publish your pages, because it simplifies the transfer and
synchronization of files between your local copy and the one on your production server.
However, if you manage a large number of websites, you may prefer to use a third-party FTP
program, since the one in Expression Web does not remember user IDs and passwords for
FTP connections.
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As mentioned previously, we will look at FTP and FPSE. WebDAV is rarely used, but if you
have that option, just follow the prompts. The File System option is useful if you’re publishing
across a network.

Using FTP

Follow these steps to use FTP to publish your site:

1. Select the FTP radio button.

2. Type the location of your FTP server. This is usually the site name proceeded by ftp://,
but it may vary, which means you need to check the documentation provided by your
web host.

■Note In most cases, when you use FTP to connect to your website, you will be entering at a level above
your public folder or directory. Common names for this root folder, which is displayed to your web visitor, are
public_html, www, or webroot. Consult the instructions you have received from your host.

3. Click the OK button to launch the login credentials dialog box, shown in Figure 2-11.

Figure 2-11. This credentials box will be the same whether you are using FTP or 
FPSE to publish.

Using FPSE

If you have FPSE installed on your web server, you may use it to publish to your production
site. Since Expression Web will remember your user ID/password when you publish with FPSE
and not when you publish with FTP, you may find this method more convenient if your web
host supports FPSE publishing.

If you select the radio button for FrontPage Server Extensions, the “Remote Web site loca-
tion” field will change to look like the one in Figure 2-12.
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Figure 2-12. The remote Web site location changes to reflect an HTTP address.

Notice that with FrontPage Server Extensions you publish using HTTP. On some corporate
networks FTP is blocked, but you can still publish via HTTP, since it uses the same port as the
one used to view web pages (80) instead of the blocked FTP port (25).

Publishing Your Web Page

Once you have connected to your website, you will see a split screen with your local website
on the left and your remote website on the right. As shown in Figure 2-13, there may be files in
your remote site even before you publish any files. Typically, your web host will have a default
placeholder page that says “coming soon” or some other generic text that you will need to
replace. You may also have folders such as cgi_bin or aspnet_client.

■Caution Do not delete or change any folders that your web host has preinstalled without checking with
your host first, or your website may not function properly.

Expression Web will keep track of the publishing status of your web pages. Figure 2-13
shows a question mark (?) next to the index.html file in each location, because Expression Web
is able to tell that the two pages are not the same based on file dates and other metadata. To
synchronize your website, you can use the radio buttons at the bottom to publish your local
website to your server, transfer pages from the remote to the local (useful if you are working
on a site from a new computer or program), or synchronize pages, which will publish newer
files from one site to the other.

To transfer all the changed files in your website between your local computer and your
website, select the appropriate radio button in the bottom “Publish all changed pages” sec-
tion, and then click the Publish Web site button.

If you want to transfer just one file, you may highlight it in the appropriate site and use
the arrow between the two site windows to transfer or replace the one in the other site.

In Exercise 2-2, you’ll learn how to publish your web page.
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Figure 2-13. You web host will have preinstalled files and/or folders when you first connect.

Exercise 2-2. Publishing Your Web Page

In this exercise, you will publish the web page you created in Exercise 2-1. Make sure that you have the informa-
tion from your web host available before you start this exercise.

1. For the local website you created in Exercise 2-1, make sure you have saved your index.html file. While
you can publish a file that is open in the document window, only the last saved version will publish.

2. From the File menu, select Publish.

3. Select FTP or FPSE, depending on your web host options. If using FTP, make sure you have the correct folder
name in the FTP Directory text box for the folder that is the root of your public website. Check your hosting
documentation for the correct folder.

4. Type your user ID and password in the Credentials dialog box.

5. Click the Synchronize button to publish your local website to your server. You should get the Conflicts dialog
box shown in Figure 2-14. Choose Overwrite Remote Files, since you will be replacing the generic place-
holder home page.
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Figure 2-14. This conflicts warning will appear whenever Expression Web is unable to tell the 
status of individual files.

■Note When you have successfully synchronized, any files or folders on your remote site will have been
transferred to your local site. Generally, these are scripting folders that you should not be editing. If you right-
click the folder in the folder list and select Convert to Web, you will be able to synchronize files in the future
without publishing the folder or its contents.

You should no longer have a conflict between the two index.html versions, and any scripting or other hosting
folders will have a globe icon inside their icon on your local site to let you know that those files will not be pub-
lished when you synchronize files in the future, as shown in Figure 2-15.

Figure 2-15. Notice the globe in the local aspnet_client folder, which marks it as a separate 
subweb not to be published.

Congratulations, you have published your first web page!

CHAPTER 2 ■ TAKING YOUR FIRST STEPS38



Edit Menu
The Edit menu, shown in Figure 2-16, has all the standard Windows edit commands:

• Undo/Can’t Undo: Lets you undo the last action. It’s grayed out in Figure 2-16, since
there are no actions to undo.

• Redo/Can’t Redo: Lets you restore your last action after using Undo.

• Cut, Copy, Paste, Paste Text, Delete, Select All, Find, and Replace: These are the standard
Windows commands.

• Incremental Search: This search option finds as you type, instead of searching for a full
word or string.

• Go to Bookmark: This will open the Bookmark dialog box. Note that this changes to Go
to Line if you are in Code view.

• Quick Tag Editor: Opens the Quick Tag Editor, shown in Figure 2-17, which can be the
easiest way to change a tag.

• Check In, Check Out, and Undo Check Out: These options are useful for teams working
on a site; they can help to prevent accidentally over writing changes made by others.

• Code View and IntelliSense: I discuss these options in more detail in the following
section.

Figure 2-16. The Edit Menu has all the traditional Windows options along with a few that
are unique to Expression Web.
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Figure 2-17. The Quick Tag Editor floats on top of the Document window and allows to you make
quick edits.

Edit Code View
If you are like me, you want to see the code that is being created, whether it is code Expres-
sion Web creates for you or code you write yourself. The Edit ➤ Code View section, shown in
Figure 2-18, has actions that can make it easier to work in Code view. You will be able to see
these options only when you are using Code view or your cursor is in the Code section of
Split view. While it is best to set your default Code view configuration using Tools ➤ Page
Editor Options, some of the options on this menu can help your workflow.

Figure 2-18. The Code view submenu is divided into sections for code formatting and for manag-
ing HTML element tags, code bookmarks, and hyperlinks.

Tag Management Section

This section of options allows you to work with your HTML tags using the following options:

• Select Tag: Selects the opening and closing tags as well as everything in between

• Find Matching Tag: Takes you to the closing tag for the element selected
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• Select Block: Selects the nearest block level element

• Insert Start Tag: Inserts opening and closing angle brackets, < >, to add an HTML ele-
ment tag

• Insert End: Inserts a pair of angle brackets with the closing slash, </ >, to close a tag

• Insert Comment: One of the most useful of the tag management section; allows you to
insert comments to yourself so when you have not worked on a page for a long time
you will know why you did what you did

Bookmark Section

The following options are not for bookmarks in your HTML; instead, they allow you to create
bookmarks in your code to quickly jump from one section to another in Code view:

• Toggle Bookmark: Lets you set a temporary bookmark in Code view, which can be
helpful when trying to troubleshoot errors whether in your code or in your stylesheet.
These bookmarks are temporary and will be deleted when you close the web page in
Expression Web.

• Next Bookmark and Previous Bookmark: Moves forward or backward between book-
marks in Code view.

• Clear Bookmarks: Just as it says, it removes all the Code view bookmarks when you are
finished troubleshooting.

Hyperlinks Section

Like the bookmark section, these options are only for Code view. They let you move between
the CSS and JavaScript files that are linked in to your page.

■Note Microsoft also uses the term “bookmark” to refer to in-page links for your visitors to navigate
within your web page that are added via the Insert menu. The code for a permanent bookmark is 
<a name="top"> back to top</a>.

Edit IntelliSense
Similar to the Edit ➤ Code View options, your cursor must be active in page code and inside
an HTML element that has IntelliSense options for the Edit ➤ IntelliSense section to become
available. These options are options you would normally use the keyboard for, since using
Ctrl+spacebar for code completion is easier than using Edit ➤ IntelliSense ➤ Complete Word.
The most useful option here is to trigger the code snippet list for you to choose a code snippet
to insert. See Chapter 3 for more information about code snippets.
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View Menu
The View menu, shown in Figure 2-19, has many options worth paying attention to, since they
can help you troubleshoot problems.

Figure 2-19. The options on the View menu are unique to Expression Web.

For now, leave the default settings on the View menu, but I’ll quickly run through the
options so you know what they do.

• Page: This lets you set the display mode for the main document window. The options
are Design, Split, and Code.

• Visual Aids: These options, shown in Figure 2-20, allow you to set how certain struc-
tures are displayed in Design view.

Figure 2-20. Visual Aids are useful but can change how your page renders in Design view.
Turning them off gives you a browser preview.

Visual Aids allow you to see and modify code elements in Design view instead of work-
ing directly in code. The choices follow:

• Block Selection is the default. When you select an element in Design view, the ele-
ment boundaries will be outlined, and the HTML element will be identified at the
top-left of the outlined area.
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• Visible Borders shows a dotted line around elements such as table cells when the
element does not have visible borders set in the code.

• Empty Containers is a quick way to show empty elements on your page. This is
most useful when the page is not displaying as you expect—frequently an empty
element is on the page, which typically happens when you forget an opening or
closing element when you delete or edit text.

• Margins and Padding gives a red outline to the containers. By dragging the outline as
shown in Figure 2-21, you can change the margin around an HTML element. If you
press Ctrl and drag, you will change the amount of padding around your element.

Figure 2-21. To change the margin or padding, make sure you are not over one of the
resize handles.

• CSS Display:none Elements gives you a quick way to view elements with the CSS
property of display: none. Items with display: none will have the space they
occupy collapsed by the browser.

• CSS Visibility:hidden Elements allows you to toggle to display elements hidden
using visibility: none, the other method of hiding elements using CSS. The
space these elements occupy will not collapse in a browser.

• ASP.NET Non Visual Controls will show a rectangle as a placeholder for ASP.NET
controls.

• ASP.NET Control Errors will provide you with an error message if there is a problem
with the control, such as not being able to connect to a data source.

• Show Template Region Labels displays an orange outline by default when you are in
an editable region. This option will show all editable regions on the page, not just
the active one.

• Formatting Marks: This menu will be grayed out until you have turned on Show. Once
you have turned on Show, you can choose which of the marks you would like to use.
“Formatting marks” is a slightly misleading term, since this section includes hidden
form fields, script elements, and CSS properties.

• Ruler and Grid: Many people, especially those who are used to designing for print or
who have been using tables for page layout, use rulers for reference. The options are
self explanatory.
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• Tracing Image: Some designers will create a mock-up or comp in PhotoShop or another
graphics program and then use the image as a visual aid in laying out their web page. 
If such an image is part of your workflow, this is where you would select and place the
image. Images used in this manner will be displayed in Expression Web but not on your
web pages.

• Page Size: This allows you to quickly see how your page layout will look at the most
common screen resolutions in Design view. While this is not a substitute for checking in
a real browser, it is useful for a quick check.

• Folder List: This opens the Folder List task pane if it is closed.

• Quick Tag Selector: This opens or closes the Quick Tag bar. I recommend that the Quick
Tag bar always be displayed.

• Toolbars: This provides you with a list of the toolbars available and allows you to open
or close each one. Toolbars that are currently open have a check mark next to them.
One toolbar that is not open by default that I find useful is the Styles toolbar. Explore
the toolbars available on your own to see which ones you find useful.

• Refresh: This is the same as pressing F5 on your keyboard to refresh Expression Web. If
you have added files to your site through Windows Explorer or by saving a file directly 
to your website from another program using this option (or pressing F5) will make it
appear in your Folder List task pane.

Insert Menu
Most of the functions on the Insert menu, shown in Figure 2-22, are duplicated in either the
Toolbox task pane or the Behaviors task pane, both of which offer more options than those in
the Insert menu. These elements will be explained as you use them or when you explore the
Toolbox task pane.

Figure 2-22. The HTML and ASP.NET controls duplicate a fraction of the elements available on
the Toolbox task pane.
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These are the items on the Insert menu:

• Hyperlink: Opens a dialog box to insert a link to another page, a document, a file, or a
bookmark on the same page.

• Bookmark: Opens a dialog box to insert an anchor element: <a> to mark a specific sec-
tion of the page for a hyperlink.

• Picture: Inserts a picture and sets the alt attribute, which is the text that is displayed if
the image does not load or your visitor is unable to see images.

• File: Imports content into your web page from another HTML document, a Word file, or
one of the other file types listed in Figure 2-23.

• Interactive Button: Creates the appearance of a button and rollover effects as you
mouse over the links created.

• Symbols: Lets you add copyright, trademark, and other items from the symbol menu.

Figure 2-23. The Insert menu’s File option allows you to browse to files on your computer
with the extensions shown to insert them as content on your page.

■Note In most cases with RTF or Word documents, the formatting will be imported as well. You may need
to clean up the code after you have imported content using this method.

Format Menu
You will frequently use the Format menu, shown in Figure 2-24, since it contains one of the
most important commands for bringing in content from other sources such as Word files:
Remove Formatting. This lets you quickly remove the outdated and bulky code many word
processing and other programs add for presentation so you can apply the look and feel of your
site to the content.

Here, you have options to create and apply styles to your page, to add behaviors such as
rollovers, and to use DWTs and master pages to keep the look and feel of your site consistent
from page to page. Although many of the options on the Format Menu are available in task
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panes, the Remove Formatting, Dynamic Web Template, and Master Page options are most
frequently used from the Format menu.

Figure 2-24. Format menu options include page and tools for keeping your pages consistent
within your site.

While some of the options in the middle section of the Format menu (starting with Font
and ending with Borders and Shading) look like their Word or FrontPage counterparts, they 
do not work the same. Instead of creating bulky inline font markup that is repeated every time
you use the buttons, a style is created and reused. This automatic reuse of existing styles is one
of the best features in Expression Web, one that will help you create pages that load faster. In
Chapters 5 to 7, I will cover using a CSS to format your page display and layout.

Summary
You should be familiar now with the basic menu functions and be able to create a local website
and a basic HTML page. You have explored the menus that are common in all Microsoft pro-
grams, and you have seen where Expression Web–specific additions to the Microsoft standard
menu commands exist. Other than the Window and Help menus, the rest of the menus are task
or program specific. Remember that you should never work on individual pages in Expression
Web without opening the local website or your links, and other page features may break.

Throughout the remainder of this book, you will be using the options on these menus and
related task panes to create a fully functional, attractive website. In Chapter 3, I will show how
to configure Expression Web to make that task easier by changing some of the defaults in
Application Options, Page Editor Options, and Site Settings.
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