
5 CREATING A CSS SITE STRAIGHT
OUT OF THE BOX



In this chapter, I’ll lead you through the process of creating a page using one of the 32 built-
in CSS layouts in Dreamweaver CS4, showing you how to get the most out of the CSS Styles
panel in Current mode. The CSS layouts were originally introduced in Dreamweaver CS3 and
provide a very solid foundation for creating a standards-compliant website consisting of
header, sidebar, main content area, and footer. For a sneak preview of where this chapter
ends up, load stroll_final.html from examples/ch05 into a browser, or take a look at
Figure 5-7 later in this chapter. If you’re new to CSS, you may find some parts of this chapter
daunting, but come along for the ride. Even if you don’t understand how all the style rules fit
together, you’ll pick up some cool techniques that will give your own sites that extra lift.

In this chapter, you’ll learn about the following:

Attaching external style sheets when creating a new page

Making sure conditional comments are applied correctly

Adapting a Dreamweaver CSS layout

Getting the most out of the CSS Styles panel in Current mode

Understanding the impact of the CSS cascade

Refining selectors in the New CSS Rule dialog box

Using Dreamweaver’s Find and Replace feature

Using a built-in CSS layout
If you click HTML or PHP in the Create New section of the welcome screen, Dreamweaver
opens a blank page using your default settings (see “Setting new document preferences”
in Chapter 2). You get a much bigger choice with File ➤ New, which opens the New
Document dialog box (see Figure 5-1).

Figure 5-1. Open the New Document dialog box to select one of the built-in CSS 
layouts.
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In both the Blank Page and Blank Template categories, the Layout column offers you a
choice of 32 CSS layouts when the Page Type is suitable for a complete web page, such as
HTML or PHP. You can also choose just a blank page by selecting <none> from the top of
the Layout column. The dialog box remembers your choices the next time you open it.

Choosing a layout

The layouts cover the most commonly used conventions of web page design: one-, two-,
and three-column pages, with and without a header and footer. They have been tested in
all the main browsers and provide a rock-solid basis for building a site.

You can choose four different types of column widths, identified by simple diagrams, as
follows:

Fixed: The width is defined in pixels. 

Elastic: The width is defined in ems. 

Liquid: The width is defined as a percentage. 

Hybrid: The main column width is defined as a 
percentage; other columns are defined in ems.

As you select each layout, a diagram appears on the right of the New Document dialog box
showing the style together with a brief description, as shown in Figure 5-1.

Deciding where to locate your style rules

When you select a layout, the Layout CSS menu at the bottom right of the New Document
dialog box is activated (it’s grayed out when <none> is selected). The menu has three
options, as follows:

Add to Head: This embeds the style rules in the <head> of the document.

Create New File: This puts all the style rules in an external style sheet.

Link to Existing File: This discards all style rules associated with the layout and links
to an existing style sheet.

The minimum versions required for the CSS layouts are Firefox 1.0, Opera 8, Safari 2.0
(Windows and Mac), and Internet Explorer 5.5 (Windows).
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Linking to existing style sheets
The third option is typically for subsequent pages based on the same layout. Before click-
ing Create, you must specify the style sheet by clicking the chain icon alongside Attach CSS
file, as shown here:

This opens the Attach External Style Sheet dialog box, which was described in the previous
chapter. After selecting the style sheet, click OK, and you will be returned to the New
Document dialog box. You can add as many style sheets as you want. The text area below
the chain icon displays a list of the selected style sheet(s).

When you’re satisfied, click Create to load the new layout page into the Document win-
dow. When you first save the page, Dreamweaver automatically adjusts any document-rel-
ative paths to style sheets.

In many dialog boxes, Dreamweaver remembers your last set of options—and this includes
the list of attached style sheets at the foot of the New Document dialog box. That’s very
helpful if you want to link the same style sheets to your next document, but it may give
you a nasty surprise if you forget. To remove style sheets from the list, highlight them, and
click the trash can icon alongside the chain icon.

Making sure conditional comments are applied
To make the style sheets easier to edit, as well as to ensure standards compliance, the lay-
outs don’t use any weird and wonderful CSS hacks to overcome bugs in Internet Explorer.
Instead, special rules to correct these bugs are embedded in conditional comments just
before the closing </head> tag of the layout page. Conditional comments are a Microsoft
extension of HTML comments and look like this:

<!--[if IE 5]>
<style type="text/css">
.twoColFixLtHdr #sidebar1 { width: 230px; }
</style>
<![endif]-->

Only the Windows version of Internet Explorer takes any notice of the style rules embed-
ded in them. All other browsers treat them as ordinary comments and ignore them. It’s a
perfect, standards-compliant way of tackling Internet Explorer bugs. However, for them to
be effective, they must come after all other style rules. If your style rules are in external
style sheets, the conditional comments must come after the <link> or @import commands
that attach them to the page. Although you can put special rules for Internet Explorer in
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an external style sheet and use a conditional comment to attach the style sheet, the com-
ments themselves cannot go in an external style sheet. They must be in your web page.

This has important implications if you attach further style sheets. When you click the
Attach Style Sheet icon at the bottom of the CSS Styles panel, as described in Chapter 4,
Dreamweaver attaches external style sheets immediately before the closing </head> tag—
in other words, after any conditional comments. This means you must always move the
code that attaches your style sheet to before the conditional comments. Even if you’re
sure there’s no conflict of style rules, it’s safer to do so because Dreamweaver ignores the
conditional comments in the same way as a non-Microsoft browser, so you won’t notice
any difference in Design view if you forget to move the link to the new style sheet.
However, it will be immediately apparent to anyone using a version of Internet Explorer
with bugs that the conditional comments are meant to correct.

You must move the link to the external style sheet manually in Code view. Dragging and
dropping the style rules in the CSS Styles panel in All mode has no effect.

Styling a page

The layout I have chosen for this chapter is 2 column fixed, left sidebar, header and footer. It
creates a 780-pixel wide page centered horizontally in the browser. This is designed to fit
in an 800 × 600 monitor. You can change the width to suit your own needs, but I’m going
to leave it as it is.

The following exercise shows how to start transforming the basic layout. Of course, I didn’t
just pluck the settings out of thin air; it took some experimentation. But the way I did it was
exactly the same—using the CSS Styles panel to edit each property and watching the grad-
ual transformation of the page in Design view. The page you’ll build uses some of the same
materials as the previous chapter but results in a much more sophisticated design.

These instructions assume you have already familiarized yourself with using the CSS Styles
panel in All mode, as described in Chapter 4.

1. Open Dreamweaver, and select File ➤ New. In the New Document dialog box, select
the Blank Page category, and use the following settings:

Page Type: HTML

Layout: 2 column fixed, left sidebar, header and footer

DocType: XHTML 1.0 Transitional

Layout CSS: Create New File

Make sure there are no style sheets listed under Attach CSS file, and click Create.

Preparing the basic layout

Visit http://msdn.microsoft.com/workshop/author/dhtml/overview/ccomment_ovw.asp
to learn more about Microsoft conditional comments.
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2. Dreamweaver prompts you to save the style sheet. Navigate to the workfiles
folder, create a new subfolder called ch05, and save the style sheet in the new folder
as stroll.css. When you click Save, the CSS layout loads into the Document
window as an unnamed and untitled document. Save it in workfiles/ch05 as
stroll.html. The style sheet is added to the Related Files toolbar at the top of the
Document window.

Your first reaction may be “Ugh, what an ugly duckling!” But this ugly duckling has
the right genes, or infrastructure, to turn it into a beautiful swan. The first task is to
analyze the structure. Do this with the help of the CSS visual aids by moving your
mouse around the Document window and clicking any solid lines that indicate the
presence of a <div> as described in the previous chapter. Also click in each part of
the document to see the structure revealed in the Tag selector.

To assist you, Figure 5-2 shows how the page is divided. The whole page is wrapped
in a <div> called container, which centers the content in the browser. The rest of
the page consists of four sections, each within a <div> named header, sidebar1,
mainContent, and footer. The sidebar and main content are both floated left.

Figure 5-2. The main underlying structure of the two-column fixed layout with header 
and footer

3. Select stroll.css in the Related Files toolbar to display the contents of the style
sheet in Split view. As Figure 5-3 shows, the style sheet begins with an @charset
rule. This is not strictly necessary when working with English, but it tells
Dreamweaver and the web server which encoding you’re using. It must come
before any CSS selectors.
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Figure 5-3. The style rules are liberally commented to make it easy to understand the role they play in the layout.
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5The rules are copiously sprinkled with CSS comments that explain their purpose.
The styles applied to the body selector control the fonts and give the page a dark
gray background color. The white background is common to all elements in the
container <div>, but the header, sidebar1, and footer override this with various
shades of gray.

Most of the content on the page is dummy text, but the first paragraph in the left
sidebar contains the important information that the background color stretches only
as far as the content. It also advises adding a border to the left side of the
mainContent <div> if it will always contain more content. So let’s start by fixing that.

4. You can edit the style rules directly in stroll.css in Split view and see the effects
reflected in the Design view section of the Document window. However, I want to
show you how to use the CSS Styles panel in Current mode to identify which style
rules affect a particular part of the page when you don’t know the name of the
selector.

In Design view, click in the text beneath the
Main Content headline, select <div#mainContent>
in the Tag selector at the bottom of the
Document window, and then click the Current
button at the top of the CSS Styles panel. The
panel should now look similar to the screenshot
alongside.

In Current mode, the CSS Styles panel consists of
three sections, which you may need to resize to
see everything (the width of the columns is also
resizable by dragging horizontally). The top pane
(Summary for Selection) shows the rules that
apply to the current selection both through its
own selector and through the rest of the cas-
cade, whereas the bottom pane (Properties)
shows you the style rules for the currently high-
lighted selector. By default, the middle pane tells you where the property selected
in either pane is defined in the style sheet.



Although it looks confusing at first glance, Current mode presents you with a lot of
useful information and is an extremely effective place to edit CSS. Using it in prac-
tice makes it easier to understand, so just follow along for the time being.

5. Click Add Property at the bottom of the Properties
pane. This opens a blank drop-down menu. This is
where you specify the CSS property you want to
add to the rule. To create a left border, you need
the border-left property. The drop-down menu
is editable, so either you can click the down
arrow on the right of the menu to reveal all the options or you can start typing the
name of a CSS property. If you don’t want to type the full name, type just bor, and
press the down arrow key (or click the menu’s down arrow). The border property
should already be highlighted. Scroll down to border-left, as shown alongside.

Press Tab or click border-left, and Dreamweaver opens the right side of the pane for
you to type the value you want to assign to the CSS property. If it doesn’t open
automatically, click to the right of border-left. Type 1px dashed #000, and press
Enter/Return.

Click anywhere in the mainContent <div> to deselect it, and you should see a dot-
ted black border on the left side of the text.

6. Now let’s deal with the sidebar background. Click anywhere in the sidebar. If you
look at the Properties pane of the CSS Styles panel, you’ll see that it refers to
.twoColFixLtHdr #container and not the sidebar. Because nothing is actually selected,
Dreamweaver shows you the rules for the parent <div> for the whole page.
Although this seems counterintuitive, it’s actually quite useful.

The drop-down menu that contains the CSS properties remains editable only
when you first open it. Once you have selected a property, you cannot change it;
only the value field to the right of the property name remains editable. If you
choose the wrong property, highlight it, and press Delete or click the trash can
icon at the bottom right of the CSS Styles panel. Then click Add Property again
to choose the correct property.

The built-in CSS layouts use a technique known as giving the page a CSS
signature. This is a class added to the <body> tag of the page, identifying the
layout. Each style rule uses a descendant selector that begins with the class
name. So the style rule for the mainContent <div> is called .twoColFixLtHdr
#mainContent. Adding the class makes the style rules more specific, so you can
combine one of these layouts with an existing site that already has its own style
rules. If you add new rules yourself, remember that CSS selectors are case sensi-
tive. Use the same camel-case spelling.
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As you can see from the screenshot alongside,
background, border, margin, and width are all
struck through with a horizontal line. This indi-
cates that a more specific rule is overriding these
properties in the sidebar. The useful piece of
information here is that the background property
for the container <div> is white (#FFFFFF). If
you remove the background for the sidebar, it
will inherit the color of its parent.

7. Click <div#sidebar1> in the Tag selector at the
bottom of the Document window. The Properties
pane now shows the rules for .twoColFixLtHdr
#sidebar1, which set the background color of
the sidebar to light gray (#EBEBEB). Highlight
background, and press Delete or click the trash
can icon at the bottom of the CSS Styles panel,
as shown here.

8. The sidebar should now have the same white background as the mainContent
<div>. Let’s do the same to the footer, which has a slightly different gray back-
ground color (#DDDDDD). Position your cursor anywhere in the footer <div>, select
<div#footer> in the Tag selector, and then delete background from the Properties
pane of the CSS Styles panel.

9. If you look at stroll.html in Design view or Live view, the gray background should
be gone from the sidebar and footer, and there should be a dashed border down
the left side of the main content. The only gray background remaining is behind
the header. However, if you press F12/Opt+F12 to preview the page in your main
browser, the gray backgrounds are still all there. Why? The answer lies in the
Related Files toolbar.

10. Switch back to Dreamweaver. You should see an asterisk alongside stroll.css in the
Related Files toolbar, as shown in the following screenshot:

Changes made to the style sheet are not automatically saved when working with
the Related Files toolbar. This allows you to roll back any changes, but it also means
you need to remember to save them if you want to keep them. To save a related
file that has been edited, select the file name in the Related Files toolbar, and select
File ➤ Save or press Ctrl+S/Cmd+S.

If you delete the wrong property, you cannot undo it by pressing Ctrl+Z/Cmd+Z
or selecting Edit ➤ Undo because the change has been made to an external style
sheet. Select the style sheet’s name in the Related Files toolbar to undo the
change.
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Selecting a file name in the Related Files toolbar always opens the related file in
Split view. If you don’t want to open it, select File ➤ Save All, or right-click the main
document’s tab and select Save All from the context menu.

11. Save stroll.css, and test stroll.html in a browser. The sidebar and footer back-
grounds should now have disappeared.

Check your files, if necessary, against stroll_border.html and stroll_border.css
in examples/ch05.

Getting rid of the background colors doesn’t make a dramatic difference to the look of
the page. The real transformation begins with adding background images. By using the
CSS Styles panel, the changes are reflected immediately in Design view.

In this exercise, you’ll add a background image and banner to the header <div>, and you’ll
position a background image at the bottom of the container <div>. Continue working
with the same files as in the preceding exercise.

1. Instead of white or gray, I’ve chosen a shade of cornflower blue as the background
color for the header. This is because I’m going to use a background image but want
a similar color to be displayed if the image fails to load.

Click in the header <div>, select <div#header> in the Tag selector, and delete back-
ground from the Properties pane of the CSS Styles panel. Although you’re going to
use a different color, I’ve suggested deleting the shortcut property because it’s eas-
ier to use the separate background-color and background-image properties.

2. With the header <div> still selected, click Add Property, and select background-
image using either the arrow keys or the drop-
down menu. Dreamweaver not only opens the
right side of the pane for you to type the name of
the image but also displays two icons that should
be familiar from the main Property inspector, as
shown here.

You can click the Point to File icon on the left to point to the image in the Files
panel, or you can click the folder icon to navigate to the file. It’s often easier to
close the Files panel when working in the CSS Styles panel, so the latter tends to be
more useful. Use either method to select images/stroll_header_bg.jpg.

3. Click Add Property, select background-repeat, and select repeat-x from the drop-down
menu that appears alongside. This tiles the background image only horizontally.

Adding background images

It’s important to note that you cannot normally undo changes to an external
style sheet if the option Open CSS files when modified has been deselected in the
CSS Styles category of the Preferences panel (see Chapter 4). If you set your
preferences not to open CSS files and are wondering why your changes haven’t
been automatically saved, it’s because selecting stroll.css in the Related Files
toolbar in step 3 has the effect of opening it, making all changes undoable.
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4. Click Add Property again, and select background-
color from the drop-down menu. This time,
Dreamweaver inserts the color picker alongside
the property, as shown alongside.

5. Click the color picker, and use the Eyedropper
tool to get the color of the background image in
the header <div>. It has a slight pattern, so the precise color isn’t important. I told
you that it was a lot easier not using shortcuts for the background property.

6. Remove all padding from the header <div> by clicking the value alongside
padding, and change it from 0 10px 0 20px to 0. Sizes in CSS must always be accom-
panied by a unit of measurement, such as em or px, with no gap between the num-
ber and unit. The only exception is 0, which doesn’t require a unit of measurement.
Although 0px is valid, the px isn’t necessary—and leaving it out saves typing.

7. Select the word Header, and replace it with Stroll Along the Thames. Then select the
<h1> tag in the Tag selector, and press the right arrow key on your keyboard. If you
open Split view, you’ll see that this positions the cursor between the closing </h1>
tag and the closing </div> tag in the underlying code.

8. Insert the header image by selecting the Insert Image button in the Common
category of the Insert bar or by selecting Insert ➤ Image. Browse to images/
stroll_header.jpg. In the Image Tag Accessibility Attributes dialog box, set Alternate
text to Stroll Along the Thames, and click OK.

9. Change the Document title to Stroll Along the Thames by replacing Untitled
Document in the Document toolbar. The top of the page should now look like this
in Design view:

When opening Split view with Related Files enabled, Dreamweaver remembers
which file was opened most recently in Split view. To make sure you open the
right file, always use the Related Files toolbar, rather than clicking the Split View
button on the Document toolbar. To inspect the HTML code of the main docu-
ment, click Source Code in the Related Files toolbar.
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The text heading in the <h1> tags is for the benefit of search engines and browsers
that can’t cope with CSS, but you need to hide the text for visual browsers. Once
it’s out of the way, you can tuck the header image neatly into the top of the page.

10. Position your cursor in the text heading, and select the <h1> tag in the Tag selector.
Highlight the padding property in the Properties pane of the CSS Styles panel, and
delete it. Then add the following two properties and values:

position: absolute

top: –500px

Using absolute positioning removes the heading from the flow of the document,
and giving it a top position of –500 pixels moves it conveniently out of the way.

11. Now let’s add a bit of interest to the bottom of the page. Click anywhere in Design
view, and select <div#container> in the Tag selector. Highlight background in the
Properties pane of the CSS Styles panel, and delete it. The whole of Design view will
turn a dark gray, but fear not. You can restore the light right away by clicking Add
Property, selecting background-color, and setting its value to #FFF.

12. Next add the background-image property, and navigate to images/city_footer.jpg.
It tiles throughout the page, so you need to set the following properties and values:

background-repeat: no-repeat

background-position: left bottom

The first of these properties accepts only one value, so Dreamweaver lists valid
options as a drop-down menu. The second accepts combined values, so no drop-
down menu is available. Nevertheless, Dreamweaver still comes to your rescue by
displaying code hints when you hover your mouse pointer over the field where the
values need to be entered.

13. Click the Live View button in the Document toolbar. If your monitor is large
enough, the page should look similar to Figure 5-4.

If you want to check the page in a browser, remember to save stroll.css first.

14. The page is beginning to look pretty good, but the margins on both sides look
drab. Their color is controlled by the body selector; and after some experimenta-
tion, I decided to make them a light pink to match the winter sunset sky behind
Saint Paul’s Cathedral. The color I chose was #F8F1EB. Select <body.twoColFixLtHdr>
in the Tag selector, and click the value of background in the Properties pane of the
CSS Styles panel. Replace #666666 with #F8F1EB.

When entering a value like –500px, you can either type the unit of measurement
immediately after the number or select it from the drop-down menu that
Dreamweaver places alongside. Since you’re already at the keyboard, it’s
quicker to type it yourself.
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Figure 5-4. The built-in CSS layout looks very different after changing some background settings.
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15. The border around the container <div> is now a little too dark, so select
<div#container> in the Tag selector. The Properties pane of the CSS Styles panel
shows that border has been set to 1px solid #000000—in other words, a solid, black
border all around. Although I have set my preferences to use shorthand styles for
the border property, you can use shorthand only when all sides have the same
value. I want no border at the top and bottom, but a deep russet on either side.

Highlight the existing border property, and delete it. Then click Add Property to cre-
ate two separate rules for border-left and border-right with the value 1px solid
#C99466.



16. Save stroll.html and stroll.css, and preview the page in a browser. It’s now
looking quite respectable. If you want to check your progress, compare your files
with stroll_bg.html and stroll_bg.css in examples/ch05.

Making these changes to the background has already transformed the basic CSS layout,
but to make further changes, you need to exploit the Current mode of the CSS Styles
panel to its full potential by using it to analyze the way style rules interact with each
other—in other words, the cascade.

Inspecting the cascade in Current mode

Halfway down the right side of the CSS Styles panel in Current mode are two
insignificant-looking icons (shown alongside). By default, the left one is selected,
but the right one holds the key to the cascade of rules affecting the currently selected
tag. I recommend you select the icon on the right and use this as your default setting
(Dreamweaver always remembers your most recent choice).

Study Figure 5-5 carefully. The title bar of the Properties pane is identical in both screen-
shots, but the Summary for Selection is different, and all the properties are struck through
in the left screenshot. No, it’s not a bug; Dreamweaver isn’t broken. The left screenshot
was taken with the insertion point in the text of one of the paragraphs in the mainContent
<div>. The properties are struck through because they don’t affect the paragraph directly.
What Dreamweaver is telling you is that you can edit these values, but they won’t change
the look of the current selection in Design view. The screenshot on the right was taken
with the whole of mainContent <div> selected. As a result, the properties are no longer
struck through; they apply directly to the current selection. They’re also listed in the
Summary for Selection.

The Rules pane in the middle shows the full cascade of all style rules that affect the cur-
rent selection. As you hover your mouse pointer over each one, Dreamweaver displays the
rule’s specificity as four comma-separated numbers (see “Calculating specificity”).

The real power of Current mode comes in the ability to select any of the properties listed
in the Summary for Selection or any of the selectors in the Rules pane. Doing so immedi-
ately displays the relevant style rule in the Properties pane. For example, selecting font in

Cascading style sheets are so called because of the way rules
inherit properties from each other, rather like the increased
flow of water cascading down a waterfall. Not only do rules
inherit from one another, a more powerful influence further
down the cascade can override everything that has gone
before. Understanding how the cascade works is the key to
successful implementation of CSS.
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Calculating specificity
Specificity determines which rule “wins” when there’s a conflict—the higher
the numbers, the greater the precedence that’s given to a particular rule.
Specificity is calculated in a rather unusual way using a series of comma-
separated values like this:

For every ID attribute in the selector, add 0, 1, 0, 0.

For every class, attribute selector, and pseudo-class (such as a:link),
add 0, 0, 1, 0.

For every HTML element or pseudo-element, add 0, 0, 0, 1.

Precedence is given to numbers on the left. So a CSS selector with a speci-
ficity of 0, 1, 0, 0 overrides one that has a specificity of 0, 0, 0, 2. If you find
this confusing, a simple rule of thumb is that ID attributes have the highest
precedence, followed by classes. Type (tag) selectors have the lowest prece-
dence of all.

the top pane displays the body style rules ready for editing in the bottom pane (see
Figure 5-6).

It takes a while to get used to working with the CSS Styles panel in Current mode, but once
you do, you’ll wonder how you ever did without it.

Figure 5-5.
In Current mode, the 
CSS Styles panel shows
the different impact of
the cascade on text in the
mainContent <div> (left)
and on the <div> itself.

Figure 5-6. The 100-percent font
size in the body selector needs to
be overridden further down the
cascade.



You might be wondering why there’s a fourth digit in specificity calculations since the first
one doesn’t seem to be used at all. Actually, an inline style has a specificity of 1, 0, 0, 0,
and overrides all other style rules. Inline styles are very inflexible and are rarely justified,
except perhaps for creating HTML email because of poor support for CSS in some email
programs.

For more details about specificity, see www.w3.org/TR/REC-CSS2/cascade.html#specificity.

Finishing the layout

Let’s return to stroll.html and smarten it up a little more by adding some images, chang-
ing the font size, and adding a pull quote.

Continue working with stroll.html and stroll.css. Alternatively, copy stroll_bg.html
and stroll_bg.css from examples/ch05 to your workfiles/ch05 folder. If Dreamweaver
asks you whether you want to update links, click Update.

1. Position your cursor near the top of the first paragraph in mainContent <div>, say
at the beginning of the third sentence, and insert images/living_statues.jpg.
Give the image some alternate text, such as Living statues on the South Bank.

2. Select the image in Design view, and click the arrow to the right of the Class drop-
down menu in the Property inspector. This lists all classes defined in the style sheet.
Adobe has anticipated the need to wrap text around images and provided two
classes, .fltlft and .fltrt, which float elements left and right, respectively.
Choose fltlft from the Class drop-down menu to float the image to the left.

3. Insert images/graffiti.jpg into the text beneath the second heading, give it
some alternate text, and select fltrt from the Class menu to float the image to 
the right.

4. The size of the text is a bit too large for my liking, so let’s adjust it. Position your
cursor anywhere in the text in the mainContent <div>, and open the CSS Styles
panel in Current mode. It should look like the left screenshot in Figure 5-5.

Select font in the Summary for Selection pane. This reveals that all the font prop-
erties for the page are defined in the <body> tag, as shown in Figure 5-6.
Although you could edit the font size here, it would affect fonts throughout the
rest of the page, and using a percentage other than 100 percent on the body
selector makes it difficult to calculate font sizes further down the cascade. So
let’s create a new rule.

5. Click the New CSS Rule icon (see alongside) at the bottom of the CSS Styles
panel.

Dreamweaver makes an intelligent guess and suggests .twoColFixLtHdr #container
#mainContent p as the name of the new selector, as shown here:

Inserting images and adjusting fonts
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This isn’t what you want, because it would apply only to paragraphs in the
mainContent <div>. To apply it to all paragraphs, you want a simple type (tag)
selector.

6. You can do this in two ways. First, you could change Selector Type to Tag (redefines
an HTML element), and then type p in the Selector Name field.

The other way is to use the Less Specific button. The first time you click the Less
Specific button, .twoColFixLtHdr is removed from the Selector Name field. Click
twice more, and you’re left with just p. Although Selector Type still says Compound
(based on your selection), Dreamweaver creates the correct style rule.

Use either method to create a new style rule for all paragraphs, and click OK.

7. This opens the CSS Rule Definition dialog box. As I explained in Chapter 4, I find this
a rather clumsy way of defining a new rule because you need to wade through the
different categories to find what you want. But if you’re new to CSS, it may help fix
the available properties in your mind. Anyway, it opens automatically at the Type
category, which is what you want.

Enter 85% in the Size field, set Line-height to 1.3, and select multiple from the drop-
down menu alongside the Line-height field. Click Apply to view the result in Design
view (move the CSS Rule Definition dialog box if necessary). Make any adjustments
you want, and then click OK to create the rule.

8. The footer text is obscured by the background image, so let’s adjust that too. Click
anywhere in the footer <div>, and switch to Current mode in the CSS Styles panel.
The Dreamweaver CSS layout has already defined a selector called .twoColFixLtHdr
#footer p with values for margin and padding.
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Click Add Property, and use the following settings:

color: #8A5B31

text-align: right

Moving the text across to the right and giving it a dark brown color makes it stand
out against the lighter part of the background image. Select File ➤ Save All to save
stroll.html and stroll.css, but keep them open for the next exercise.

Since it’s a page about London, there’s just one final touch I’d like to add: Samuel
Johnson’s famous assertion that when a man is tired of London, he’s tired of life.

In the bad old days, the <blockquote> tag was misused by all and sundry to indent text.
Well, let’s be honest, it still is, but you know better, don’t you? You’re going to use 
<blockquote> for its real purpose—to highlight a quotation—and then style it with CSS to
turn it into a distinctive pull quote.

1. Place your cursor at the end of the first paragraph in the sidebar, and press
Enter/Return to create a new paragraph. Type: No, Sir, when a man is tired of London,
he is tired of life; for there is in London all that life can afford. Press Enter/Return again,
and type the attribution: Samuel Johnson, 1777.

2. Select both paragraphs in Design view, and click the Text Indent button in the HTML
view of the Property inspector, as shown here (make sure you’re in HTML view; the
icons in the CSS view look very similar but perform different functions):

This wraps the paragraphs in a pair of <blockquote> tags.

3. Switch to the CSS view of the Property inspector, and select <New CSS Rule> from
the Targeted Rule menu, as shown in the following screenshot:

The names of the Text Indent button and the one to its left (Text
Outdent) still reflect the old presentational type of markup that
you should avoid in a standards-compliant site. When applied to
ordinary text, think of them as the “blockquote” and “remove
blockquote” buttons. When used in an ordered or unordered list,
they create or remove a nested list, as explained in Chapter 3.

Adding a pull quote
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Click the Edit Rule button to open the New CSS Rule dialog box.

4. Dreamweaver suggests using the following selector: .twoColFixLtHdr #container
#sidebar1 blockquote p. That’s too precise for what you want to do at the
moment, so choose Tag (redefines an HTML element) for Selector Type. Because you
have a <blockquote> selected in Design view, Dreamweaver should automatically
enter blockquote in the Selector Name field. If for any reason it doesn’t, choose
blockquote from the Selector Name drop-down menu, and click OK.

5. In the CSS Rule Definition dialog box, select the Type
category, and set Font to Georgia, Times New Roman,
Times, serif and Color to white (#FFF). Next, select the
Background category, and set Background color to
#999 (medium gray). You need to add a few more
properties, but it’s much easier to do the rest in the
CSS Styles panel, because you can see exactly how
they affect the look of the pull quote in Design view.

Click OK to save the current rules. The pull quote
should now look like the one shown alongside.

6. The default margin around the <blockquote> is too
wide, so position your cursor anywhere in the quote,
and select <blockquote> in the Tag selector. With the CSS Styles panel in Current
mode, click Add Property to add the following settings:

margin: 10px

padding: 0

7. The text in the pull quote now needs to be pulled in from the edges. Click anywhere
in the <blockquote> element in Design view. This deselects <blockquote> in the Tag
selector but puts the insertion point in a paragraph nested in the <blockquote>.
You’ll see why this is important when you open the New CSS Rule dialog box.
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8. Open the New CSS Rule dialog box in the same way as in step 3. Alternatively, click
the New CSS Rule icon at the bottom right of the CSS Styles panel. Dreamweaver
suggests the same selector as in step 4 (.twoColFixLtHdr #container #sidebar1
blockquote p). This time, it’s appropriate, but you don’t really need it to be so spe-
cific. Click the Less Specific button three times to change the contents of the
Selector Name field to blockquote p.

9. The descendant selector blockquote p restricts the rule to paragraphs in a 
<blockquote>. Click OK, select the Box category in the CSS Rule Definition dialog
box, and use the following settings for Padding and Margin:

10. When you click OK to save the settings for the blockquote p rule, you’ll see that
the bottom line is flush with the gray background. Everything comes right in a
moment.

Select <blockquote> in the Tag selector again, and click Add Property in the
Properties pane of the CSS Styles panel. Select background-image, and navigate to
images/top_quote.gif. The image tiles horrendously, so add two further proper-
ties as follows:

background-repeat: no-repeat

background-position: left top

11. Just a couple more tweaks and you’re there. The beginning of the pull quote over-
laps the quotation marks of the background image, so click in the first paragraph of
the quote, and add the following property to the blockquote p style rule:

text-indent: 20px

12. CSS doesn’t let you apply two background images in the same rule (you’ll have to
wait for CSS3 to do that), so you need to create a new rule for the quote attribu-
tion within the <blockquote>. Position your cursor in the paragraph that reads
Samuel Johnson, 1777, and switch to the HTML view of the Property inspector.
Enter quote_attrib in the ID field, and press Enter/Return to register the change.

13. Use the ID selector #quote_attrib to create a new CSS rule. With your cursor still
in the same paragraph, open the New CSS Rule dialog box. This time, Dreamweaver
suggests .twoColFixLtHdr #container #sidebar1 blockquote #quote_attrib as
the selector. Click the Less Specific button four times until you’re left with
#quote_attrib in the Selector Name field. Then click OK to open the CSS Rule
Definition dialog box.

14. Select the Background category, and set Background image to images/
btm_quote.gif, Repeat to no-repeat, Background-position (X) to right, and Background-
position (Y) to bottom.
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Then use either the CSS Rule Definition dialog box or the CSS Styles panel to set the
remaining properties:

font-size: 70%

margin-top: 0

padding-bottom: 30px

text-align: right

text-indent: 0

15. Select File ➤ Save All to save both stroll.html and stroll.css, and press
F12/Opt+F12 to preview the page in a browser. It should look similar to Figure 5-7
(I’ve changed the headings to give the page a more authentic look). The ugly duck-
ling in Figure 5-2 is now an elegant swan. You can compare your files with
stroll_final.html and stroll_final.css in examples/ch05.
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Figure 5-7. With a little imagination and work, you can transform the basic CSS layouts into attractive pages.



Creating a new page with the same styles

All the hard work of creating an external style sheet is repaid by the fact that you can
apply the same styles instantly to any other page in the site. To round out this series of
exercises in adapting one of Dreamweaver’s CSS layouts, I want to show you quickly how
to create another page using the same style sheet.

This exercise shows you how to reuse the stroll.css style sheet with a new page. It also
shows you how to turn off the display of styles temporarily to make it easier to add content.

1. Open the New Document dialog box by selecting File ➤ New or pressing
Ctrl+N/Cmd+N.

2. In the Blank Page category, select HTML as Page Type and 2 column fixed, left sidebar,
header and footer as Layout (these are the same options as before).

3. At the bottom right of the New Document dialog box, set the value of Layout CSS
to Link to Existing File.

4. Click the chain icon to attach the existing style sheet, as shown here:

5. In the Attach External Style Sheet dialog box, click the Browse button, navigate to
workfiles/ch05/stroll.css, and then click OK (Choose on a Mac) to select it.

6. Click OK to close the Attach External Style Sheet dialog box and return to the New
Document dialog box. The settings at the bottom right should now look like this:

7. Click Create to create the new page with the attached style sheet. Dreamweaver
might display a warning about document-relative paths. This is nothing to worry
about. Just dismiss the warning by clicking OK.

Creating a subsequent page
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8. Save the new page as page2.html in workfiles/ch05. If your monitor is large
enough, it should look like Figure 5-8. It has picked up all the styles from
stroll.css, but what has happened to the header?
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Figure 5-8. The new page has picked up all the styles, but the header is missing.

You can’t see the header because the style rule for the <h1> heading was set to an
absolute position of –500px from the top. You need to disable that rule temporar-
ily to change the value of the header and insert the banner image.

If you’re wondering why the background image doesn’t make the header visible,
it’s because the <div> doesn’t have a height. Absolute positioning removes the
<h1> content from the flow of the document, and backgrounds don’t show if an
element doesn’t have a height. Of course, a simple solution would be to add the
height of stroll_header.jpg to the style rule for the header <div>, but I want
to show you another technique.



9. Select View ➤ Style Rendering ➤ Display Styles. Alternatively, if you have enabled
the Style Rendering toolbar (see Figure 4-18) as described in the previous chapter,
click the CSS On/Off button. This temporarily disables CSS in Design view.

10. Select the word Header in the <h1> element at the top of the page, and replace it
with Stroll Along the Thames.

11. Select <h1> in the Tag selector at the bottom of the Document window, and press
your right arrow key once to move the insertion point outside the closing </h1>
tag. Then insert stroll_header.jpg, giving it some alternate text.

12. Turn the display of CSS back on by selecting View ➤ Style Rendering ➤ Display
Styles or clicking the CSS On/Off button in the Style Rendering toolbar. The banner
at the top of the page should now be correctly displayed. If you want to check your
code, compare it with page2.html in examples/ch05.

That concludes this exercise in transforming one of the 32 CSS layouts that can be
accessed from the New Document dialog box. The structure of each layout is very similar,
so once you have learned how to adapt one, working with the others becomes a lot easier.

There’s just one thing that remains to be done. The comments in the Dreamweaver CSS
layouts are deliberately verbose—they’re there to help you understand what each rule
does. Although commenting style sheets is a good idea, you’ll probably want to get rid of
the Dreamweaver comments once you’re familiar with the layouts. It’s easy to do with
Dreamweaver’s Find and Replace feature.

Using Find and Replace
Dreamweaver’s Find and Replace feature is very powerful, so it’s useful to get to know how
it works. In many ways, it’s similar to the Find and Replace feature in word processing pro-
grams such as Microsoft Word, but it has dedicated features designed for working with
HTML and other web-related languages. It not only searches code and text, but you can
get it to search for specific attributes in tags or for tags that have a missing attribute. And
if that’s not enough for you, it will perform the same search on multiple files or even
through the whole current site.

To launch Find and Replace, select Edit ➤ Find and Replace, or press Ctrl+F/Cmd+F. This
opens the dialog box shown in Figure 5-9.

As I mentioned at the beginning of this chapter, Dreamweaver
remembers your last choice in most dialog boxes. Don’t forget that
stroll.css is now listed in the New Document dialog box and will
be automatically attached to any new page unless you remove it
from the Attach CSS file field.
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Figure 5-9. The Find and Replace dialog box enables you to perform sophisticated searches.

The basic dialog box has the following options:

Find in: This determines the broad scope of the search. The options are as follows:

Current Document: This is limited to the document that currently has focus in the
Document window. It does not include files listed in the Related Files toolbar.

Selected Text: This limits the scope to highlighted text or code.

Open Documents: This applies not only to documents currently open in the
Document window but also to files listed in the Related Files toolbar.

Folder: When you select this option, a field opens alongside for you to enter the
name of the folder you want to search. A folder icon alongside the field opens
the Choose Search Folder dialog box for you to navigate to the folder.

Selected Files in Site: This searches within files that have been selected in the
Files panel. Related files are not included.

Entire Current Local Site: Use this to search the entire site.

Search: This narrows the scope of the search. The options are as follows:

Text: This limits the search to text that can be seen in Design view. In other
words, tags and attributes are excluded.

Source Code: This searches everything, including text, tags, attributes, com-
ments, JavaScript, and server-side code.

Text (Advanced): This allows you to narrow your search for text to specific parts
of a page. For example, you can search for a word or phrase that appears in an
<h3> tag but ignore all other instances.

Specific Tag: This looks for specific tags with or without specified attributes.

Find: This is what you want to search for.

Replace: This is what you want to replace the search term with. You don’t need to
enter anything in this field if you’re just doing a search.

Options: Most of these are self-explanatory. The Use regular expression checkbox
lets you perform complex searches using Perl-compatible regular expressions
(regex), a powerful pattern-matching language. You’ll see how this works in an
exercise later in this chapter.
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The two icons at the top right of the text area where you enter the search term are for sav-
ing and loading stored queries. The buttons on the right of the Find and Replace dialog box
are self-explanatory. The dialog box performs the dual purpose of simply finding some-
thing or finding specific text or code and replacing it.

As you can see, there are many options. Let’s start by looking at how to perform a basic
search.

Searching for text

Searching for text is quite simple. The Find and Replace feature works just like it does in
most word processors. Since this option is limited to Design view, it’s not available if the
current document contains only code (for example, a style sheet or JavaScript file). The
basic procedure is as follows:

1. Launch Find and Replace (Edit ➤ Find and Replace or Ctrl+F/Cmd+F).

2. Set the broad scope of the search with the Find in menu, as described in the pre-
ceding section.

3. Set the Search menu to Text.

4. Type the text you’re searching for in the Find field.

5. Enter the replacement text (if any) in the Replace field.

6. Select any options by putting a check mark in the appropriate checkbox. Make sure
that Use regular expression is unchecked.

7. Choose the appropriate button on the right to perform the operation you want.

You can step through the Find and Replace process one instance at a time by using the
Find Next and Replace buttons. This gives you the opportunity to inspect each instance
before replacing it. Alternatively, if you just want to find all instances, click Find All. If
you’re happy to do a global replace operation without checking, click Replace All.

As soon as you click one of the buttons (except for Close and Help), the Results panel
springs open and lists the items found or replaced. Some people find this intensely annoy-
ing, particularly on a small monitor, but you cannot disable this behavior. To minimize the
Results panel, click the dark gray bar anywhere to the right of the tabs, or press F7.

Dreamweaver is capable of conducting Find and Replace operations in documents that
are not currently open in the Document window. If you set the broad scope of the
search in the Find in menu to include closed documents and click Replace All,
Dreamweaver warns you that the operation cannot be undone. This is a very powerful
but potentially dangerous feature. It’s a good idea to make a backup of your site before
altering a large number of documents without first checking the effect such changes
will have. There isn’t a simple undo command for changes to open documents.
However, if you save them before running Find and Replace, you can either close the
documents without saving the changes or select File ➤ Revert. This discards all changes
to a document and restores it to its last saved state.
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Searching source code

Searching the source code is identical to searching for text, except for step 3, where you
should choose Source Code from the Search menu. The important thing to remember
about selecting this option is that it searches everything, regardless of whether it’s part of
code or text. Also, searching the source code of any document that’s currently open
includes the code in all files listed in the Related Files toolbar.

If you’re not careful, a Find and Replace operation can alter your HTML in unintended
ways. The following exercise demonstrates the difference between searching text and
source code, and it demonstrates the danger of choosing the wrong one. The download
files in examples/ch05 contain two files called search_me.html and search_me.css, which
are copies of the finished exercise file from Chapter 4. You’ll discard the changes to the
files at the end of the exercise, so you can work on them in their current location.

1. Open search_me.html in the Document window, and launch Find and Replace by
selecting Find ➤ Find and Replace or pressing Ctrl+F/Cmd+F.

2. Use the following settings:

Find in: Current Document

Search: Text

Find: graffiti

Replace: doodle

3. Click Replace All.

4. The Results panel opens at the bottom of the Workspace, as shown in Figure 5-10.

Figure 5-10. The Results panel provides a direct link to items that have been found and
replaced.

Searching text and source code
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At the bottom of the panel, it reports how many items have been found and
replaced (if you’re searching multiple files, it also reports how many documents it
searched). In the body of the panel, it shows the replaced text in context and
underlined in red. Double-click one of the results, and Dreamweaver selects the
text in the Document window, as shown in Figure 5-10.

5. To discard the changes, select File ➤ Revert. When prompted, confirm that you
want to revert to the previously saved version and lose the changes.

6. Open the Find and Replace dialog box again by clicking the right-facing green arrow
on the left of the Results panel, just below the Search tab.

7. Use the same settings as in step 2, except change the Search menu from Text to
Source Code.

8. Click Replace All.

9. This time, Split view opens because the search has been conducted in the underly-
ing code, and four items are listed in the Results panel. Double-click the first one,
and you’ll see that the name of graffiti.jpg has been changed to doodle.jpg.
The word graffiti has also been changed in the image’s alt attribute.

The two remaining instances are the same as before, confirming that Source Code
means both code and text.

10. Discard the changes by selecting File ➤ Revert.

11. Open the Find and Replace dialog box again. Leave Find in and Search at Current
Document and Source Code, respectively. Enter h1 in the Find field. It doesn’t mat-
ter what’s in the Replace field.

12. Click Find All. The Results panel should show two items: the opening and closing
<h1> tags around Stroll Along the Thames.

13. Change Find in to Open Documents, and click Find All again.

14. This time the Results panel reports four items; two of them are in search_me.css.
Even though the style sheet is not open in a tab of its own, it’s listed in the Related
Files toolbar so is considered to be an open document. Of course, this won’t hap-
pen if you have disabled the Related Files feature in the Preferences panel.

Performing advanced text searches

The options in the Find and Replace dialog box change when you select Text (Advanced) or
Specific Tag in the Search menu. The following screenshot shows what the dialog box looks
like when you first select Text (Advanced):

In addition to providing a direct link to items that have been found and
replaced, the Results panel lets you upload the amended files directly to your
remote server. Just select the file in the Results panel, right-click, and select Put
from the context menu.
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The new menu inserted between the Find and Replace fields has two options: Inside Tag
and Not Inside Tag. The drop-down menu alongside lists all valid tags. So, for example, you
could select Inside Tag and table, and the search would be confined to text in a table.
Alternatively, Not Inside Tag and table would ignore any matching text in a table but would
search for matches elsewhere.

If you click the plus (+) button alongside the menu between the Find and Replace fields, a
new set of options is added, as shown in the next screenshot:

The related fields depend on which option you choose, as follows:

With/Without Attribute: This lets you choose an attribute, a comparison operator, and
a value. The comparison operator can be set to equal to, greater than, less than, or
not equal to.

Containing/Not Containing: This offers two choices: Text or Specific Tag. If you choose
Text, you enter the text in the adjacent field. If you choose Specific Tag, the adja-
cent field turns into a drop-down menu listing valid tags.

Inside/Not Inside Tag: The adjacent field turns into a drop-down menu listing valid tags.
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You can continue adding refinements to your search by clicking the plus button again. If
you decide to remove a set of options, click the minus (–) button alongside.

Using the options, you can build quite complex text search operations. However, you need
to specify individual tags. For instance, you can search for text in any <h1> heading, but
you cannot search for text in a range of heading levels. To perform that sort of search, you
need to use a regular expression.

Although all the settings relate to tags and attributes, the Text (Advanced) option looks for
text only within those tags. You cannot use it for altering the tags or attributes. That’s the
job of the Specific Tag option described next.

Performing complex replacements with specific tags

The Specific Tag option in the Search menu lets you drill down into your code to look for
a particular tag and perform a replace operation on it. For example, you might want to
search your code to insert an empty alt attribute in <img> tags that don’t have one.

Selecting the Specific Tag option changes the Find and Replace dialog box like this:

You specify which tag you want to search for in the drop-down menu alongside Search
Specific Tag. You can then narrow the search by setting the same options as for Text
(Advanced). If you just want a general search, click the minus button to remove those
options. Finally, you set the Action options to tell Dreamweaver what to do when it finds a
matching tag.

The options offered by the Action menu differ according to your previous selections, but
they include the following:

Replace Tag & Contents

Replace Contents Only

Remove Tag & Contents
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Strip Tag: This removes the tag but leaves the contents.

Change Tag: For example, you could change <h1> tags to <h2>.

Set Attribute

Remove Attribute

Add Before/After Start Tag: This inserts text or code immediately preceding or after
the opening tag.

Add Before/After End Tag: This inserts text or code immediately preceding or after
the closing tag.

Specific tag Find and Replace operations are particularly powerful when used in combina-
tion with regular expressions, which you’ll look into in more detail now.

Using regular expressions in searches

Regular expressions (often shortened to regexes) describe patterns of text and other
characters. They are like wildcard characters but much more powerful. Regular expressions
use character sequences known as metacharacters to represent different types of char-
acters that you want to match in a pattern. Table 5-1 lists the most commonly used.

Table 5-1. Commonly used character sequences in regular expressions

Sequence Meaning Sequence Meaning

\n Newline character * Match zero or more times

\r Carriage return + Match at least once

\w ? Match zero or one time

\d Number {n} Match exactly n times

\s Whitespace {n,} Match at least n times

. {x,y} Match at least x times, but
no more than y times

\. Period (dot) *? Match zero or more times
but as few as possible

^ Beginning of a string +? Match one or more times
but as few as possible

$ End of a string

Any character, except
new line

Alphanumeric character
or underscore
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Learning how to use regular expressions is not easy, but it’s a skill worth acquiring, because
regexes are widely used in programming languages such as JavaScript and PHP. There are
two types of regex: Perl-compatible regular expressions (PCRE) and Portable Operating
System Interface (POSIX). Dreamweaver uses the Perl-compatible type, which is more effi-
cient and also the preferred type in PHP. To learn more about regexes, see Regular
Expression Recipes: A Problem-Solution Approach by Nathan A. Good (Apress, ISBN: 978-1-
59059-441-4). The standard work (not for faint hearts) is Mastering Regular Expressions,
Third Edition by Jeffrey Friedl (O’Reilly, ISBN: 978-0-59652-812-6). You can also learn about
regexes online at www.regular-expressions.info, and there’s a repository of regexes
(some good, some not so good) at http://regexlib.com/.

In spite of the difficulty of regular expressions, as you’ll see from the following exercise,
they can do some amazing things.

Many designers like to display the alternate text of an image as a tooltip when the user
moves the mouse pointer over the image. Internet Explorer does this automatically with
the alt attribute, but this is actually incorrect behavior. Other browsers use the title
attribute instead. So, if the title attribute is missing, no tooltip appears. This exercise
shows you how to use regular expressions to copy the content of every image’s alt attrib-
ute to its title attribute.

1. Open search_me.html from the previous exercise in the Document window (it’s in
examples/ch05).

2. Select one of the images in Design view, and click the Split View button to inspect
the underlying code. You should be able to see that it contains an alt attribute but
not a title one. Do the same with the other image.

3. Launch the Find and Replace dialog box (Edit ➤ Find and Replace or Ctrl+F/Cmd+F).

4. Use the following settings:

Find in: Current Document

Search: Specific Tag

5. Activate the drop-down menu alongside Specific Tag, and select img.

Automatically adding a title attribute to images

There are a couple of important differences about the way Dreamweaver
uses regular expressions in the Find and Replace dialog box. Perl-compatible
regular expressions are normally enclosed in a pair of characters known as
delimiters (forward slashes are used the most frequently, but you can use
any nonalphanumeric character). You omit the delimiters when using a
regex in Dreamweaver. This also means you cannot use any of the modifiers
that follow the closing delimiter.
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6. Set the option immediately below to With Attribute (if there’s no option available
between Search and Action, click the plus button, and select With Attribute from the
menu that appears).

7. Select alt from the menu alongside With Attribute, set the comparison operator to
the equal sign (=), and enter (.+) in the next field. The opening parenthesis, period,
plus symbol, and closing parenthesis is a regex that copies any value as long as it
contains at least one character.

8. Select Set Attribute from the Action menu, select title from the drop-down menu
alongside, and enter $1 in the To field. $1 is a regular expression that contains the
value captured by the first regex.

9. Select the Use regular expression checkbox. The settings in the Find and Replace dia-
log box should now look like this:

10. Click Replace All. The Results panel should open and report that two replacements
have been made. Double-click one of them to confirm that the content of the alt
attribute has been copied to a new title attribute.

11. You’ll use the same file in the next exercise, so restore the page to its original state
by selecting File ➤ Revert and confirming that you want to abandon the changes.

Being able to copy the value of a tag’s alt attribute into its title attribute is pretty
impressive, but you probably don’t want to overwrite any existing title values. This exer-
cise improves on the settings used in the previous exercise to skip images that already
have a title attribute, thereby preserving the original value.

1. Continue working with search_me.html from the previous exercise. Let’s begin by
making sure that empty alt attributes aren’t copied.

2. Select one of the images in Design view, click the little arrow in the Alt field in the
Property inspector to open the drop-down menu, and select <empty>. This sets the
alt attribute to alt="".

Preventing an existing title from being overwritten
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3. Open the Find and Replace dialog box. Dreamweaver should have remembered the
previous settings, so click Replace All. If it hasn’t remembered the settings, use
those shown in step 9 of the previous exercise.

This time, the Results panel should report only one replacement. The image with
the empty alt attribute was ignored. That’s good but still not perfect. You need to
make sure that existing title attributes are not overwritten.

4. Restore the page to its original state by selecting File ➤ Revert.

5. Select one of the images. The Property inspector doesn’t have a field to set the
title attribute. You could use the Tag Inspector panel, but it’s probably quicker to
dive into Code view and add a title attribute to one of the images. It doesn’t mat-
ter what value you give it, as long as it’s different from the alt attribute.

6. Open the Find and Replace dialog box. It should still have the previous settings.

7. Click the plus button alongside With Attribute to add a new set of options. Set the
new options to Without Attribute and title. The settings should now look like this:

8. Click Replace All. This time, the Results panel should report just one replacement:
the image that you didn’t add a title attribute to. Check the other image to make
sure its original title is still intact.

9. You can close search_me.html without saving the changes, but don’t make any
changes to the settings in the Find and Replace dialog box just yet.

If you think that’s useful, it gets even better. You can store Find and Replace operations for
future use, as described in the next section.

Saving queries for future use

The two icons at the top right of the Find and Replace dialog box (see alongside)
are for working with stored queries. The icon that looks like a floppy disk
(remember them?) launches the Save Query dialog box. When you have a query you want
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to store for future use, click this icon, navigate to a folder where you want to store the
query (it doesn’t need to be in a Dreamweaver site), and give the query a name that will
help you remember what its purpose is. Dreamweaver automatically gives it a .dwr file
name extension. I have saved the query in step 7 of the previous exercise as add_title.dwr
in examples/ch05.

Crafting a regular expression to perform a complex query requires a lot of patience and
experimentation. Saving the query to a .dwr file can save a lot of heartache if you acci-
dentally delete the regex in the Find and Replace dialog box. Save early, and save often.

Once you have saved a query, all you need to do is click the icon that looks like a folder
with a sheet of paper protruding from it. This opens the Load Query dialog box. Navigate
to the folder where you keep your stored queries, select the one you want, and click Open.
Dreamweaver loads the query into the Find and Replace dialog box ready to run. That’s all
there is to it.

Using a stored query to remove CSS comments

Now that you know all about Find and Replace, regular expressions, and stored queries,
you can strip the verbose comments from the style sheet created by the Dreamweaver CSS
layout in the exercises in the first half of this chapter.

The regex to describe a CSS comment looks like this:

/\*[\s\S]+?(?=\*/)\*/

Because this regex is so useful—and easy to mistype—I have created a stored query to
automate the process. It’s called css_comment_remover_v3.dwr and is in the examples/
ch05 folder. Simply load it as described in the previous section. To remove all the CSS
comments in a single operation, click Replace All. This removes all comments, including
any CSS hacks that look like comments. If you’re in any way uncertain, remove the com-
ments selectively by clicking Find Next to highlight the first one. Then click Replace to
remove it or Find Next to move to the next one.

Dreamweaver always remembers your last Find and Replace operation, so these settings
will be displayed the next time you open the Find and Replace dialog box. Delete the reg-
ular expression from the Find field, and deselect the Use regular expression checkbox
(unless you plan to use another regex). This final point is very important. When a Find
operation fails for no obvious reason, it’s usually because you have selected the Use regular
expression checkbox by accident.

Chapter review
Depending on your knowledge of CSS, this chapter is likely to have been relatively easy or
something of a nightmare. If you fall into the latter category, I encourage you to persevere.
It can take a long time for CSS to sink in. If you find it difficult to understand how to build
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your own style sheets, download a page from a site you admire, complete with images and
style sheets. Then use the CSS Styles panel to change or delete individual properties.
Watch the effect of each change. Also select different parts of the page to analyze the cas-
cade of styles.

Mastering the CSS Styles panel takes time and patience, but it will reward you in the end.
Remember that Current mode shows the cascade as it affects the current insertion point or
selection. Use the Tag selector at the bottom of the Document window to highlight spe-
cific elements, and then use the Summary for Selection and Rules panes to drill down to the
CSS rules you want to inspect or edit.

You’ll get some more practice with the CSS Styles panel in the next chapter when you
integrate a Spry menu bar into the page layout. The menu bar and other Spry widgets
come with their own predefined style sheets, so you need to know how to adapt them to
blend in with your own design.
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