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The previous chapter showed you how to get content into a web page, but quite frankly,
the results look abysmal. Content may be king, but without a touch of style, it’s unlikely to
be able to compete for attention with the millions of other web pages out there.

Judging by the runaway success of books such as CSS Mastery by Andy Budd with Simon
Collison and Cameron Moll (friends of ED, ISBN: 978-1-59059-614-2), web designers
have finally got the message that using CSS is the way to design a website. Getting the
message is the easy part, but many designers rapidly find their initial enthusiasm takes a
severe dent when they run into the reality of creating a CSS-driven site. Creating a style
rule is simple enough, and most CSS properties have intuitive names. The difficulty lies
in the infinite number of ways in which style rules can be combined. And that’s what
makes it so powerful and worthwhile. You need only visit the CSS Zen Garden at
http://www.csszengarden.com to see why—the underlying HTML of every page is iden-
tical; what makes each one so different is the CSS.

Whether you’re capable of designing a masterpiece worthy of the CSS Zen Garden or just
a beginner, the embedded WebKit browser engine in Dreamweaver CS4’s Live view should
make life easier by showing you the impact of your style rules inside the Document win-
dow. Another welcome change is the way Dreamweaver no longer generates meaningless
class names, such as style1, style2, style45, and so on. Not only has the Property inspec-
tor been split into HTML and CSS views, but also the New Style Rule dialog box has been
redesigned to help you create CSS selectors with meaningful names.

This chapter puts into practice the theory from the previous chapter, and shows you how
to give basic styles to your unadorned content. It also looks at the main CSS management
tools in Dreamweaver CS4. In particular, it examines the CSS Styles panel. This extremely
powerful tool takes a little getting used to, but once you know how it works, it speeds up
the design process immensely.

In this chapter, you’ll learn about the following:

Using page properties to create basic style rules

Centering page content with a wrapper <div>

Exploring the CSS Styles panel in All mode

Exporting style rules to an external style sheet 

Attaching an external style sheet to a page

Using drag and drop to move style rules

Converting inline styles to style rules

Setting Dreamweaver preferences for CSS

Checking how your styles will look in other media

This chapter is much more hands-on than the other chapters so far, so get ready to roll
up your sleeves and dive into the program. All the necessary files can be found in the
examples/ch04 and images folders of the download files.
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Creating basic style rules
Dreamweaver is designed to suit many different workflows. Experienced designers will
often have a core set of style rules that is applied to every site, so they just need to link the
core style sheet to their pages, and they’re ready to go. Alternatively, they just open a new
CSS document and start creating style rules from scratch.

If you’re new to CSS, the Page Properties dialog box offers a simple interface to create basic
styles that are automatically applied to the entire page. It’s not capable of anything sophis-
ticated, but it does provide a gentle starting point. In addition to setting basic CSS style
rules, the Page Properties dialog box lets you change settings such as the HTML DOCTYPE and
encoding for the current page. So let’s take a quick look at the features it offers.

Modifying page properties

The quickest way to open the Page Properties dialog box is to click the Page Properties
button in the Property inspector whenever your cursor is inside text or an empty page.
Alternatively, select Modify ➤ Page Properties or press Ctrl+J/Cmd+J. As you can see in
Figure 4-1, six categories are listed in the column on the left side of the dialog box.

Figure 4-1. The Page Properties dialog box can be used to control the basic look of a page.

As mentioned in the previous chapter, the main focus of this book is on using
the tools in Dreamweaver CS4. To learn about CSS, refer to one of the books 
I recommended earlier.
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The focus of this chapter is CSS, so we’ll focus on the three categories labeled CSS. But
first let’s take a quick look at the other three categories that are not related to CSS.

Appearance (HTML): This sets the look of the page background, link styles, and mar-
gins using deprecated HTML attributes. It lets you alter the values on legacy pages,
but should not be used for new pages, unless there is a specific reason for using
HTML attributes instead of CSS (for example, creating an email newsletter).

Title/Encoding: This lets you change the page title, DOCTYPE, and encoding. Since the
page title is easily accessible through the Document toolbar, the only reason you
would ever want to use this option is to change the DOCTYPE or page encoding.

Tracing Image: Some designers like to use an image as a guide for laying out a page.
This option lets you add such an image to the page and control its transparency. It’s
important to realize that the image does not become part of the page. It’s purely a
layout guide and has nothing to do with CSS. If you want the image to appear in the
page, use the CSS background or background-image property. I’ll show you how to
add background images to page elements in the next chapter.

The best way to describe the CSS categories in the Page Properties dialog box is through a
hands-on exercise.

This exercise shows you how to import text from a Microsoft Word document (as
described in the previous chapter) and create a basic set of style rules for a page. As this
chapter progresses, you’ll build on this exercise to add images and other elements to the
page, and eventually export the style rules to an external style sheet so they can be applied
to other pages.

1. Create a new HTML file and save it as stroll.html in the workfiles/ch04 folder. If
you use File ➤ New to create the file, select Blank Page on the left side of the New
Document dialog box, HTML as the Page Type, and <none> as the Layout. If anything
is listed in the Attach CSS file field at the bottom right of the dialog box, select each
item and click the trash can icon to remove the style sheets listed there (the use of
the Attach CSS file field is described in the next chapter).

2. If you have a large monitor, you might find it useful to switch to Split view to keep
an eye on the code Dreamweaver creates. If you find Split view uncomfortable to
work in, select Design view. Whichever you choose, click inside the Design view sec-
tion of the Document window to ensure that it has focus.

Using page properties to create basic styles for a page

For all the exercises, I suggest that you create a folder called workfiles at the top level
of the site you are using with this book. Create a separate folder for each chapter inside
the workfiles folder, naming them ch04, ch05, and so on. If you encounter any prob-
lems, use the File Compare feature described in Chapter 2 to check your own files
against those in the equivalent subfolder of the examples folder in the download files.
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3. In Windows, select File ➤ Import ➤ Word Document, and navigate to examples/ch04
in the Import Word Document dialog box. Select either stroll.doc or stroll.docx
(they both contain the same content), set Formatting to Text, structure, basic format-
ting (bold, italic), and make sure that the Clean up Word paragraph spacing checkbox
is selected. Click Open to import the Word document.

If you’re using the Mac version, use Finder to navigate to examples/ch04, and open
either stroll.doc or stroll.docx. Select all the text and press Cmd+C to copy it
to your clipboard. Return to Dreamweaver, click in Design view to give it focus, and
paste the contents of the clipboard into stroll.html. If you have set Text with
structure plus basic formatting (bold, italic) for Copy/Paste in the Dreamweaver
Preferences panel (see Figure 3-7 in the previous chapter), just press Cmd+V (or
select Edit ➤ Paste) to paste the content with its basic structure and formatting.
Otherwise, press Shift+Cmd+V (or select Edit ➤ Paste Special) to bring up the Paste
Special dialog box, and select Text with structure plus basic formatting (bold, italic) and
Clean up Word paragraph spacing before clicking OK.

Your Document window should now look like Figure 4-2. The page has basic for-
matting, but lacks real style.
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Figure 4-2. Dreamweaver preserves the basic formatting of a document imported from Microsoft Word.



4. All web pages should have a title, so delete Untitled Document from the Title field in
the Document toolbar at the top of the Document window, and replace it with a
title of your choice. I used Creating basic styles.

5. Click the Page Properties button in the Property inspector as shown in the follow-
ing screenshot. It doesn’t matter whether you’re in the HTML or CSS view of the
Property inspector. If you can’t see the button, click the expander triangle at the
bottom right of the Property inspector.

Alternatively, select Modify ➤ Page Properties (Ctrl+J/Cmd+J).

6. This opens the Appearance (CSS) category of the Page Properties dialog box, as
shown in Figure 4-1. This sets the basic font, text color, and background for the
page. It’s a good idea to set a default font for the page, which you can override in
special cases, such as for headings or pull quotes. You also should set default col-
ors for the text and page background. However, you shouldn’t set the font size
here, even if you think the default size is too big. It’s usually much better to control
font size for different page elements. 

Use the following settings:

Page font: Trebuchet MS, Arial, Helvetica, sans-serif

Size: leave blank

Text color: #000 (if you click the color well, and select black from the color
swatches, Dreamweaver inserts the hexadecimal color for you automatically)

Background color: #FFF (white) 

Leave the other fields blank.

7. Select the Links (CSS) category from the column on the left. The Links (CSS) cate-
gory lets you set the font and colors for hyperlinks. The color options are the
equivalent of the following CSS pseudo-classes:

Dreamweaver CS4 uses shorthand hexadecimal numbers for colors wherever
possible. HTML and CSS normally specify colors using six-digit hexadecimal
notation, with each pair of digits representing the red, green, and blue elements
of the color. However, when both digits of each pair are identical, you can use
just one. So, #FFFFFF can be shortened to #FFF. To use the shorthand, all three
color elements must consist of an identical pair. So #006633 (dark green) can be
shortened to #063, but #006634 has no shorthand equivalent.

If your page looks completely different, check it against stroll_01.html
in examples/ch04. Also, if you can’t open the Word document, copy
stroll_01.html to workfiles/ch04, and rename the file stroll.html.
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Link color: a:link

Visited links: a:visited

Rollover links: a:hover

Active links: a:active

The Underline style option lets you choose whether your links are always under-
lined, never underlined, show an underline on hover, or hide the underline on
hover. If you decide not to underline links, it’s a good idea to choose a distinctive
color and select the Bold icon alongside Link font.

Use the settings shown in the following screenshot:

8. Select the Headings (CSS) category from the column on the left. This lets you
choose a different font for headings (the same choice applies to all six levels). You
can also set the size and color separately for each level. Using percentage sizes or
ems gives visitors more freedom to adjust your page to their visual needs and pref-
erences, so these choices are better from the accessibility point of view, but you
can use pixels if you prefer. 

I used the following settings:

9. When you have finished, click OK to close the Page Properties dialog box. Your
styles are immediately applied to the page in Design view. What’s more, they’re
applied automatically. 

An em is a typographical measure based on the width of the letter m. In CSS, it
means the height of the specified font. So, 1em is the default height, and .8em
is 80 percent of the default height. 

USING CSS TO ADD A TOUCH OF STYLE

161

4



10. Position your cursor anywhere inside the first paragraph, and select Heading 3 from
the Format menu in the HTML view of the Property inspector. The paragraph is trans-
formed into a large, brown Verdana. Select Paragraph again from the Format menu,
and it switches back to normal black Trebuchet MS or Arial. This is because the
Format menu changes the surrounding tags from <p> to <h3> and back again.
Everything is controlled by the CSS type selectors that Dreamweaver has embedded
into the <head> of the page. Type selectors change the default style of HTML tags.

11. Select some text in one of the paragraphs, and type # in the Link field of the HTML
view of the Property inspector to create a dummy link. The text is automatically
styled as a link. If you have been used to the old-school way of selecting everything
and applying colors and fonts, this should be an exciting revelation that convinces
you of the power of CSS.

12. Click the Live View button in the Document toolbar. You won’t notice much differ-
ence, if any at all. Now mouse over the dummy link you created in the previous
step. The color should change, and a line appears under the text, indicating that it’s
a clickable link.

13. Press F12/Opt+F12 to view the page in your primary browser. It should look similar
to Figure 4-3. It’s a little more stylish than before, but the text spreads across the
full page. It also needs livening up with some images.
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14. Save stroll.html. You’ll continue improving it throughout the chapter. If you want
to compare your code with the download files, check it against stroll_02.php in
examples/ch04.

Unfortunately, the Page Properties dialog box creates only the most basic rules. To improve
the look of the page, you need to add some structure with a <div> tag and create other
style rules with the CSS view of the Property inspector.

Before doing that, however, let’s take a look at where the Page Properties dialog box has
created the CSS for the page.

Inspecting the rules created by Page Properties

If you switch to Code view or Split view and scroll to the top of the underlying code, you’ll
see that the Page Properties dialog box has created a <style> block in the <head> of the
document, as shown in Figure 4-4. All the style rule definitions use type selectors. In other
words, they redefine the look of HTML tags. Consequently, they apply to any new element
that uses one of those tags.

Figure 4-4. The Page Properties dialog box embeds the style rules in the head 
of the page.
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This is extremely useful, but putting the rules in the <head> of the page like this means
that the styles apply only to the current page. The real value of CSS comes from using an
external style sheet that can be attached to every page in the site, instantly changing its
look. As you’ll see later in the chapter, Dreamweaver makes it very easy to export style
rules into an external style sheet. Before that, let’s continue exploring the tools for
creating CSS.

Inserting and styling a <div>

Text that spreads across the browser window is difficult to read. You could constrain the
width by adding the width property to the rules for paragraphs and headings. However, a
more common technique is to wrap the entire content in a <div> and apply a width to the
<div>. This has the advantage of letting you center the page within the browser. You can
also apply other styles, such as a background and border, to the <div>.

In this exercise, you’ll wrap the content of the page from the previous exercise in a
wrapper <div>, and create a style rule to constrain its width and center it. You’ll also
use Dreamweaver’s visual aids to examine the CSS box model. (If you’re not familiar
with the CSS box model, there’s a comprehensive and well-written explanation at
http://www.brainjar.com/css/positioning/default.asp.)

Continue working with stroll.html from the previous exercise. Alternatively, use
stroll_02.html from exercises/ch04 as your starting point.

1. Click <body> in the Tag selector at the bottom left of the Document window, as
shown in the following screenshot, to select the entire content of the page.

2. Click the Insert Div Tag button in the Common or Layout tab of the Insert bar (or
choose Insert ➤ Layout Objects ➤ Div Tag). In the dialog box that opens, Insert

Creating a wrapper <div>
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should automatically have been set to Wrap around selection. Type wrapper into the
ID field, and click the New CSS Rule button at the bottom of the dialog box as
shown in the following screenshot.

3. This opens the New CSS Rule dialog box shown in Figure 4-5. This is where you
define the type of CSS selector you want, its name, and where the rule will be
defined. I’ll explain this dialog box in the next section. For the moment, just check
that the settings are the same as in Figure 4-5. Then click OK.

Figure 4-5. The New CSS Rule dialog box is where you define the type of selector 
you want to use.
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4. The CSS Rule definition dialog box now opens. As shown in Figure 4-6, this is
another multiple category dialog box. As with the New CSS Rule dialog box, I’ll go
over how it works in the next section. For the moment, select the Box category in
the list on the left side of the dialog box.

Figure 4-6. The CSS Rule definition dialog box supports CSS 1 properties.

5. The Box category sets properties relating to the CSS box model. Set the Width field
to 720 px. No prizes for guessing that sets the width of the wrapper <div>.

Once a block-level element has a declared width, you can center it by setting its left
and right margins to auto. In the Margin section on the right side of the dialog box,
deselect the checkbox labeled Same for all. This lets you set different values for the
margin on each side. Click the down arrow to the side of the field labeled Right,
and select auto from the drop-down menu, as shown in the following screenshot.
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6. Do the same with the field labeled Left. So the values you have changed in the Box
category should be as follows:

Width: 720 px

Margin Same for all: unchecked

Margin Right: auto

Margin Left: auto

Leave the other fields blank.

7. Click OK to close the CSS Rule Definition dialog box. This returns you to the Insert
Div Tag dialog box. Click OK to close it.

8. Switch to Design view, if necessary. You should see the page content surrounded by
a dotted line and centered in the Document window. If you have a small monitor,
press F4 to hide the panels and see the effect more clearly. If you can’t see a dot-
ted line around the content, open the Visual Aids menu on the Document toolbar
(or select View ➤ Visual Aids), and check that you have the default settings as
shown in the following screenshot.

Each setting is toggled on and off by clicking it. A checkmark indicates that the
option is turned on. All visual aids should be turned on except CSS Layout
Backgrounds and Frame Borders.

The dotted line surrounding the content is purely a visual aid; it won’t appear in the
page when displayed in a browser. It indicates the extent and position of the wrap-
per <div> you have just created. As the screenshot of the Visual Aids menu shows,
you can hide all visual aids through the menu or by pressing Ctrl+Shift+I/
Shift+Cmd+I. Try it, and then restore the visual aids.

9. Move your cursor until it touches the dotted line surrounding the wrapper <div>.
When the line turns solid red, click once. This triggers the CSS Layout Box Model
visual aid, surrounding the wrapper <div> in a thick blue line, and displaying its
margins as a crosshatched pattern, as shown in Figure 4-7.
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Figure 4-7. Dreamweaver’s visual aids let you inspect CSS style rules.
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As you move your cursor around, different tooltips should appear, displaying details
of the CSS rule applied to that area. In Figure 4-7, my cursor was just to the right of
the wrapper <div>. The tooltip shows that the margin is set to auto; the figure in
parentheses is the calculated value (125px). It also shows that the border and
padding of the <div> are set to 0px. Again, these are calculated values, as indicated
by the parentheses. Neither value was set explicitly in the style rule you just created.

When you move your cursor inside the <div>, you should see a more detailed
tooltip with details of its style properties. Most values are blank because they
haven’t been set. Sometimes the tooltips seem to have a shy gene, so you might
need to move your cursor around a bit to trigger their appearance.

Notice that the Tag selector at the bottom left of the Document window shows the
ID you gave the <div> like this: <div#wrapper>. The tag is inset in the Tag selector,
indicating that this is the current selection. If you find it difficult to trigger the
visual aids by clicking the edge of a <div>, use the Tag selector instead.

10. To dismiss the visual aids, click anywhere inside the Document window.

11. Save stroll.html and press F12/Opt+F12 to preview it in your main browser. The
content should now be constrained to 720 pixels in width and centered in the
browser window. If you need to check your code, compare it with stroll_03.html
in examples/ch04.



This exercise introduced you to the New CSS Rule and CSS Rule definition dialog boxes.
These are important parts of the Dreamweaver tool set for creating style rules. The next
section describes their roles in greater detail.

Creating new style rules
Creating a style rule involves two steps: first define the selector, and then add
property/value pairs to the style block. The selector determines which parts of the page
the rule applies to.

The main types of CSS selectors are as follows:

Type: A type selector uses the name of the HTML tag that you want to style. For
instance, using h1 as the selector for a style rule applies the rule to all <h1> tags.
Dreamweaver calls this a tag selector.

Class: A class can be applied to many different elements in a page. The selector
name always begins with a period, for example, .warning.

ID: An ID selector applies the rule to an element identified by its id attribute. If the
element, such as a list, has child elements, the rule also applies to the children. The
name of an ID selector always begins with the hash sign (#), as in #wrapper.

Pseudo-classes and pseudo-elements: These selectors style elements according
to their positions or roles in a document, such as a link when the mouse passes
over it or the first line of a paragraph. They consist of a type selector followed by a
colon and the name of the pseudo-class or pseudo-element, for example, a:hover
or p:first-line.

Descendant: A descendant selector combines two or more of the previous types to
target elements more precisely. For instance, you may want to apply a different style
to links inside a <div> with the id attribute footer. Descendant selectors are sepa-
rated by a space between the individual parts of the selector, like this: #footer a.

Group: When you want to apply the same set of rules to several selectors, you can
group them together as a comma-separated list, as in h1,h2,h3,h4,h5,h6.

Dreamweaver refers to the last three types as compound selectors.

Defining a selector

You define the selector in the New CSS Rule dialog box (see Figures 4-5 and 4-8). There
are several ways to open this dialog box:

Select Format ➤ CSS Styles ➤ New from the main menus.

Click the New CSS Rule button in the Insert Div Tag dialog box (this is the method
you used in the previous exercise).

Click the New CSS Rule icon (shown alongside) at the bottom right of the 
CSS Styles panel.

Right-click inside the CSS Styles panel and select New from the context menu.
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Select the CSS view of the Property inspector, set the Targeted Rule drop-down
menu to <New CSS Rule>, and click the Edit Rule button directly below, as shown
in the following screenshot.

Previous versions of Dreamweaver automatically assigned meaningless class names, such
as style1, style2, and so on, when you used the Property inspector to style text.
Dreamweaver CS4 no longer does that. The New CSS Rule dialog box has been redesigned
in Dreamweaver CS4 to make it easier to choose the appropriate selector. Depending on
where your cursor is when you launch the dialog box, Dreamweaver tries to make a help-
ful suggestion. When I took the screenshot in Figure 4-8, the cursor was inside a paragraph
nested in the wrapper <div>. Consequently, Dreamweaver suggested creating a Compound
selector called #wrapper p. This is a much more useful selector, as it will be applied auto-
matically to every paragraph inside the wrapper <div>.

Figure 4-8. When creating a new style rule, you must specify its type, selector 
name, and location.
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Let’s take a look at the various options in the New CSS Rule dialog box.

Selector Type: This determines the type of CSS selector. You can choose from four
options:

Class (can apply to any HTML element): This creates a CSS class.

ID (applies to only one HTML element): This creates an ID selector.

Tag (redefines an HTML element): This creates a CSS type selector.

Compound (based on your selection): This is used for pseudo-classes, pseudo-
elements, and descendant and group selectors.

As you can see, the options are labeled in a helpful way to assist newcomers to CSS
by reminding them of the purpose of each type of selector.

Selector Name: This is where you enter the name for the CSS selector. When creat-
ing a class or an ID selector, it doesn’t matter whether you prefix the name with a
period (for a class) or a hash sign (for an ID selector); Dreamweaver automatically
adds the correct symbol if necessary. When creating a tag (or type) selector, the
field turns into a drop-down menu listing all valid HTML tags. You can either type
in the tag name (without any angle brackets) or select it from the menu.

The text area below the Selector Name field describes which elements will be
affected by the new style rule.

Less Specific: Dreamweaver automatically suggests a selector based on your cur-
rent insert position. If a descendant selector, such as #wrapper p, is suggested,
clicking this button creates a less specific selector by removing the leftmost ele-
ment. In the example shown in Figure 4-8, this removes #wrapper, leaving just p. In
a more deeply nested descendant selector, you can continue clicking to remove
one element at a time. The effect of the changes is described in the text area above
the button.

More Specific: This is grayed out by default, but is made active as soon as you edit
the suggested descendant selector by clicking the Less Specific button as just
described. It reverses the edits by restoring one element at a time. So, after remov-
ing #wrapper by clicking Less Specific, you can restore it by clicking the More
Specific button.

Rule Definition: This option lets you choose where to put the new rule. The drop-
down menu lists all style sheets currently attached to the page and contains an
option to create a new external file. If you choose (This document only), the style
rule is embedded within <style> tags in the <head> of the document.

When you click OK in the New CSS Rule dialog box, Dreamweaver opens the CSS Rule def-
inition dialog box, unless you decide to create the rule in a new style sheet. In that case,
you’re first asked to specify the name of the new file and where it is to be located.
Attaching style sheets is covered later in this chapter, in the “Attaching a new style sheet”
section.
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Defining the rule’s properties

As you discovered in the preceding exercise, the CSS Rule definition dialog box (see
Figure 4-6) is a multiple-category panel. Table 4-1 describes what each category contains.
Most are obvious; others less so.

Table 4-1. Properties that can be set in the CSS Rule definition dialog box

Category Properties covered

Type All font-related properties, plus color, line-height, and 
text-decoration

Background All background properties, including background-color and
background-image

Block word-spacing, letter-spacing, vertical-align, text-align,
text-indent, white-space, and display

Box width, height, float, clear, padding, and margin

Border All border properties

List list-style-type, list-style-image, and list-style-position

Positioning CSS positioning, including visibility, z-index, overflow, and clip

Extensions page-break-before, page-break-after, cursor, and nonstandard
filters

The CSS Rule definition dialog box is intended to make life easier for beginners, but the need
to hunt around in the different categories can be very frustrating and time-consuming. It
also lists only CSS1 properties, so you may end up looking for something that’s not there.

Fortunately, Dreamweaver CS4 now lets you create the new style rule without setting any
properties. Of course, a rule with no properties won’t have any effect on the way your
page looks, but you can add new properties to the empty style block through the CSS
Styles panel or by editing the style sheet directly in Code view.

Before exploring the CSS Styles panel, let’s add some extra style rules to the stroll.html
example from earlier exercises.

CSS is constantly evolving. The current version is CSS2.1, which adds a small number of
new properties, such as cursor and outline, to the core properties defined in CSS1.
Work is in progress on CSS3, and although it won’t be completed for many years,
Firefox, Safari, and Opera already support some of its features. 
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This exercise continues to improve the look of stroll.html by adjusting the line height,
text size, and margins of paragraphs. This demonstrates the use of the Targeted Rule field
in the CSS view of the Property inspector. You’ll also add images and wrap text around
them with simple CSS style rules.

Continue working with stroll.html from the preceding exercise. Alternatively, if you want
to jump in at this stage, use stroll_03.html from examples/ch04.

1. With stroll.html open in Design view, position your cursor inside one of the para-
graphs, and then click the CSS button on the left side of the Property inspector to
select the CSS view. The Property inspector should look like the following screenshot.

Adding paragraph margins and images 
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The Targeted Rule field indicates which rules will be affected by any changes you
make in the CSS view of the Property inspector. It also controls which rule is edited
when you click the Edit Rule button. Make sure that the Targeted Rule field is set to
#wrapper.

When you created the #wrapper style rule in the previous exercise, the only proper-
ties you set controlled the width and the left and right margins. However, the
Property inspector shows the font family, color, and size. This is because the wrap-
per <div> inherits the rules set in the Page Properties dialog box in the first exercise. 

2. Change the Size setting to 85, and then press Enter/Return to apply the new value.
This reduces the size of not only the text in the paragraphs, but also of the headings
(if you get giant text instead, make sure that the drop-down menu alongside the Size
field is set to %). The headings are affected because the Targeted Rule is #wrapper.

3. Switch to Code view and scroll up to find the <style> block. The #wrapper rule
looks like this:

#wrapper {
width: 720px;
margin-right: auto;
margin-left: auto;
font-size: 85%;

}

Changing the Size value in the Property inspector with #wrapper selected as
Targeted Rule has added the font-size property to the style rule. CSS inheritance
will apply this rule to everything in the wrapper <div>, causing potential difficulties,
so delete the line highlighted in bold. 

4. Switch back to Design view, and position your cursor inside one of the paragraphs
again. The values in the CSS view of the Property inspector should look like the
screenshot in step 1 again.



5. Click the down arrow to the right of the Targeted Rule field, and select <New CSS
Rule> from the menu as shown in the following screenshot.

6. Click the Edit Rule button to open the New CSS Rule dialog box. Dreamweaver
automatically suggests a Compound (descendant) selector called #wrapper p (see
Figure 4-8, shown earlier).

7. Click OK to open the CSS Rule definition dialog box. In the Type category, set Size to
85, and select % from the drop-down menu alongside.

Also set Line height to 1.4, and select multiple from the drop-down menu alongside.
This adds vertical space between the lines of the paragraph to make the text easier
to read. You can use pixels or percent to set the line-height property, but I find
that choosing multiple gives the most reliable results.

8. Select the Box category from the column on the left side of the CSS Rule definition
dialog box. This category lets you define such properties as width, padding, and
margin. Both Padding and Margin have a checkbox labeled Same for all, which is
selected by default. This applies to all sides whatever value you enter in the Top
field. Let’s put a wide margin on both sides of each paragraph, but not on the top
and bottom. Deselect the checkbox for Margin, and enter the following values:

Top: 0 px

Right: 20 px

Bottom: 8 px

Left: 40 px

By setting the top margin to 0 and the bottom one to 8 pixels, you’ll get good spac-
ing between paragraphs. Setting the left margin to 40 pixels indents the text nicely
in comparison with the headings.

9. Click Apply to view the effect of the new style rule for paragraphs. If you need to
get a better view of the Document window, move the CSS Rule definition dialog box
to one side. If you want to make any changes to the settings, do so, and then click
OK to close the CSS Rule definition dialog box.

10. Let’s liven the page up with a couple of images. Insert living_statues.jpg any-
where inside the first paragraph and graffiti.jpg inside the paragraph following
the Artists at Work heading. Both images are in the images folder of the download
files. (Refer to Chapter 3 if you need a refresher on how to insert images.)

11. To wrap text around images, you need to float the image either left or right and
add a margin on the opposite side to leave some breathing space between them.
You’ll now create two classes that can be applied to any image.
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If an image is selected in Design view, the CSS view of the Property inspector is not
visible. Deselect the image and repeat step 5 to select <New CSS Rule> in the
Targeted Rule field, and then click Edit Rule to open the CSS Rule definition dialog
box. Alternatively, use any of the other methods listed in the “Defining a selector”
section earlier in the chapter.

12. In the New CSS Rule dialog box, select Class (can apply to any HTML element) in the
Selector Type drop-down menu. This clears any suggested value from the Selector
Name field. Type floatleft in the empty field. Make sure that Rule Definition is set to
(This document only), and then click OK.

13. In the CSS Rule definition dialog box, select the Box category, and set Float to left.
Deselect the Same for all checkbox for Margin, and set Right to 10 px. Leave all other
settings blank. This aligns any element that uses the floatleft class to the left of
its parent element and puts a 10-pixel margin on the right side. This is much more
flexible than using the HTML hspace attribute, which puts the same amount of
space on both sides. The advantage of CSS is that you can put a different margin on
each side. Click OK to save the new class rule.

14. Select one of the images in Design view, and open the Class drop-down menu on
the right side of the Property inspector. This lists all classes defined in your styles.
Select floatleft, as shown in Figure 4-9.

When typing the name of a class in the New CSS Rule dialog box, you can omit
the leading period. This is a change from previous versions of Dreamweaver.
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Figure 4-9. To apply a class to the current element, select the class from the Class field in 
the Property inspector.



The image should now be flush with the left margin of the paragraph. The text
flows naturally around the image, with a comfortable 10-pixel margin.

15. Repeat steps 11–14 to create another class called floatright. For this class, set the
value of Float to right, and create the margin on the left. Apply the new class to the
other image.

16. Save stroll.html and press F12/Opt+F12 to view it in your main browser. It should
now look like Figure 4-10. It’s still relatively plain, but it looks a lot more stylish
than the original version. If you want to check your version, compare it with
stroll_04.html in exercises/ch04.
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Figure 4-10. With the help of basic style rules, the page is beginning to look much better.



If you found hopping around in the CSS Rule definition dialog box tedious and repetitive,
you’ll be pleased to know that Dreamweaver CS4 makes it easy to work directly with style
rules through the CSS Styles panel and the Code Navigator. The Code Navigator, which is
new to Dreamweaver CS4, was described in Chapter 1. The next section introduces you to
the powerful CSS Styles panel.

Introducing the CSS Styles panel
To get the most out of the CSS Styles panel, you need a solid understanding of CSS.
Although that statement is likely to provoke sighs of despair—or even anger—from read-
ers expecting Dreamweaver to do everything for them, it’s true of any tool or piece of
software. The greater your understanding of the tools you’re working with, the easier the
job becomes. Also, with a little persistence, using the CSS Styles panel should help begin-
ners improve their skills, because it shows you exactly which rules affect a particular part
of the page. And even if the theory behind CSS taxes your brain, you can quickly check
how your page will look in a standards-compliant browser by switching on Live view.

Over the next few pages, I’ll explain the key features of the CSS Styles panel in preparation
for using it to style one of Dreamweaver’s preinstalled CSS layouts in the next chapter.

Opening the CSS Styles panel

To open the CSS Styles panel, double-click the CSS Styles tab at
the top right of the screen in the Classic workspace, or click the
CSS Styles icon (shown alongside) if you’re using iconic mode.
Alternatively, select Window ➤ CSS Styles. On Windows, there’s
also the keyboard shortcut Shift+F11. (Mac keyboard shortcut
enthusiasts are out of luck, because the same combination runs
Exposé in slow motion on OS X.)

Viewing All and Current modes

The CSS Styles panel has two modes, All and Current, which are toggled by clicking the but-
ton at the top of the panel. Figure 4-11 shows both modes with an explanation of the
icons at the bottom of the panel and in the middle pane of Current mode. Current mode
(on the right of Figure 4-11) is more powerful, but it’s also more complex, so beginners
should try to get used to working in All mode first.

A good way of regarding All mode is as a window into all CSS rules available to the page,
regardless of whether they are embedded in the <head> of the document or in multiple
external style sheets. The top pane (labeled All Rules) displays the hierarchy of style rules as
a tree menu. If the rules are embedded in the <head> of the document, the root of the tree
(at the top) is displayed as a <style> tag, as in Figure 4-11. If they’re in an external style
sheet, the file name appears at the root. The tree menus are collapsible to make it easier to
work when multiple style sheets are attached to the page. The only style rules that you can-
not inspect or edit in All mode are inline styles, although you can see them in Current mode.
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Figure 4-11. The CSS Styles panel crams a lot of tools and information into a small space.
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The Properties pane at the bottom of the CSS Styles panel is common to both modes. It
displays details of the currently selected style rule and lets you edit or delete properties
and add new ones.

Use All mode when you need to do any of the following:

View the overall structure of the styles attached to a page.

Change the order of rules.

Inspect or edit the contents of a style rule identified by its selector.

Add a new style rule (you can do this in both modes).

Attach a style sheet to the current page (this is one of several places you can do this).

Don’t confuse the Properties pane of the CSS Styles panel with the Property inspector,
which is normally docked at the bottom of the Document window. If you’re not familiar
with Dreamweaver, the names are easy to mix up, because the title bar of the Property
inspector says Properties. When working with CSS, any reference to the Properties pane
means the pane at the bottom of the CSS Styles panel as shown in Figure 4-11.



I’ll describe the features of Current mode in the next chapter. For the moment, let’s take
a look at the seven icons at the bottom of the CSS Styles panel, as they apply to both
modes.

Exploring the Properties pane of the CSS Styles panel

The default setting of the Properties pane is to display only those CSS properties that have
been set in a particular style rule, as shown in Figure 4-11. However, the two leftmost icons
let you display properties grouped by category or alphabetically.

Displaying CSS properties by category
If you select the leftmost icon (see alongside) at the bottom of the CSS Styles
panel, the Properties pane lists all available CSS properties grouped together in
easily identifiable categories, as shown in Figure 4-12. If you’re new to CSS and find it dif-
ficult to remember the names of the various properties, I recommend that you use this
display until you gain sufficient confidence to use the less cluttered default view.

Click the plus (+) and minus (–) symbols (triangles in the Mac version) to expand or close
each category, and click in the right column alongside the property name to edit it. If a
fixed range of options is available, a drop-down menu appears. Similarly, a folder icon or
color picker appears if the property requires a pathname or color. To remove a property,
highlight it and click the trash can icon at the far right. Unlike the default display, the
property remains listed, but the value is deleted. 

Displaying CSS properties alphabetically
Clicking the middle icon (shown alongside) at the bottom left of the CSS Styles
panel lists virtually all available CSS properties in alphabetical order, as shown in
Figure 4-13. Properties that have already been set move to the top of the list. To set 
a new one, you need to scroll down to find it, making this view the least user-friendly.

Figure 4-12.
Displaying all available CSS
properties organized by
category makes life easier
for beginners.
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This alphabetical list omits a small number of poorly supported CSS properties, such as
counter-increment and counter-reset, but as you can see from Figure 4-13, nonstan-
dard properties beginning with -moz are also listed. These are supported mainly by Firefox
and Mozilla, but are expected to become part of CSS3. Dreamweaver also lists some
Microsoft-only properties, such as layout-grid, and properties that were dropped from
the CSS2.1 specification, such as font-stretch. This wide choice is useful if you are a CSS
expert, but could lead you astray if you’re a novice. Use the alphabetical display with care.

Displaying only CSS properties that have been set
To restore the Properties pane to its default display of only those properties that
have been set (see Figure 4-11), click the third icon from the left at the bottom of
the CSS Styles panel (shown alongside).

Attaching a new style sheet
The chain icon (shown alongside) at the bottom right of the CSS Styles panel
opens the Attach External Style Sheet dialog box (see Figure 4-14). This lets you
attach the file using either <link> or @import and set the media type.

The File/URL field lists recently used style sheets in a drop-down menu. Click the Browse
button to navigate to a new style sheet. If you type the file name of a nonexistent style
sheet in the File/URL field, Dreamweaver displays a warning, and asks if you want to create
the link/import statement anyway. If you click Yes, you can create the necessary style sheet
afterward, and it becomes immediately available inside your page.

Normally, you can leave the Media field empty. If you do so, browsers apply your styles to
all media. However, if you want to create separate style sheets for different purposes,
such as mobile devices and print, select a media type from the drop-down menu in the
Media field, or enter a comma-separated list of any of the following media types: all,
aural, braille, handheld, print, projection, screen, tty, and tv. Use screen for visual
browsers, or all to apply your styles to all types of media.

Figure 4-13.
You can also display all available

CSS properties in alphabetical order.

THE ESSENTIAL GUIDE TO DREAMWEAVER CS4 WITH CSS,  AJAX,  AND PHP

180



Figure 4-14. You can attach an external style sheet using <link> or 
@import.

If you choose a media type other than screen or all, use the Style Rendering toolbar,
which is described later in this chapter, to see the effect of your styles in Design view.

Adding, editing, and deleting style rules
The final three icons at the bottom right of the CSS Styles panel let you add new rules,
edit existing rules, and delete existing rules and properties. Most editing and deletion is
done directly in the CSS Styles panel, and I’ll show you how to do that in the next chapter.

Moving style rules
All the rules you have created in the exercises so far are in the <head> of the document, so
they apply only to the current page. The real value of CSS lies in the ability to apply the
same styles to an entire website by storing the rules in one or more external style sheets.
That way, any change to the external style sheet is propagated throughout the site. It also
reduces page size because the browser caches the style sheet the first time it loads.
Moving style rules is a breeze, because Dreamweaver automates the process for you. 

Exporting rules to a new style sheet

If you have CSS style rules defined in a document, you can easily move them into an exter-
nal style sheet. The best way to show you how this works is with a hands-on exercise.

There are several other ways of attaching external style sheets. As you’ll see in the next
chapter, you can attach style sheets in the New Document dialog box when first creat-
ing a page. There is also an option to attach a new style sheet at the bottom of the
Class drop-down menu in the HTML view of the Property inspector and in the New CSS
Style dialog box (see Figure 4-8).
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This exercise shows you how to move the style rules from the <head> of the page that
has been used in the exercises throughout this chapter into an external style sheet. If
you have been doing the exercises, continue working with stroll.html. Otherwise, use
stroll_04.html from examples/ch04.

1. With stroll.html open in the Document window, open the CSS Styles panel and
select All mode, as described in the preceding section. 

2. If necessary click the plus (+) icon (disclosure triangle on a Mac) alongside <style>
to expand its contents. Use Shift-click to select all the style rules, as shown in the
following screenshot.

3. Right-click and select Move CSS Rules from the context menu. This brings up the
following dialog box.

4. In the Move To External Style Sheet dialog box, select the radio button labeled A new
style sheet, and then click OK.

5. In the next dialog box, navigate to the workfiles/ch04 folder, and save the new
style sheet as stroll.css.

Moving embedded styles
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6. Check the CSS Styles panel. The styles should now be listed below stroll.css, as
shown in the following screenshot.

7. Check the Document window. The Related Files toolbar has been added between
the document tab and Document toolbar, as shown in the following screenshot.
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8. Click stroll.css in the Related Files toolbar. Dreamweaver switches to Split view, with
the external style sheet in the Code view section and the main page in the Design
view section, as shown in the following screenshot.



9. Click Source Code in the Related Files toolbar. This displays the source code of
stroll.html in Code view. Scroll to the top of the document. In the <head> sec-
tion, you’re now left with an empty <style> block followed by a <link> tag to the
external style sheet, as the following screenshot shows.

10. To get rid of the empty <style> block shown on lines 6–9 in the preceding screen-
shot, you can delete it manually in Code view. Alternatively, select <style> in the
CSS Styles panel in All mode, and then press Delete.

If you want to examine the finished files, they’re stroll_05.html and stroll.css
in examples/ch04.

The preceding exercise demonstrated how to move all rules from the <head> of a page
using the CSS Styles panel. You can also use the Move CSS Rules command in Code view.
Highlight the rules you want to move, right-click, and select CSS Styles ➤ Move CSS Rules
from the context menu. When moving a single rule, you don’t need to highlight the whole
rule. Your cursor can be anywhere inside the rule you want to move. Dreamweaver treats
partial selection of a rule as affecting the whole rule.

Moving rules within a style sheet

Whenever you add a new style rule through the New CSS Rule and CSS Rule Definition dia-
log boxes, Dreamweaver puts it at the bottom of the style sheet. To take advantage of the
cascade order, or simply to group your rules in a more logical way, you need to be able to
move them. Nothing could be easier.

Simply highlight the rules you want to move (use the 
Shift or Ctrl/Cmd key to select multiple rules), and drag
and drop them within the top pane of the CSS Styles
panel in All mode. As the following screenshot shows,
the mouse pointer turns into a document icon while
dragging. The thick blue line indicates where the rule(s)
will be located when you release the mouse button.

Moving rules between external style sheets

The ability to drag and drop style rules doesn’t apply only to rules within the same style
sheet or <style> block. If more than one style sheet is attached to a page, you can move
them at will from one to another. 
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The following exercise demonstrates the power of this feature. Not only are the style rules
moved, any change in the cascade is immediately reflected in Design view.

1. Open move_styles.html in examples/ch04. Open the CSS Styles panel in All mode,
and expand the tree menus for both style sheets. The page should look like this:

Changing the look of the page by moving style rules
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In All mode, the CSS Styles panel displays CSS selectors in the same order that they
are applied to the page. As you can see from the preceding screenshot, the first
style sheet contains two rules (for body and h1), and the second one contains only
a rule for h1. If you inspect the properties for h1 in the Properties pane, you will see
that the first style sheet sets the color to maroon, but the second one sets it to
deep blue. Because the second rule is lower in the cascade, it takes precedence.
That’s why the page heading in Design view is deep blue.

2. Drag the h1 selector from the first style sheet to immediately below the h1 selector
in the second style sheet. Dreamweaver detects a conflict and displays the follow-
ing dialog box so that you can compare both versions of the rule.



When a rule with the same name exists in the target style sheet, the rule being
moved is displayed in the left panel, and the rule in the target style sheet is shown
on the right. If you click Yes, Dreamweaver preserves the rule in the target style
sheet and inserts the rule being moved alongside it.

Selecting No instructs Dreamweaver not to move the rule currently displayed but
to carry on with the rest of the operation. Cancel tells Dreamweaver to abandon
the operation, and no rules are moved. If you select the checkbox labeled Use this
decision for all remaining conflicts, the Yes and No buttons are treated as Yes to All
and No to All.

3. Click Yes. The page heading should immediately turn maroon in Design view. An
asterisk is inserted alongside the names of the two style sheets in the Related Files
toolbar to indicate that they have been changed. When you close move_styles.html,
you will be asked if you want to save the changes to the style sheets. Dreamweaver
always reminds you if changes have been made to related files, but it’s up to you
whether to make the changes permanent.

The ability to move and edit style rules without ever needing to leave Design view makes
Dreamweaver a very powerful tool for creating websites with CSS.

Moving inline styles to a style sheet

Unless you need to create HTML email, inline styles are the most inflexible way of applying
CSS. As the name suggests, an inline style is a style rule embedded in the target element’s
opening tag. For example, the following paragraph has an inline style that displays its con-
tent as 12-pixel, bold, red Arial, Helvetica, or sans-serif:

<p style="color: #F00; font-weight: bold; font-size: 12px; font-family:
Arial, Helvetica, sans-serif;">The styles affect only this para.</p>

Using inline styles is inefficient because only one element is affected, and the properties in
an inline style always override any other rules.

Dreamweaver makes it easy to extract the properties from inline styles and convert them
into an ordinary style rule in the <head> of the page or an external style sheet. Use the Tag
selector to select the tag that contains the rule you want to convert, right-click, and select
Convert Inline CSS to Rule from the context menu. Alternatively, position your cursor any-
where inside a tag that contains an inline style, right-click, and select CSS Styles ➤ Convert
Inline CSS to Rule. In Code view, you can also use the Move or Convert CSS button on the
Coding toolbar (see Figure 1-31 in Chapter 1). The dialog box that opens lets you choose
whether to create a new class or define your own CSS selector. You can also choose where
to create the new rule.

This feature is particularly useful for cleaning up pages that have absolutely positioned ele-
ments defined using inline styles (layers in Dreamweaver MX 2004 or earlier). You can con-
vert only one layer at a time, but it’s a much quicker and more accurate way of tidying up
legacy pages than attempting to cut and paste everything manually. It doesn’t matter
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whether you’re in Code view or Design view; as long as your cursor is anywhere inside the
absolutely positioned element, just right-click and select CSS Styles ➤ Convert Inline CSS
to Rule from the context menu. Dreamweaver presents you with the Convert Inline CSS
dialog box, as shown in Figure 4-15. 

Figure 4-15. As long as your cursor is inside a layer, Dreamweaver can move the inline 
styles to an external style sheet or the head of the document.

Dreamweaver automatically chooses the ID as the name of the selector for the new rule.
Although you can change the name in the dialog box, this affects only the new style rule.
It doesn’t change the ID of the <div>. The Convert to drop-down menu at the top left of
the dialog box has two other options: to create a class based on the inline styles or to
apply the styles to all <div> elements. They are for converting other inline styles and
should not be used when converting old-style absolutely positioned elements. You can test
this feature using layers.html in examples/ch04.

Creating inline styles for HTML email

Not all email programs are capable of displaying CSS correctly, so it’s a common practice
to revert to <font> tags and other old-style formatting techniques to create the content
for HTML email. In previous versions of Dreamweaver, switching back temporarily to HTML
formatting was easy: you just deselected the option in the General category of the
Preferences panel to use CSS instead of HTML tags. When you had finished creating the
content for HTML email, you turned the option back on, and continued working with CSS.
However, that option has been removed from the Preferences panel in Dreamweaver CS4,
leaving no easy way of creating <font> tags apart from hand-coding them in Code view.
The solution is to use inline CSS, which most, if not all, email programs support.

To create inline CSS, select the element you want to style. Then, in the CSS view of the
Property inspector select <New Inline Style> in the Targeted Rule drop-down menu, and
click the Edit Rule button, as shown in the following screenshot.
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This opens the CSS Rule definition dialog box (see Figure 4-6 and Table 4-1), where you can
define the properties for the inline style.

Inline styles are automatically copied to the next paragraph when you press Enter/Return
to create a new paragraph.

Setting your CSS preferences
Developers have individual ways of working, and Dreamweaver tries to accommodate
most common preferences. Two sections of the Preferences panel (Edit ➤ Preferences, or
Dreamweaver ➤ Preferences on a Mac) control the way Dreamweaver handles CSS:

The CSS Styles category of the Preferences panel (see Figure 4-16) controls the cre-
ation and editing of style rules.

The Code Format category of the Preferences panel also lets you determine how
style rules are laid out. 

Figure 4-16. My personal preferences for the way style rules are created and edited

First, let’s take a look at the options in the CSS Styles category.



Creating and editing style rules

There are two ways of writing style rules for font, background, margin, padding, border, and
list-style: the long way and shorthand. For example, the following style rules both have the
same meaning:

/* long way of declaring font and margin properties */
p {
font-family: Arial, Helvetica, sans-serif;
font-size: 85%;
line-height: 1.4;
margin-top: 0;
margin-right: 5px;
margin-bottom: 5px;
margin-left: 15px;

}
/* shorthand version of preceding example */
p {
font: 85%/1.4 Arial, Helvetica, sans-serif;
margin: 0 5px 5px 15px;

}

The advantage of the long way of declaring these properties is that the meaning is crystal
clear. The disadvantage is that it makes your style sheets much longer. The shorthand version
is more compact, but it comes at a price: you need to remember the correct order of the
property values. For margin and padding, it’s easy: they start at the top and go in a clockwise
direction—top, right, bottom, and left. The shorthand for border is also easy: the width,
style, and color properties can go in any order. As shown in Figure 4-16, the CSS Styles
category of the Preferences panel lets you choose the default way of writing these rules. My
preference is to use shorthand for margin, padding, and border only.

The next set of options lets you specify whether to use shorthand when editing existing style
rules. If you’re working as part of a team, the first option (If original used shorthand) prevents
Dreamweaver from messing up the styles used by your colleagues. If you’re on your own,
choose the second option so that Dreamweaver converts style rules to your own preferred
format.

The checkbox labeled Open CSS files when modified makes a critical difference to the way
Dreamweaver handles changes to an external style sheet. What happens depends on whether
Related Files is enabled or disabled.

With Related Files enabled, if you select Open CSS files when modified, Dreamweaver tracks
changes in external style sheets and marks the file in the Related Files toolbar as having
changed. You can undo the last change by selecting the style sheet’s name in the Related Files
toolbar and pressing Ctrl+Z/Cmd+Z or selecting Edit ➤ Undo. To undo all changes, close the
main file, and click No when prompted to save the changes to the style sheet. If you deselect
Open CSS files when modified, Dreamweaver automatically saves any changes to external style
sheets. There is no way to undo them. However, if you open the external style sheet in Split
view by selecting its name in the Related Files toolbar, all subsequent changes are tracked and
undoable.
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With Related Files disabled, if you select Open CSS files when modified, Dreamweaver opens
the external style sheet in a new tab, but leaves the focus in the main page. You can undo
any changes by selecting the tab that contains the style sheet. If you deselect Open CSS
files when modified, changes are made silently to the external style sheet and automatically
saved. There is no way to undo them.

The final section lets you choose what happens when you double-click inside the CSS
Styles panel. The first option, Edit using CSS dialog, opens the CSS Rule definition dialog box
(see Figure 4-6) described earlier in the chapter. This dialog box can be helpful, but I don’t
recommend its use on a regular basis. The most useful option is the last one, Edit using
code view. This opens the style sheet in the Document window and positions your cursor
inside the selected rule, ready to edit it.

Setting the default format of style rules

To control the way your style rules are laid out, select the Code Format category in the
Preferences panel, and click the CSS button in the Advanced Formatting section. This opens
the CSS Source Format Options dialog box (see Figure 4-17).

Figure 4-17. The CSS Source Format Options dialog box controls how 
style rules are formatted.

In previous versions of Dreamweaver, I preferred Dreamweaver not to open CSS files
when modified, because I found it a nuisance to save the style sheet every time I wanted
to preview my page in a browser. However, Dreamweaver CS4 lets you preview the
effects of changes in Live view without saving the style sheet. So, selecting the option to
open CSS files when modified makes it much easier to undo the changes if you don’t like
the effect.
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The options are self-explanatory, and the Preview panel at the bottom of the dialog box
shows you what your selections will look like. Click OK to close the dialog box, and click
OK to save your new preferences. All new style rules will use the new settings.

To apply your format preferences to existing style sheets, open the style sheet, and select
Apply Source Formatting from the Commands menu. This is an all-or-nothing option: you
can’t apply the formatting to a selection. Dreamweaver is smart enough to apply the CSS
format options to <style> tags in the <head> of a page, but it ignores styles inside condi-
tional comments (covered in the next chapter).

Checking how styles will look in other media
Many people think of style sheets in terms of “one size fits all”—in other words, they cre-
ate one set of style rules and hope that the site will look just as good in every medium.
However, you can specify different style sheets for a variety of media. Style sheets for ordi-
nary browsers (screen), print, and handheld devices have the best support. By default,
Dreamweaver Design view and Live view show your page as it will look in a visual browser,
but the Style Rendering toolbar and Device Central let you check what your page will look
like with style sheets designed for other media.

Using the Style Rendering toolbar

One of Dreamweaver’s best-kept secrets—because it isn’t enabled by default—is the Style
Rendering toolbar (see Figure 4-18). It’s indispensable if you work with style sheets for dif-
ferent types of media. To enable it, select View ➤ Toolbars and choose Style Rendering.

The Style Rendering toolbar lets you see the effect of each media style sheet in Design
view. It also allows you to disable CSS entirely, so that you can see the logical flow of your
web page in the same way that it would be presented to a search engine or a visually dis-
abled person using a screen reader.

The Design-time Style Sheets button gives direct access to the Design-time Style Sheets dia-
log box, giving you control over which style sheets are applied or hidden while working in
Design view. This allows you to view two or more style sheets in combination, whereas the
Style Rendering toolbar selects only one at a time. Design-time style sheets are covered in
Chapter 12.

Figure 4-18.
The Style Rendering toolbar
displays the effect of different style
sheets without leaving Design view.
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If you prefer working with menus, you can access the Style Rendering submenu from the
View menu. You can also access the Design-time Style Sheets dialog box by selecting Format
➤ CSS Styles ➤ Design-time.

Using Device Central CS4

In addition to Live view and launching a variety of browsers from within Dreamweaver to
preview your website, you can see how it will look in a mobile device by launching Adobe
Device Central CS4. This is a separate program shared by most programs in the Adobe
Creative Suite, which is installed at the same time as Dreamweaver unless you deselected
it during the installation setup. Figure 4-19 shows how Device Central emulates the display
of stroll.html in a generic mobile device, but you can choose skins from all the main
mobile phone manufacturers from the Device Central online library.
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Figure 4-19. Device Central lets you see what your site will look like in a wide range of mobile devices.



You access Device Central by selecting File ➤ Preview in Browser ➤ Device Central. The key-
board shortcut (Ctrl+Alt+F12/Ctrl+Opt+F12) is easy to remember because it’s so similar to
the shortcut for previewing in your default browser (F12/Opt+F12). The display in Device
Central is interactive, so you can use the mobile keypad and click links to navigate to other
pages. Although Device Central is intended to be used as an emulator in a development
environment, you can also view live pages on the Internet. Just type the website address
into the URL field in the right panel and press Enter/Return.

Chapter review
This chapter has shown you how to create basic style rules in Dreamweaver and covered
the main CSS tools in Dreamweaver. The next chapter builds on that knowledge by adapt-
ing one of the 32 built-in CSS layouts in Dreamweaver. You’ll also learn about using the
CSS Styles panel in Current mode, a powerful tool for analyzing the effect of the cascade
within your style sheets.
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