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When you create a new web page in Dreamweaver, it presents you with a blank canvas.
Although it shares a common interface with graphical design programs in the Adobe
Creative Suite, it doesn’t work like a desktop publishing program. If you attempt to drag
and drop elements onto the page and move them round without understanding what’s
happening to the underlying code, you’ll end up banging your head against the keyboard
with frustration. To create a web page, you need to know the basics of inserting and
organizing elements on the Dreamweaver page. 

In this chapter, you’ll learn about the following:

Inserting text, images, and Flash and Flex movies

Using Photoshop Smart Objects as images

Adding structure to text with headings, paragraphs, and lists

Creating tables to display data

Importing and exporting table data

Inserting <div> tags to organize content in a logical structure

Creating links with text and images

Creating an image map 

This chapter is aimed mainly at newcomers to Dreamweaver. It concentrates on the
mechanics of adding content in the Document window. If you’re upgrading from a previ-
ous version of Dreamweaver, most of this material should be familiar. However, you will
want to learn about the important changes to the way Flash and Flex movies are inserted,
as well as the redesign of the Property inspector to separate HTML structural elements
from the creation of CSS style rules.

This chapter doesn’t contain any formal exercises, but you can use the files in the
examples/ch03 and images folders (available for download) to practice the techniques
described. Most of the techniques covered in this chapter will form the basis of hands-on
exercises in the next chapters, which show you how to style your raw content with CSS.

Creating a new document
Dreamweaver can create a wide variety of document types, and you have several ways to
start your new document.

As explained in Chapter 1, Dreamweaver CS4’s UI is highly configurable.
For consistency, all screenshots in this and the remaining chapters have
been taken using the preset Classic Workspace layout and the tabbed
interface of the Insert bar. To avoid repetition, references to a particular
tab on the Insert bar apply to the menu category of the same name on the
Insert panel.
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Starting from the Welcome screen

The easiest way to create a new document is to select the type of page you want from the
Create New list in the center of the Dreamweaver Welcome screen (see Figure 3-1). This
list includes the most frequently used types of documents. 

If you choose one of the first four types (HTML, ColdFusion, PHP, or ASP VBScript),
Dreamweaver uses the default DOCTYPE declaration set in the Preferences panel (see
Chapter 2). If you haven’t changed it, the Dreamweaver default is to use XHTML 1.0
Transitional.

Figure 3-1. The Dreamweaver Welcome screen offers a quick shortcut to create the most frequently
used documents.

The disadvantage of using the Welcome screen is that it disappears as soon as you open a
document. Unless you never have more than one document open at a time, you need an
alternative way of creating a new document. 

Using the New Document dialog box

The document-creation method that offers the most choices is through the New Document
dialog box (see Figure 3-2). Select File ➤ New to open this dialog box.
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Figure 3-2. The New Document dialog box offers a huge range of options.

The options available depend on your selection in the left column, which offers the fol-
lowing categories:

Blank Page: This lets you choose from 17 different types of web-related documents.
The ones you will use most frequently in this book are HTML and PHP—at the top
and bottom of the Page Type list, respectively. If you select <none> in the Layout
column, Dreamweaver creates a page with no content other than the basic HTML
skeleton used by every web page. The choices offered by the Layout column are
discussed in Chapter 5.

Blank Template: This lets you create a Dreamweaver template from scratch.
Templates are covered in Chapter 13.

Page from Template: This lists all the sites you have defined in Dreamweaver, along
with templates associated with each one. Use this option to create a child page
from an existing template.

Page from Sample: This contains a selection of sample style sheets that can be used
as a starting point for creating your own. It also offers a range of framesets. Frames,
although very popular in the late 1990s, are now widely frowned upon because

Although Dreamweaver CS4 no longer supports ASP.NET and JSP server behav-
iors, you can still use the program to create ASP.NET and JSP pages. Selecting
one of these page types inserts processing instructions that tell the web server
how to treat the page, and gives the page the appropriate file name extension.
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they cause usability problems (see http://apptools.com/rants/framesevil.php).
The use of frames is not covered in this book.

Other: This creates other web-related documents, including plain text files.

In addition to the range of page types, the New Document dialog box lets you select a
different DOCTYPE from the default and attach one or more external style sheets to the
new page.

Other ways of opening a new document

You can create a new document in three other ways:

Click the New icon on the Standard toolbar. In spite of its name, the Standard tool-
bar is not displayed by default. To display it, select View ➤ Toolbars ➤ Standard. The
Standard toolbar contains icons for common file operations, such as open, save,
cut, copy, and paste.

Press Ctrl+N/Cmd+N. Depending on how you have set up the New Document cate-
gory in Preferences (see Chapter 2), this either opens the New Document dialog box
or creates a blank page of the current site’s default page type.

Right-click in the Files panel and select New File from the context menu. This cre-
ates a blank page of the current site’s default page type. The file name is automat-
ically placed in editable mode, ready for you to change it.

When you use either of the last two methods, the default page type is determined by
whether you have defined a testing server for the site. If the testing server uses PHP
MySQL as its server model, the default page type is created with a .php file name exten-
sion. If no testing server has been defined, the page is created with an .html extension.

The first time you open a new document in Dreamweaver, it’s displayed in Split
view. Thereafter Dreamweaver remembers your latest setting. If the current docu-
ment is in Code view, a new document or an existing one will also open in Code
view. If the current document is in Design view, that’s how the next document will
open. When you close Dreamweaver, the state of the last document to be closed
determines how the first document will open when you next launch the program.
Some documents, such as style sheets and JavaScript files, can be opened only in
Code view, so this also affects how the next document is displayed.

Previous versions of Dreamweaver included a range of common layouts in the
Page from Sample category. These have been removed from Dreamweaver CS4
because they used table layout with deprecated HTML styling. Whether you like
it or not, Dreamweaver CS4 is pushing you more and more to adopt CSS in place
of old-school habits.
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Inserting text
When you create a new web page, such as one with an .html or a .php file name exten-
sion, Dreamweaver automatically inserts all the necessary HTML tags for a basic page. In
Design view, you’re presented with what looks like a completely blank page, but if you
look in Code view or Split view, you’ll see the basic skeleton tags with the insertion point
(or cursor) between the opening and closing <body> tags, as shown in Figure 3-3.

Figure 3-3. In the underlying code, the insertion point is automatically placed between the <body> tags.

Inserting text directly

If you start typing in Design view, your text will appear, just as it would in a word proces-
sor. The same text will also appear in Code view, as shown in Figure 3-4. There is usually a
slight delay between typing in Design view and the appearance of the text in Code view.
The length of the delay depends on your computer specifications and any other programs
running at the same time.
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Notice that the text in the Code view half of the page in Figure 3-4 is inserted directly
between the <body> tags. As soon as you press Enter/Return, Dreamweaver automatically
wraps the existing text in <p> tags and creates a new pair of <p> tags with a nonbreaking
space (&nbsp;) in between, as shown on lines 9 and 10 in Figure 3-5.
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Figure 3-5. Dreamweaver automatically formats text as paragraphs when you press Enter/Return.

Figure 3-6. Paragraphs are automatically spaced apart in Design view, just as they would be in a browser.

As soon as you start typing in the new paragraph, Dreamweaver removes the nonbreak-
ing space (&nbsp;) from the underlying code and replaces it with the new text. Text is
automatically aligned left and wraps when it reaches the edge of the Document window.
In this and many other respects, entering text is like working with a word processor.
However, you need to press Enter/Return only once between paragraphs. As you can see
in Figure 3-6, a space roughly equivalent to one line is left between each block of text.
Pressing Enter/Return twice results in an empty paragraph (<p>&nbsp;</p>) being
inserted in the underlying code.



Copying and pasting text

If you’re building a website for a client, you’re likely to get the text in the form of a word-
processed document. To paste text from other applications, place your cursor in Design
view and select Edit ➤ Paste, press Ctrl+V/Cmd+V, or right-click and select Paste from the
context menu. (You can practice this with the Stroll.doc and Stroll.docx files in the
examples/ch03 folder of the accompanying download files.) Dreamweaver does a pretty
good job preserving most, if not all, of the formatting. It also offers you a choice of how
much formatting to keep, if any. 

Dreamweaver uses the paste options set in the Preferences panel. To set the default paste
behavior, open the Preferences panel from the Edit menu (Dreamweaver menu on a Mac)
or press Ctrl+U/Cmd+U, and select the Copy/Paste category. This presents you with the
dialog box shown in Figure 3-7.

Figure 3-7.
You can set the default

paste options in the
Preferences panel.

Newcomers frequently ask how to prevent Dreamweaver from inserting a space between
lines. This usually indicates a fundamental misunderstanding of how HTML works. HTML
tags such as <p> (paragraph) and <h1> (level 1 heading) are intended to represent the
structure of the document not primarily in the sense of how it looks on the screen, but
according to its meaning. Control over how a page looks is the role of CSS, not HTML. 

If you want to eliminate or reduce the space between lines, you should begin by consid-
ering the meaning of the text. Do you want paragraphs, or should you be creating a
list? If it’s the latter, use the appropriate HTML element, such as <ul> (unordered list) or
<ol> (ordered list). The bullets can easily be removed from an unordered list with CSS. If
you simply want to break a line within a text element, press Shift+Return/Enter to insert
a line break (<br />). If you do want paragraphs, but don’t like the default space
between them, the correct way to deal with it is to create a CSS style rule to adjust the
margins of all paragraphs. You’ll start working with CSS in the next chapter.
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The following options are available:

Text only: This means exactly what it says. You get the plain text and nothing else. All
formatting and line breaks are stripped out.

Text with structure: This preserves headings, paragraphs, lists, tables, and other struc-
tural formatting.

Text with structure plus basic formatting: This also preserves bold and italic text.

Text with structure plus full formatting: This converts fonts, colors, and other styles
into CSS. The result in Design view is very impressive, but the CSS is a nightmare.
Do not use this option. It’s much better to choose Text with structure plus basic
formatting and create your own CSS.

Retain line breaks: This checkbox cannot be selected independently. It merely indi-
cates whether line breaks will be preserved by the selected option (all do, except
Text only).

Clean up Word paragraph spacing: This removes the extra line between paragraphs
in text pasted from Microsoft Word.

If you want to choose a different option without changing the default settings, choose Edit
➤ Paste Special, press Ctrl+Shift+V/Shift+Cmd+V, or right-click and choose Paste Special
from the context menu. This brings up a dialog box with the same options as shown in
Figure 3-7. Choose the options you want, and then click OK. The new options apply only to
the current paste operation.

Importing Microsoft Word documents (Windows only)

Microsoft Word has become a de facto standard for word-processed documents, so
Dreamweaver has the option to import entire Word documents directly into the
Document window. It works in a very similar way to copying and pasting. 

To import a Word document, select File ➤ Import ➤ Word Document. In the dialog box
that opens, navigate to the document you want to import. Dreamweaver CS4 supports
both older Word files that use the .doc file name extension and the newer .docx standard
created by Word 2007 and Word 2008 for Mac. As shown in Figure 3-8, the Formatting
drop-down menu at the bottom of the dialog box offers the same choices as are available
for pasting. (The Stroll.doc and Stroll.docx files are available with the downloadable
files, in the examples/ch03 folder.)

When pasting from Microsoft Word, Dreamweaver expects a blank line between para-
graphs. If new paragraphs begin on the next line, Dreamweaver treats the text as a sin-
gle paragraph and inserts a <br /> tag between each one. To format paragraphs
correctly on a large amount of text, it’s usually quicker to use Find and Replace in Word
to replace single paragraph marks (^p) with two (^p^p).
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Figure 3-8. The Import Word Document dialog box offers the same formatting 
choices as are available when pasting.

Importing a Word document like this produces exactly the same result as copying and past-
ing, but it has the advantage that you don’t need to open the Word document to bring its
contents into a web page. The disadvantage is that it’s an all-or-nothing option: you get the
whole document. If you know what the document contains—and you want it in its
entirety—this is a useful alternative to copying and pasting. It’s also important to remember
that the results are only as good as the original formatting of the document. Sometimes it’s
better to select Text only and format the content yourself inside Dreamweaver.

Inserting images
Images are inserted into HTML with the <img> tag, which takes attributes describing the
source of the image file, its height and width, and alternate text for nonvisual browsers.
When you insert an image in either Design view or Code view, Dreamweaver takes care of
generating the necessary code. All you need to do is decide where the image should go.

Inserting images stored on your computer

There are several ways of inserting an image. Perhaps the simplest way, assuming the
image is already stored within your site, is to drag the image from either the Files or Assets
panel. You can also drag and drop images into the Document window (but not into the
Files panel) from Adobe Bridge, Windows Explorer, or Finder on a Mac.
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Dragging and dropping images
Dreamweaver inserts the image wherever you drop it. The Files panel is fine if you know
the file name of the image you want, but if you want to see a thumbnail preview, open the
Assets panel (it’s grouped with the Files panel in all preset workspace layouts or can be
opened from the Window menu).

As Figure 3-9 shows, the Assets panel sorts site assets into nine categories accessed by
clicking one of the icons in the left margin. In addition to showing a thumbnail preview of
an image, the panel displays its dimensions and size. If you decide to change the image
before inserting it, click the Edit button at the bottom right of the panel to launch your
default graphic design program. 

If you have a lot of images or other assets, you can add them to your favorites by clicking
the Add to Favorites button at the bottom right of the panel or by right-clicking and select-
ing Add to Favorites from the context menu. Toggle between your favorites and the full set
by clicking the radio buttons at the top of the Assets panel. 

As well as dragging and dropping an image from the Assets panel, you can click the Insert
button at the bottom left of the panel to insert the image wherever your cursor is located
in the Document window.

Selecting an image through the file system
The other way to insert images is through the Select Image Source dialog box (see Figure
3-10). To open this dialog box, select Insert ➤ Image, click the Image icon on the Common
tab of the Insert bar, or press Ctrl+Alt+I/Opt+Cmd+I. The Select Image Source dialog box
also displays a thumbnail preview of the image (on Windows, there’s a checkbox at the
bottom of the dialog box that lets you turn this off), as well as its dimensions and file size.

Figure 3-9. The Assets panel
gives a quick preview of assets
such as images and colors.
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Figure 3-10. The Select Image Source dialog box also lets you see a preview of the image
before inserting it.

If you’re using the default setting of document-relative links (see Chapter 2), Dreamweaver
displays the following alert when you try to insert an image in a page that hasn’t yet been
saved.

This is simply a gentle reminder that Dreamweaver is a site-based program. It needs to
know where the page is located in your site before it can insert the correct value in the
<img> tag’s src attribute. When you click OK, Dreamweaver still inserts the image in the
page, but creates a tag that looks like this:

<img src="file:///C|/vhosts/dwcs4/images/graffiti.jpg" width="300" ➥

height="216" />
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As soon as you save the page in a defined site, Dreamweaver changes the src attribute to
a valid relative link, like this:

<img src="../../images/graffiti.jpg" width="300" height="216" />

Provided that you always create web pages within a defined site, you can safely ignore this
alert. The alert is displayed only for links relative to the current document; it doesn’t apply
to site-root-relative links.

Adding alternate text
Before Dreamweaver inserts the image into the page, it displays the Image Tag Accessibility
Attributes dialog box, as shown in Figure 3-11. This prompts you to add alternate text to
describe the image. This text is inserted into the <img> tag’s alt attribute for the benefit
of visually impaired people using assistive technology to surf the Web, as well as those who
prefer to turn off images or use text browsers.

Figure 3-11. Dreamweaver automatically prompts you to insert alternate 
text for images.

According to the W3C specifications, the alt attribute is required (not optional). However,
alternate text should be used only for images that convey meaning. Don’t use it for purely
decorative images or transparent images designed to space apart page elements (spacers).
Imagine the frustration of a blind person visiting your page with a screen reader listening to
an endless recitation of “spacer gif”! To comply with the W3C specifications without driving
others mad, activate the drop-down menu for Alternate text and select <empty>. This inserts
an empty alt attribute (alt="") in the <img> tag.

A common question in the Dreamweaver forum (http://www.adobe.com/support/
forums/) is “Why don’t my images display when I upload the page to my website? They
look fine in Design view.” In the vast majority of cases, it’s because the src attribute
begins with file:///. In other words, it’s still pointing to the location of the image on
the designer’s local computer. This usually happens because the designer has failed to
define a site in Dreamweaver, and then uploaded the pages independently. Site defini-
tion is the key to maintaining your sanity with Dreamweaver.
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The Long description field is for the URL to a more detailed description of the image. This
is optional, and it is normally used only for complex images, such as bar charts or graphs.

After filling in the Alternate text field (and the Long description field, if necessary), click OK
to insert the image. If you click Cancel, the image is still inserted, but the alternate text and
long description are ignored.

A link at the bottom of the Image Tag Accessibility Attributes dialog box takes you to the
Accessibility category of the Preferences panel, where you can turn off this and other
accessibility prompts. I don’t recommend doing so, as most industrialized countries now
impose a legal obligation on website designers to make their sites accessible to people
with disabilities.

Text and image alignment
When you insert an image on a page that already contains text, the text does not auto-
matically flow around the image. Instead, the text is aligned with the bottom of the image,
as shown in Figure 3-12. This should come as no surprise if you’re familiar with HTML. In
the past, it was common practice to use the align, hspace, and vspace attributes in the
<img> tag to solve this problem. Dreamweaver CS4 still lets you insert these attributes, but
CSS offers a much more versatile solution, as you’ll see in Chapter 4.

Figure 3-12. Text does not flow automatically around images.

Inserting remote images

As well as using images stored in your own site, the src attribute of the <img> tag accepts
the URL of an image on another website. To insert a remote image, select the Image button
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on the Insert bar, use Insert ➤ Image, or press Ctrl+Alt+I/Opt/Cmd+I. In the Select Image
Source dialog box, delete any content in the URL field and replace it with the URL of the
remote file, as shown in the following screenshot (use the full URL beginning with http://).

When you click OK, Dreamweaver presents you with the Image Tag Accessibility Attributes
dialog box, and then inserts the <img> tag for the remote image. By default, if you are con-
nected to the Internet, Dreamweaver accesses the remote image, inserts the correct
height and width dimensions in the <img> tag, and displays the image in Design view.
Obviously, this doesn’t happen if Dreamweaver can’t access the remote file for any reason.
In that case, it creates the <img> tag without the height and width attributes, and displays
a broken-image icon in Design view.

On a slow connection or a page that uses a large number of remote files, this can slow
Dreamweaver to a crawl. If you experience performance problems, turn off Display External
Files on the View menu. Like many options on Dreamweaver menus, a check mark along-
side the menu item indicates that the option is enabled. Clicking the menu item toggles
the option on and off. 

Inserting placeholder images

Sometimes, you don’t have the images available when laying out a page. In this case, use a
placeholder. Using an image placeholder has the advantage that you can specify its size
and other attributes in a single operation. It also prevents Dreamweaver from displaying a
broken-image icon, as happens if you use the name of a nonexistent image, Position your
cursor in the Document window where you want the image to be inserted and select
Image Placeholder from the Common tab of the Insert bar, as shown in Figure 3-13 (click
the down arrow to the right of the Image icon to open the submenu). Alternatively, select
Insert ➤ Image Objects ➤ Image Placeholder.

Including remote images in a web page is a practice known as inline linking or
hotlinking (see http://en.wikipedia.org/wiki/Inline_linking). You should do it
only with the permission of the site whose image you’re using. Linking to an image with-
out permission could land you in legal hot water over breach of copyright. It could also
leave you with egg on your face. When the owner of a site discovers images are being
linked to without permission, it’s quite common to replace them with one that reads
“This image was stolen from . . .”
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This presents you with a dialog box with the following fields:

Name: This is simply a name to identify the placeholder. If you enter a name here,
it’s used as both the name and id attributes of the <img> tag, so the name must
begin with a letter and it cannot contain any spaces or special characters. If you
leave this field blank, Dreamweaver inserts name="", but no id attribute.

Width: The width of the placeholder in pixels. The default is 32.

Height: The height of the placeholder in pixels. The default is 32.

Color: This inserts an inline CSS style attribute for background-color. Its main pur-
pose is to make the placeholder stand out or blend in with the rest of your page.
You can use either the color picker in the dialog box or enter a hexadecimal num-
ber in the text field. If you don’t choose a color, Dreamweaver doesn’t insert a
style attribute, but displays the placeholder as light gray in Design view.

Alternate text: This is for the alt attribute. If you leave this blank, Dreamweaver
inserts alt="" in the <img> tag.

When you click OK, a solid block of color is placed in Design view, displaying the name and
dimensions of the placeholder, as shown in Figure 3-14.

Figure 3-13.
Using an image placeholder is

convenient when you don’t
have access to the original.
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When you’re ready to replace the placeholder with a real image, click the placeholder in
Design view to reveal its details in the Property inspector (see Figure 3-14). You can then
either create a new image or replace the placeholder with an existing one, as follows:

Create a new image: Click the Create button in the center of the Property inspec-
tor. This launches Adobe Fireworks (assuming you have it installed) with the can-
vas automatically sized to the same dimensions as the placeholder. Click the Done
button at the top left of the Fireworks workspace when you have finished, and fol-
low the instructions to save the image. This is a Fireworks-only operation. It won’t
launch Photoshop, even if Photoshop is your primary image editor. However,
Photoshop users get their day in the sun with Smart Objects, which are covered in
the next section.

Replace the placeholder with an existing image: Type the path to the image in
the Src field of the Property inspector. Alternatively, click the folder icon to the
right of the Src field, and navigate to the image in the file system. You can also use
the Point to File tool just to the left of the folder icon. As shown in Figure 3-15, you
drag the icon shaped like a crosshair sight to the name of the image file in the
Files panel. Release the mouse button when the correct file is highlighted, and
Dreamweaver inserts the correct path to the image in the Src field of the Property
inspector.

Figure 3-15. The Point to File tool offers a quick way of linking to a file in the Files panel.

Whichever method you choose to select the image, Dreamweaver replaces the place-
holder with the new image and automatically updates the height and width attributes to
the correct values.

Using Photoshop Smart Objects as images

A Smart Object is a web image, such as a .jpg or .gif file, that retains a link to the orig-
inal source file from which it was created. This makes it easy to edit and reoptimize the
web image. When working with a Smart Object, changes are made only to the web image,
leaving the original untouched. However, if you do make any changes to the original
Photoshop file, the Smart Object link simplifies updating the web image.

The inline style attribute for background-color is not removed from the <img> tag
when you replace the placeholder. In most circumstances, this makes no difference, but
it could affect style rules embedded in the head of the document or an external style
sheet. To avoid any problems, delete the value in the Color field of the Property inspec-
tor before setting the Src field. This leaves an empty style attribute in the <img> tag. It’s
redundant, but won’t do any harm.
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The concept of Smart Objects will be very familiar to designers migrating from Adobe
GoLive, which has now been discontinued. However, Smart Objects have been integrated
into Dreamweaver in a slightly different way from their treatment in GoLive. Moreover,
you can use Smart Objects only in conjunction with Photoshop. They do not work with any
other Creative Suite program or with PDF files.

Inserting a Photoshop Smart Object
There’s no need to open Photoshop to insert a Smart Object. You don’t even need
Photoshop installed. All that’s needed is the original image stored as a Photoshop .psd file.
Dreamweaver CS4 has all the necessary functionality to generate a .gif, .jpg, or .png file
from the Photoshop original. As Figure 3-16 shows, you can even make some adjustments
to the image that’s generated. However, don’t be fooled into thinking you get a free cut-
down version of Photoshop with Dreamweaver. You can’t edit the .psd file; that requires a
full version of Photoshop. 
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You insert a Smart Object in the same way as an ordinary image: by opening the Select
Image Source dialog box (click the Image icon on the Common tab of the Insert bar, select
Insert ➤ Image, or press Ctrl+Alt+I/Opt+Cmd+I). Navigate to the Photoshop .psd file that
you want to use as the original. If you want to practice using Smart Objects, use the
stroll_header.psd file in the examples/ch03 folder of the accompanying download files. 

It can be anywhere on your file system; it doesn’t need to be in your site. However, the
location of the Photoshop original needs to remain constant for the Smart Object link to
work. You can also drag and drop a Photoshop .psd file from the Files panel if it’s stored
within your site.

When you have selected the Photoshop file, click OK (or Choose on a Mac). This opens the
Image Preview dialog box (see Figure 3-16). This is where you optimize the web image
before inserting it in the page. The dialog box has a large number of options, all of which
are described in detail if you click the Help button at the bottom left.

The preview window on the right side of the dialog box displays a flattened version of the
whole Photoshop file. Depending on the size of the original, you need to use the Pointer
and/or Zoom tools to view the entire image. The Zoom tool and magnification drop-down
menu alongside it work only in fixed steps. You can’t drag the Zoom tool around a specific
area to display it.

What looks like the Crop tool in Photoshop and other image editors determines the area
that will be exported from the .psd file. Like all settings in the Image Preview dialog box, it
affects only the web image. No changes are made to the Photoshop original.

The Optimize to size wizard is a rather crude device that sets a target size for the web image
in kilobytes. Figure 3-17 shows the result of selecting a target size of 10KB. What I actually
got was a 2.6KB image with heavy banding, or posterization (unacceptably abrupt
changes of color), and a severe loss of definition.

Figure 3-17. Using the Optimize to size wizard can 
produce very unsatisfactory results.

You get much better results by using one of the options in the Saved settings drop-down
menu, or by selecting your own values for Format, Quality, and Smoothing. You can com-
pare different settings by selecting one, two, or four preview windows.

Once you have made your decision, click OK. Dreamweaver presents you with a dialog box
in which you specify the name of the web image and where you want to save it. After sav-
ing the image, Dreamweaver prompts you to set alternate text for the image, and finally
inserts it into the page.
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Updating a Smart Object
As an image file, a Photoshop Smart Object is no different from any other .jpg, .gif, or
.png file. What makes it special is the link that Dreamweaver preserves with the original
.psd file. This link is indicated in Design view by a Smart Object icon in the top-left corner
of the image, as shown in Figure 3-18.

Figure 3-18. The status of a Smart Object is indicated by the icon in the top-left corner of the
image.

Resizing a Smart Object 

If you resize the image in Design view, the icon is superimposed with an exclama-
tion mark inside a yellow triangle, as shown alongside. If you hover your mouse
pointer over the icon, a tooltip explains that the dimensions of the image are dif-

ferent from the HTML width and height attributes. Right-click the image and select
Update From Original from the context menu. Alternatively, select the image, and choose
Modify ➤ Image ➤ Optimize.

Dreamweaver re-creates the web image from the Photoshop original, resampling it to get
the same optimization settings as before. This all takes place in the background, and when
the process is complete, the Smart Object icon reverts to the synchronized state shown in
Figure 3-18.

Reverting to the Smart Object’s original size 

If you decide you don’t like the new size, right-click the Smart Object in Design view, and
select Reset Size To Original from the context menu. This resets the size, but does not resam-
ple the image. Right-click again, and select Update From Original from the context menu.

If you are upgrading from Dreamweaver CS3, this process is very similar to copying the
whole or part of a Photoshop file and pasting it into Dreamweaver. Copying and past-
ing still works in Dreamweaver CS4, and opens the same Image Preview dialog box.
However, copying and pasting from Photoshop does not create a Smart Object. To cre-
ate a Smart Object, you must import the .psd file through the Select Image Source dia-
log box or drag and drop it from the Files panel.
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The context menu also has a Reset Size option. This reverts the image to the previous size.
In other words, it acts like an undo command. The same options are available through the
Modify ➤ Image submenu.

Changing the optimization settings of a Smart Object 

You can change the quality and other optimization settings of a Smart Object image at any
time by right-clicking and selecting Optimize from the context menu. This reopens the
Image Preview dialog box shown in Figure 3-16. Any changes to the image are applied
immediately. Even if you change the export area, you don’t get the opportunity to assign it
a different name. As always, the changes are made only to the web image, not to the
Photoshop original.

Alternative ways to reopen the Image Preview dialog box are through the Modify ➤ Image
➤ Optimize menu option, or by clicking the Edit Image Settings button in the Property
inspector, as shown in the following screenshot.
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Editing the original image 

If you decide to make changes to the Photoshop original (for example, to capitalize the
initial letter of along in the example I have been using), select the Smart Object in
Dreamweaver and click the Edit button in the Property inspector as shown in the preced-
ing screenshot. Alternatively, select Modify ➤ Image ➤ Edit With ➤ Photoshop. Of course,
you can also just open the .psd file directly in Photoshop.

After you have made the changes, save the .psd file. The Smart Object icon in
Dreamweaver changes to indicate that the Smart Object is out of sync with the
original. The changed icon is shown in the screenshot alongside, but the differ-

ence might be difficult to make out in the black-and-white image. Like the regular Smart
Object icon, it consists of two arrows in a circle, but instead of both arrows being green,
the bottom one is deep red.

If you don’t have Photoshop installed, Dreamweaver displays a message saying it can’t
find a valid editor. When you click OK to dismiss the message, you’re taken to the File
Types/Editors category of the Preferences panel, where you can select another graphics
editor to handle .psd files. However, editing a .psd file in another program could result
in losing Photoshop-specific data.



Changing the Photoshop original does not automatically update Smart Objects in
Dreamweaver. This gives you ultimate control over whether to update the web image. To
bring the web image into sync with the Photoshop original, right-click and choose Update
From Original or use the main menu option: Modify ➤ Image ➤ Update From Original.

Updating Smart Objects from the Assets panel 

If you use a Smart Object in more than one page in a site, you can update all instances
simultaneously by selecting the image in the Assets panel and updating it there. The menu
options are the same as described in the previous sections.

Inserting Flash and Flex movies

Inserting a Flash or Flex movie into a web page is very similar to inserting an image.
However, the underlying code is very different. There are also important differences from
the way previous versions of Dreamweaver handled these files.

The first change is relatively minor. The Media submenus of the Insert menu and Common
tab of the Insert bar no longer refer to Flash, but to SWF. This is because movies made 
in Flash (http://www.adobe.com/products/flash/) and Flex (http://www.adobe.com/
products/flex/) both use the SWF format and run in the Flash Player browser plugin. 

The other changes reflect developments on the Web. In 2006, a dispute over patents
between Microsoft and a company called Eolas resulted in changes to Internet Explorer
that forced users to click embedded objects, including Flash movies, to activate them.
Dreamweaver CS3 got around this problem by using a JavaScript file to load Flash. Since
Microsoft and Eolas have settled their dispute, this is no longer necessary. However,
instead of reverting to the old method of embedding SWF files, Dreamweaver CS4 adopts
a new approach for the following reasons:

It avoids using the <embed> tag, which is not part of the HTML standard.

It prompts users to upgrade their version of Flash Player if it’s too old to support
features used by the SWF file. This is particularly important for movies created in
Flex, which require a minimum of Flash Player 9.

To insert a SWF, position your cursor in the Document window where you want the movie
to be, and select SWF from the Media submenu of the Insert menu or the Common tab of

Historically, SWF stands for both Shockwave Flash and Small Web Format. It’s normally
pronounced “swiff.”

Smart Objects rely on Design Notes that Dreamweaver creates in the folder where you
save the web image. Design Notes are stored in a subfolder called _notes, which is nor-
mally hidden in the Files panel, but which can be seen in Windows Explorer or Finder on
a Mac. If you delete the _notes folder or its contents, the Smart Object link with the
Photoshop original is destroyed.
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the Insert bar. For keyboard shortcut enthusiasts, the secret code is Ctrl+Alt+F/
Opt+Cmd+F. Navigate to the SWF file in the Select File dialog box and click OK. (The
images folder of the download files contains a Flash movie called fireworks.swf, which
you can use for practice.) This presents you with the Object Tag Accessibility Attributes dia-
log box, where you can enter a title, access key, and tab index for the movie. All items are
optional, but it’s a good idea to give the movie at least a title attribute. As with images,
clicking Cancel doesn’t stop the movie from being inserted into the page; all it does is
ignore the accessibility attributes. 

By default, Dreamweaver displays a placeholder for the SWF, as shown in Figure 3-19. To
see what the movie looks like in the context of the page, select the placeholder in Design
view and click the Play button at the bottom right of the Property inspector. This con-
sumes processor power, so click the button again (its label now reads Stop) to return to
the placeholder when you no longer need to view the movie.

Figure 3-19. Dreamweaver displays a placeholder for a SWF, but you can view it by clicking the Play
button in the Property inspector.

As you can see in Figure 3-19, the Property inspector has a lot of options for controlling
the settings of Flash and Flex movies. At the top left, it displays the file type and size.
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Immediately below is an unlabeled field that displays the id attribute of the <object> tag.
Dreamweaver automatically assigns FlashID as the value for the first SWF object.
Subsequent SWF movies inserted in the same page are numbered FlashID2, FlashID3,
and so on. The field is editable, so you can enter your own choice of id instead. Most of
the other options are self-explanatory, but I’ll describe each one briefly.

W and H: The movie’s width and height in pixels. These are filled in automatically
when you insert the SWF object.

File: The pathname of the SWF. The Point to File tool and folder icons work the same
way as for images.

Src: This field is for you to enter the location of the FLA file from which a Flash
movie was created.

Bg: This inserts a parameter in the <object> tag to set the background color for
the SWF.

Edit: This opens the movie’s FLA file for editing. To use this option, you must first
enter the location of the file in the Src field.

Class: This lets you apply a CSS class to the <object> tag. This is covered in the next
chapter.

Loop: This is selected by default. Deselect it if you don’t want the movie to run as a
continuous loop.

Autoplay: This is selected by default. Deselect it if you don’t want the movie to run
automatically when the page is first loaded.

V space and H space: These insert the deprecated vspace and hspace attributes
into the <object> tag to add vertical and horizontal space around the movie. CSS
offers a more versatile solution, as you’ll see in Chapter 4.

Quality: This controls the look of the movie during playback. Choose from the fol-
lowing settings:

High: This is the default setting. It gives the best quality, but requires a lot of
processor power.

Low: Select this option if speed is more important than quality.

Auto Low: This prioritizes speed, but improves quality when possible.

Auto High: This gives equal priority to both speed and appearance, but sacrifices
quality if more speed is required.

Scale: This determines how the movie fits into the dimensions set in width and
height.

Align: This inserts the deprecated align attribute in the <object> tag. Use CSS
instead, as explained in the next chapter.

Wmode: This determines how the SWF movie interacts with drop-down menus and
other elements controlled by JavaScript. Choose from the following options:

Opaque: This is the default. It allows drop-down menus to display correctly over
the movie. It gives the movie an opaque background so that elements with a
lower z-index are hidden behind. (z-index is a CSS property that controls the
stacking order of positioned elements.) 
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Transparent: If the SWF movie has transparent elements, this allows elements
with a lower z-index to show through behind it.

Window: This removes the wmode parameter from the <object> tag. Select this
option if the movie is not affected by dynamic elements, such as drop-down
menus. It is more efficient and user-friendly to screen readers for the visually
impaired.

Parameters: This opens a dialog box to set extra parameters expected by the movie. 

Dreamweaver places a bright blue tab with an open-eye icon at the top left of the SWF
placeholder. Click the icon to display the alternate content that will appear when a user
accesses the page with a browser using an old version of Flash Player, as shown in
Figure 3-20. You can edit or delete this content however you like. 

Figure 3-20. Dreamweaver inserts a customizable message to be displayed when an old version of
Flash Player is detected.

Notice that the image linking to the Flash Player download page is surrounded by a blue
border because it is used as a link. Older versions of Dreamweaver eliminated the border
by inserting border="0" in the <img> tag, but this is deprecated, and you are now
expected to create a CSS rule to eliminate it yourself. I’ll describe how to do this in the
“Using images as links” section later in the chapter.

To close the alternate content and restore the SWF placeholder in Design view, click the
eye icon again. If you can’t see the blue tab and icon, move your mouse pointer inside the
area containing the alternate content. As soon as the mouse pointer passes over the dot-
ted line surrounding the alternate content in Design view, it triggers the reappearance of
the tab and a blue border around the alternate content. If the tab and blue border fail to
reappear, make sure there’s a check mark alongside Invisible Elements in the View ➤ Visual
Aids submenu.

The first time you save a page containing a SWF, you should see an alert telling you that
expressInstall.swf and swfobject_modified.js have been copied to the Scripts
folder in your site. Dreamweaver creates the Scripts folder if it doesn’t already exist.
These files are shared by all pages that include SWF files, so this happens only once in
each site.
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To delete a SWF movie from a page, select the blue tab at the top left of the placeholder
and press Delete. This removes all the associated code cleanly from the page.

If your page generates JavaScript errors after removing a SWF, open Code view and see if
you can locate a block of JavaScript like this at the bottom of the page:

<script type="text/javascript">
<!--
swfobject.registerObject("FlashID");
//-->
</script>

If you changed the id attribute of the SWF, FlashID will be replaced by the value you
used. Remove the entire <script> block, and the errors should be eliminated.

Editing Dreamweaver CS3 pages that contain
SWF movies

Dreamweaver CS3 created completely different code for Flash or Flex movies. Dream-
weaver CS4 cannot convert the old script to the new markup. If you don’t need to make
any changes to the Flash movie’s settings, you can leave the code as it is. However, to make
any changes to the settings of a movie embedded using the old method, you must delete
the movie from the page and insert it again. Failure to do so results in the code being only
partially updated. 

To remove a Flash movie embedded in a previous version of Dreamweaver, select the
movie placeholder in Design view and press Delete. Dreamweaver should remove the code
cleanly, ready for you to reinsert the movie. You should also remove the following line of
code from the <head> of the page, as it’s no longer needed:

<script src="../../Scripts/AC_RunActiveContent.js" type="text/ ➥

javascript"></script>

Adding structure to your page content
In the past, adding structure to a web page meant creating a grid using tables and fitting
the content into table cells. Tables have the advantage of being easy to visualize. They’re
flexible, too, because table rows and columns stretch and contract to accommodate 
the content placed inside them. However, these advantages are heavily outweighed by the
problems created by table-based design. 

When uploading your site to the remote server, don’t forget to upload
expressInstall.swf and swfobject_modified.js. SWF movies won’t be
displayed correctly without them.

THE ESSENTIAL GUIDE TO DREAMWEAVER CS4 WITH CSS,  AJAX,  AND PHP

128



Using tables, anything but the simplest of designs normally involves nesting tables inside
one another, making the page impossible for disabled people to navigate with assistive
technology. Equally important, from the design point of view, complex table structures are
very fragile. Adding a new element to the page can bring the structure tumbling down like
a house of cards. Previous versions of Dreamweaver attempted to solve this problem with
Layout mode, which let you lay out your page in Design view rather like a desktop pub-
lisher. Although Layout mode usually produced visually pleasing results, the underlying
HTML code it generated was a horrendous tangle that was impossible to edit and a serious
barrier to accessibility.

Another layout tool that attracted a lot of excitement was what Dreamweaver called lay-
ers. The term layer was dropped in Dreamweaver CS3 and replaced by AP Div. AP stands
for absolutely positioned, and is a much more accurate description because AP Divs use
CSS absolute positioning. The instant appeal of absolute positioning is that it makes web
design feel like desktop publishing. You can place elements on a page exactly where you
want them to be. Your page looks wonderful in Dreamweaver Design view. It might even
look good in a browser. But it all starts to fall apart if the browser window or text is
resized. A common question is “Why does my AP Div (layer) move when the window is
resized?” The answer is “It doesn’t.” What you see is an optical illusion. The absolutely
positioned element stays exactly where you put it in relation to its parent element (usually
the browser window). All other elements of the web page move with the flow of the doc-
ument. Although AP Divs have a useful role to play in website design, I strongly recom-
mend that you avoid them until you have a solid understanding of CSS and the rules of
positioning.

So what’s left if tables and AP Divs are to be avoided? Thanks to CSS, the possibilities are
endless. In Chapter 5, I’ll show you how to adapt one of Dreamweaver’s built-in CSS 
layouts. The layouts are a good starting point for a new page, but to be able to use them
successfully, it’s important to understand the basics of page structure. If your page is struc-
tured logically, it’s easier to maintain and style with CSS.

As you saw earlier in the chapter, Dreamweaver automatically encloses text typed into
Design view with <p> (paragraph) tags when you press Enter/Return. You can also import
text from Microsoft Word or paste text from other applications, and Dreamweaver will
attempt to preserve the structure and formatting.

Text is normally structured using one or more of the following elements:

Paragraphs (<p>)

Headings (<h1> through <h6>)

Preformatted text (<pre>)

If you are upgrading from a previous version of Dreamweaver and can’t find Layout
mode, stop looking. It has been permanently removed from Dreamweaver CS4. Rather
than attempt to edit pages originally created with Layout mode, you should redesign
them from scratch.
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Inline tags (for example, <strong>, <em>, <code>, etc.)

Lists (<ul>, <ol>, or <dl>)

Block quotes (<blockquote>)

Tables (<table>)

There are five basic ways of adding these structural elements:

Through the HTML view of the Property inspector

Through the Text tab of the Insert bar (tables use the Common and Layout tabs)

Through the Format menu (tables use the Insert and Modify menus)

By using keyboard shortcuts (not available for all elements)

By typing the code directly into Code view

Typing the code directly needs no explanation. Refer to Chapter 1 for details of code hints
and auto-completion. You can also look up keyboard shortcuts on the relevant menus. The
following sections concentrate on using the Property inspector, the Insert bar, and menus.
Let’s begin by looking at changes to the Property inspector that might confuse newcomers
and experienced users alike.

Selecting the HTML view of the Property inspector

The Property inspector has two buttons labeled HTML and CSS on the left side. The top
screenshot in Figure 3-21 shows the HTML view, and the bottom screenshot shows the
CSS view. They look very similar, but their functions are completely different.

Figure 3-21. The HTML and CSS views of the Property inspector are easily confused.

The HTML view is primarily concerned with HTML markup, although the Class drop-down
menu and Page Properties button give some access to CSS. The CSS view is exclusively
devoted to CSS. The Bold and Italic buttons that are common to both views work in very
different ways. If you click the Bold button in the HTML view, Dreamweaver inserts
<strong> tags in the underlying code. Clicking the same button in the CSS view launches
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the New Style Rule dialog box or opens an existing style rule for editing, depending on the
value displayed in the Targeted Rule drop-down menu.

Here, we’ll concentrate on using the HTML view to add structural elements.

Creating paragraphs, headings, and preformatted text

The Format drop-down menu at the top left of the HTML view of the Property inspector
(see Figure 3-21) adds structure to text by wrapping it in paragraph (<p>), heading (<h1>
through <h6>), or preformatted text (<pre>) tags. It also removes those tags when you
select None as the option.

To understand how the Format drop-down menu works, it’s a good idea to open Split view
and watch where tags are inserted or removed. It’s important to understand that the struc-
ture is not applied to selected text, but to the entire block where your cursor is currently
located. If your cursor is located inside a paragraph and you select Heading 2 from the
Format drop-down menu, the <p> tags are replaced by <h2> tags. If you select None, the
nearest pair of <p>, <h1> through <h6>, or <pre> tags is removed. No other tags are affected.

The Text tab of the Insert bar (see Figure 3-22) and the Paragraph Format submenu of the
Format menu work basically the same way. The Paragraph button on the Text tab of the
Insert bar is the fifth icon from the left. Note that the Insert bar offers only the first three
levels of headings (<h1> through <h3>), and has no option for removing tags once they
have been inserted (after all, it is the Insert bar).

Figure 3-22. The Text tab of the Insert bar adds structure to text elements.

When choosing headings, you should consider the meaning of the heading within the
structure of the page. Normally, pages should have only one main heading (<h1>).
Subsequent headings should be the next level down (<h2>). Less important subheads
after an <h2> should use <h3>. Don’t worry about the size of the heading when you first
structure the page. The size, color, and alignment can be fixed with CSS. Search engines
give more weight to well-structured documents, so don’t fall into the old-school habit
of using <h6> just because you want small text. You should rarely need more than <h1>,
<h2>, and <h3>.

The first time you launch Dreamweaver CS4, the HTML view of the Property inspector is
displayed by default. Thereafter, Dreamweaver always remembers your most recent
selection, so it’s important to be aware which view is displayed. The current selection is
indicated by its label on the left of the Property inspector being inset. Another visual
clue is that the CSS view does not have a Link field.
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Adding inline tags

Strictly speaking, making text bold or italic doesn’t alter the structure of the text, but I’m
covering it here because the HTML view of the Property inspector has buttons that insert
<strong> and <em> tags. They’re the first two of the group of icons immediately to the
right of the Class drop-down menu, as shown in the following screenshot.

Using the Bold and Italic buttons 
The Bold and Italic buttons in the HTML view of the Property inspector work the same way
as in a word processor. If you click one of the buttons, nothing happens in Code view, but
as soon as you start typing, Dreamweaver inserts <strong> or <em> tags. Click the button
again. The insertion point doesn’t move in Code view, but as soon as you start typing again,
it jumps outside the closing tag and reverts to normal text. You can also highlight a selec-
tion of text and wrap it in <strong> or <em> tags. 

The Bold and Italic buttons appear inset when inside bold or italic text. Selecting all or part
of the formatted text and clicking the button again removes the formatting from the
selection. Using these buttons is very versatile and intuitive.

The equivalent buttons on the Text tab of the Insert bar are much less versatile. They insert
<strong> and <em> tags, but cannot be used to remove bold or italic formatting.

Using the Format ➤ Style menu 
The Style submenu of the Format menu offers a much wider range of inline tags, many of
which are designed to add structure to your document. As you can see in Figure 3-23, in

Immediately to the right of the Bold and Italic icons on the Insert bar are two others
labeled S and em, which also boldface and italicize text, respectively. The Dreamweaver
default is to use <strong> and <em> tags in place of the presentational tags <b> and
<i>. If you change the default in the General category of the Dreamweaver Preferences
panel, the Bold and Italic buttons insert <b> and <i> tags. 

Current best practice advocates the use of <strong> and <em> because it’s more mean-
ingful to assistive technology for the visually impaired. However, this is a controversial
subject. Sometimes, you want to make text bold or italic simply to distinguish text from
its surrounding context. In such cases, it might be more meaningful to create a style
rule that sets the font-weight property to bold or font-style to italic. In other cases,
you can use special HTML tags, such as <cite> for book and magazine titles. Most
browsers render the <cite> tag as italic text.
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addition to Bold and Italic, this submenu offers less frequently used, but important tags
such as Code (<code>), Keyboard (<kbd>), and Citation (<cite>).

Figure 3-23. The Style submenu of the Format menu inserts both structural and presentational tags.

The Style submenu works in the same way as the Bold and Italic buttons in the HTML view
of the Property inspector. You can select an option, start typing, and select the option
again to insert the closing tag. Alternatively, you select an option to wrap highlighted text
in the inline tags, or remove the tags from a selection. The same submenu is accessible
from the context menu when you right-click in Design view.

Using Wrap Tag and Remove Tag 
Yet another way to add inline tags is to highlight a section of text, right-click, and select
Wrap Tag from the context menu. This opens a mini window with the cursor inside an
empty tag and a pop-up menu of inline tags, as shown in the following screenshot. 
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You can either start typing or scroll down to find the tag you want to wrap around the
selected text. As you type, the pop-up menu automatically scrolls to the closest matching
tag. Once you reach the tag you want, double-click the name in the pop-up menu or press
Enter/Return to insert the name inside the empty tag. If you want to add any attributes
inside the tag, press the spacebar, and a list of appropriate attributes appears. Once you
have finished, press Enter/Return again to close the Wrap tag mini window and insert the
tag in the underlying code.

If you select a tag that would create invalid HTML code in the current context,
Dreamweaver displays an alert and discards any changes.

To remove a tag, insert your cursor anywhere inside a block of text in Design view and
right-click to bring up the context menu. The Remove Tag option on the context menu
identifies the closest pair of tags surrounding the position of your cursor. Select the
option, and the tags are removed cleanly from the underlying code. For example, take 
the following text as it appears in Code view:

<p>Lorem ipsum <code>dolor</code> sit amet.</p>

If you place your cursor anywhere inside dolor in Design view, the context menu displays
Remove Tag <code>, and removes the <code> tags from the underlying code if you select
it. However, if your cursor is anywhere else in that sentence, the context menu displays
Remove Tag <p>, and removes the <p> tags if you select the option.

Creating lists

HTML creates three types of lists:

Unordered list: By default, browsers display each item as a bullet point. The list is
surrounded by <ul> tags, and each item is wrapped in <li> tags. You can change
the bullet style or remove it completely with CSS.

The Remove Tag option is available only in Design view and the Tag selector. In Design
view, it always selects the closest pair of tags surrounding the current position of the
cursor. When used in the Tag selector, it removes the selected tag, but leaves its content
intact. It’s a very useful tool if you understand the underlying structure of the HTML
code in your page.

If you are upgrading from a previous version of Dreamweaver, Wrap Tag is the new
name context menus use for the Quick Tag Editor when you make a partial selection in
the Document window. If you select a complete tag in the Tag selector at the bottom of
the Document window, the context menu still refers to the Quick Tag Editor. Both work
exactly the same way. The reason for the different names is because Wrap Tag adds a
new tag around the current selection, while the Quick Tag Editor edits an existing tag;
for example, by adding a new attribute.

THE ESSENTIAL GUIDE TO DREAMWEAVER CS4 WITH CSS,  AJAX,  AND PHP

134



Ordered list: By default, browsers prefix each item with a number, starting from 1.
The list is surrounded by <ol> tags and each item is wrapped in <li> tags. The style
and starting point of the numbering can be controlled by CSS.

Definition list: This type of list is designed for a glossary, list of terms, or collection
of name/value pairs. The list is surrounded by <dl> tags; each term to be defined is
wrapped in <dt> tags; and the definitions are wrapped in <dd> tags. Most browsers
display the definitions indented one line below the preceding term. As always, this
can be changed by CSS.

Creating bullet points and numbered lists
The icons to the right of the Class drop-down menu in the HTML view of the Property
inspector create unordered and ordered lists—in other words, bullet points and num-
bered lists—as shown in the following screenshot. 

The Unordered List and Ordered List buttons in the HTML view of the Property inspector
work just like the corresponding buttons in a word processor. Click the appropriate but-
ton, start typing, and your text appears as a bulleted or numbered list with a new item
added each time you press Enter/Return. When you have finished the list, press
Enter/Return, and click the list button again to exit the list. Alternatively, you can select
several paragraphs and convert them to a bulleted or numbered list by clicking the appro-
priate button.

To nest a list inside another, press Enter/Return to create the first item of the nested list,
and then click the Indent Text button (see the preceding screenshot). You can nest num-
bered lists inside bulleted lists and vice versa. Just click the Unordered List or Ordered List
button inside the first item of the nested list. To return to the main list, press Enter/Return
after the last item in the nested list, and click the Outdent Text button.

Creating unordered and ordered lists with the Text tag of the Insert bar or the List submenu
of the Format menu and Design view context menu works in the same way. The only dif-
ference is that you cannot use the Insert bar to nest lists.

List items in <li> tags can contain paragraphs and other HTML block ele-
ments. Unfortunately, if you press Enter/Return inside a list, Dreamweaver
automatically assumes that you want to create the next <li> item, even if
you are inside a paragraph. This is a known bug. The only way around it is
to fix the code manually in Code view.
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Creating a definition list
To create a definition list, you need to use the Text tab of the Insert bar or one of the menu
options. Click the Definition List button on the Text tab of the Insert bar—it’s the sixth from
the right and labeled dl (see Figure 3-22 earlier in the chapter). When you start typing,
Dreamweaver wraps the text in the first <dt> tag. Press Enter/Return, and Dreamweaver
creates a <dd> tag in the underlying code and indents the next block of text. Each time you
press Enter/Return, Dreamweaver alternates between <dt> and <dd> tags, creating a list
that looks like the following screenshot in Split view (it’s in definition_list.html in the
exercises/ch03 folder of the download files):

To end a definition list, press Enter/Return after the last item. Then click the Outdent Text
button in the HTML view of the Property inspector. Alternatively, select Format ➤ Outdent,
or right-click in Design view and select List ➤ Outdent from the context menu.

Creating block quotes

The HTML specification (http://www.w3.org/TR/html401/struct/text.html#h-9.2.2)
describes the <blockquote> tag as being “for long quotations (block-level content).”
However, to distinguish long quotations from regular text, browsers have always indented
text inside <blockquote> tags. As a consequence, this has become one of the most abused
HTML elements, with <blockquote> tags sometimes nested several times within one
another simply to shift content from the left margin. In the days before CSS, this was
understandable. Now it’s both lazy and inefficient (adjusting margins with CSS is covered
in the next two chapters).

The Text tab of the Insert bar also has buttons for <li>, <dt>, and <dd> tags. Do not use
these in Design view, as they simply insert tags in the underlying code. They do not con-
vert a <dt> element, for example, to a <dd> one. To do that, you need to use the Remove
Tag option from the Design view context menu, as described earlier. Then select the text
you want to wrap in <dd> tags and click the button in the Insert bar. These three buttons
are designed primarily for use in Code view.
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The reason for this mini history lesson is the confusing way Dreamweaver has imple-
mented the creation of block quotes. Everything is based on the now outdated assumption
that the <blockquote> tag should be used to indent text. When not used in connection
with a list, the Indent Text button in the HTML view of the Property inspector inserts a pair
of <blockquote> tags in the underlying code. If your cursor is inside text wrapped in
<blockquote> tags, the Outdent Text button removes the <blockquote> tags. The same
applies to the Indent and Outdent options on the Format menu.

Now here’s where it gets really confusing. The sixth icon from the left on the Text
tab of the Insert bar (shown alongside) displays a tooltip labeled Block Quote.
However, if your cursor in the underlying code is inside any sort of list, instead of

inserting <blockquote> tags, it creates a nested list.

The moral of this tale is to avoid using <blockquote> unless the structure of your text jus-
tifies it, and check in Code view or Split view that the intended code has been inserted.
This mess really needs to be cleaned up in the next version of Dreamweaver.

Using tables

How tables should be used in web pages is the subject of endless acrimonious debate,
often of a quasi religious nature. This is what the HTML specification (http://www.w3.org/
TR/html401/struct/tables.html) says (in part): “The HTML table model allows authors to
arrange data—text, preformatted text, images, links, forms, form fields, other tables,
etc.—into rows and columns of cells. . . . Tables should not be used purely as a means to
layout document content as this may present problems when rendering to non-visual
media. Additionally, when used with graphics, these tables may force users to scroll hori-
zontally to view a table designed on a system with a larger display. To minimize these prob-
lems, authors should use style sheets to control layout rather than tables.” 

These days, it’s considered best practice to use tables
purely to present data that needs to be laid out in rows
and columns. There are other circumstances where the
grid pattern created by a table is useful—for example, the
display of thumbnail images. Regardless of what you use
tables for, they’re easy to insert and edit in Dreamweaver.

Inserting tables
To insert a table in a page, position your cursor
where you want the table to begin and click 
the Table icon (shown alongside) in either the

Common or Layout tab of the Insert bar. Alternatively,
select Insert ➤ Table or press Ctrl+Alt+T/Opt+Cmd+T.
This opens the Table dialog box, as shown in Figure 3-24.
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The dialog box offers the following options:

Rows and Columns: Enter the number of rows and columns you want in the table.
You can add more columns or rows or remove them later.

Table width: You can set the width either in pixels or as a percentage. If you don’t
want to specify a width, delete the value in this field and leave it blank.

Border thickness: This sets the border attribute in the opening <table> tag and
applies the same border thickness to both the table and all table cells. CSS gives
you greater control over table and cell borders. Leave this field blank to remove all
borders or if you want to use CSS.

Cell padding: This sets the cellpadding attribute in the opening <table> tag and
applies the same amount of internal padding around all sides of every cell. For
finer control, leave this field blank and use CSS instead.

Cell spacing: This sets the cellspacing attribute in the opening <table> tag and
applies the same amount of spacing on all sides between table cells.

Header: This controls the use of table header <th> cells and the scope attribute to
indicate whether the header applies to a table row or column. Visual browsers nor-
mally display text in <th> cells bold and centered. The scope attribute makes it eas-
ier for visually impaired people to navigate the table with a screen reader. Choose
one of the four options: None, Left, Top, or Both.

Caption: If you want to give the table a caption, enter the text in this field. By
default, the caption is displayed above the table, but you can use CSS to move it to
the bottom.

Summary: This is for the benefit of screen readers for the visually impaired. Any
text entered here is read by the screen reader, but does not appear on the screen.

When you click OK, Dreamweaver creates the table skeleton and inserts a nonbreaking
space (&nbsp;) in each cell in the underlying code. This prevents empty cells from looking
odd in a browser. As soon as you insert content into the cell, Dreamweaver normally
deletes the &nbsp;. However, if you find text misaligned in a table cell, it’s a good idea to
check the underlying code and remove the &nbsp; manually, if necessary.

If you left Table width blank in the Table dialog box and find it difficult to position your cur-
sor inside table cells, select the Expanded button on the left of the Layout tab of the Insert
bar. Alternatively, select View ➤ Table Mode ➤ Expanded Tables Mode or press Alt+F6/
Opt+F6. This expands the table cells in Design view to make them easier to edit; it doesn’t
affect the underlying code or how the table will be rendered in a browser. Once you have
inserted content into the table, click the exit link at the top of the Document window or
select the Standard button on the Layout tab of the Insert bar to collapse the table to its
normal shape and size.

Editing tables
Once you have inserted a table, you can change its basic properties by selecting the table
in Design view and using the Property inspector. To select the table, click one of its edges
in Design view. If you find this difficult, the surefire way of selecting a table is to click
inside any cell, and then select <table> from the Tag selector at the bottom of the
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Document window. Figure 3-25 shows the options available in the Property inspector
when a table has been selected.

Figure 3-25. You can change the basic structure of a table in the Property inspector.

Most of the options are the same as in the Table dialog box. The blank field on the left of
the Property inspector is where you can enter an id attribute for the table. If style rules
have been created, a list of unused IDs can be accessed as a drop-down menu in this field
(IDs must be unique, so IDs that have been assigned to other elements are not listed).

If you increase the number of rows or columns in the Property inspector, they are added
to the bottom and right of the table, respectively. If you reduce the number, they are
removed from the bottom and right, and any content in them is deleted.

The Align drop-down menu at the top right inserts the deprecated align attribute in the
opening <table> tag to align the table left, right, or center of its parent element. Best
practice is to leave this at Default (left aligned) and use CSS to position the table.

The four icons at the bottom left of the Property inspector remove the height and width
attributes from all table cells and convert widths between pixels and percentages. You can
identify their roles from the tooltips displayed when you hover your mouse pointer over
each one.

The Property inspector changes when you put your cursor inside a table cell or select just
part of a table. As Figure 3-26 shows, the top half of the Property inspector displays the
CSS or HTML view, depending on which button is selected on the left, and the bottom
half contains options related to table cells.

Figure 3-26. The Property inspector for table cells has both HTML and CSS views.

The Fireworks icon and Src field grayed out at the bottom center in Figure 3-25 are
ghosts from the past. Several deprecated table attributes have been removed from the
Property inspector since the last version. This icon and field somehow got left behind,
but both are disabled and serve no purpose.
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The top half applies to content inside the cell; the bottom half applies to the selected
cell(s). Most of the options in the bottom half insert deprecated attributes (horizontal and
vertical alignment, width, height, no text wrap, and background color). These values
should normally be set through CSS, rather than using the Property inspector.

The useful options in the Property inspector for table cells are the Header checkbox, which
toggles the selected cell(s) between using <th> and <td> tags, and the two icons at the
bottom left, which merge and split cells. In Figure 3-26, the icon that merges cells using
rowspan and colspan attributes is grayed out because it is active only when more than one
cell is selected in Design view. Conversely, the split icon is active only when a single cell is
selected. When you click it, the Split Cell dialog box appears, asking whether you want to
split the cell into columns or rows and how many to create.

Inserting and deleting rows and columns accurately 
Using the Rows and Cols fields of the Property inspector to increase or decrease the num-
ber of rows and columns is a very crude measure, as you get no choice where the rows or
columns are added or deleted.

A quick way to add a single row or column is to use the Layout tab of the Insert bar. As
shown in Figure 3-27, the Layout tab has four buttons to insert a row or column on a spe-
cific side of the current insertion point.

Figure 3-27. The Layout tab of the Insert bar has options for inserting rows and columns.

Position your cursor inside a table cell and select the appropriate button. And that’s it—
you’re done.

If you prefer working with menu options, you can also insert a single row or column using
the Table submenu of the Modify menu and Design view context menu. Insert Row adds a
new row below the current one. Insert Column adds a new column to the left of the cur-
rent one.

Menu options for merging and splitting cells also exist on the Table submenus of the
Modify menu and the Design view context menu. They are labeled Decrease and Increase
Column/Row Span. However, they merge or split only one row or column at a time and
are quite difficult to master. It’s much simpler to select the target cells in Design view and
use the Property inspector. Table-based layout relies heavily on merging and splitting
cells, which can lead to a complex and unstable structure. When tables are used for dis-
playing data, the need for merging and splitting cells is greatly reduced.
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To add more than one row or column in a single operation, select Modify ➤ Table ➤ Insert
Rows or Columns (the same option is available on the Table submenu of the Design view
context menu). This opens the Insert Rows or Columns dialog box, which lets you specify
whether to insert rows or columns, how many, and on which side in relation to the
current cell.

Selecting table cells, rows, and columns 
The ability to select cells, rows, and columns is important for several reasons. You may
need to select these areas when you’re applying styles, editing tables, and applying PHP
server behaviors, such as Repeat Region.

To select a single cell, position your cursor inside the cell and select <td> (or <th> if it’s a
header cell) from the Tag selector at the bottom of the Document window. Dreamweaver
displays a thick border around the cell to indicate that it’s selected.

To select one or more cells at the same time, hold down the Ctrl/Cmd key and click inside
each cell. Cells selected this way can be in any part of the table; they do not need to be
contiguous (you might want to do this to apply the same class to individual cells). To
select a block of contiguous cells, you can also hold down the mouse button and drag
across the cells.

To select a single row, the quickest and most accurate way to do it is to position your cur-
sor inside a cell in the target row, and then select <tr> from the Tag selector at the bottom
of the Document window. An alternative way to select a row is to position your mouse
pointer over the left of the target row until it changes to an arrow, as shown in the left
screenshot of Figure 3-28. Click once to select the whole row. To select more than one
row, hold down the Ctrl/Cmd key while selecting each subsequent row.

Figure 3-28. The mouse pointer changes to an arrow indicating that 
you can select the complete row or column.

You select columns the same way, by positioning your mouse pointer at the top of the tar-
get column until it changes into an arrow, as shown in the right screenshot of Figure 3-28.
Use the Ctrl/Cmd key to select more than one column.

Selecting rows accurately is very important when applying the Repeat Region server
behavior. A common mistake is to drag to select all the cells in the row. This selects only
the cells (the <td> or <th> tags) and not the row (the surrounding <tr> tags), produc-
ing unexpected results. Even if you spend most of your time in Design view, you should
always be aware of what’s happening in the underlying HTML code. Otherwise, your
pages are likely to be difficult to maintain.
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Importing data tables from Microsoft Excel (Windows only)
In the Windows version of Dreamweaver, you can import data tables directly from
Microsoft Excel spreadsheets by selecting File ➤ Import ➤ Excel Document. Dreamweaver
CS4 handles both .xlsx and .xls formats (you can experiment with weather.xslx and
weather.xsl in the examples/ch03 folder of the download files). The options in the
Import Excel Document dialog box are the same as for importing a Microsoft Word docu-
ment (see Figure 3-8 earlier in the chapter). However, Dreamweaver doesn’t preserve any
formatting other than the table structure (if you select Text only, you just get the raw data).

The problem with importing data directly using this method is that Dreamweaver is inca-
pable of handling multiple worksheets. You get only the data from the worksheet that was
selected when the Excel document was last closed. Also, Dreamweaver has a habit of
adding a large number of empty rows at the bottom of the table. You get much better
results by copying and pasting from a spreadsheet. You get exactly the data you want, and
Dreamweaver preserves the table structure.

Importing data from a CSV file
A common way of exporting data from spreadsheets and databases is as comma-separated
values in a .csv file. The examples/ch03 folder of the download files contains celsius.csv
and fahrenheit.csv, which contain average weather data for London and the southeast of
England, formatted like this:

Month,Max Temp °C,Min Temp °C,Sun (hours),Days of Rainfall >= 1mm
Jan,7.2,1.5,54.6,12.8
Feb,7.5,1.2,73.0,9.7
Mar,10.1,2.8,111.0,11.0

You can import this sort of data and create a table from it by clicking the Import
Tabular Data icon (shown alongside) on the Data tab of the Insert bar (it’s the first
icon on the left). Alternatively, select File ➤ Import ➤ Tabular Data or Insert ➤ Table

Objects ➤ Import Tabular Data. This opens a dialog box that asks you to select the data file
and delimiter (the character used to separate each item of data). It also has basic format-
ting options for the table that will be built from the data. 

Organizing content into a logical structure

The reason tables became the standard way of laying out web pages is because they cre-
ate a grid that helps you organize your page in a logical structure. The following illustra-
tion shows a very simple, yet typical, layout for a web page. In terms of a table, it consists

You can also export data from an HTML table to a CSV file. Insert your cursor in any
table cell, and select File ➤ Export ➤ Table. Dreamweaver prompts you to select the
character you want to use as a delimiter and the type of line breaks (Windows, Mac, or
Unix). Click Export and then choose a name for the CSV file and where to save it. This
can be very useful for transferring data from a web page to a database.
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of four rows and two columns. The cells in the first two rows and the final row are merged
so they spread across the full width of the page. 

The problem with table-based layout is that designers frequently want another grid within
each section, and that’s when things start to become really complicated. You either need
to nest tables within individual cells or build one large table with a complex pattern of
merged rows and columns. Before long, it becomes a rat’s nest of tags that only the origi-
nal designer has any hope of understanding. Often, it defeats even the person who built it
in the first place.

In spite of the problems, tables were the only option for a long time. CSS first made an
appearance in 1996, but browser support was very poor. Although browser support is still
not perfect, CSS is now considered the standard way to construct and style pages. Instead
of using table cells as a grid, your page content needs to be organized into logical blocks.
The main tool for this is the <div> tag.

Grouping related content with <div> tags
A lot of misunderstanding surrounds <div> tags as a result of what earlier versions of
Dreamweaver called layers. A layer was an absolutely positioned <div>. So, while it’s true
that every layer was a <div>, the converse is not true: a <div> is not a layer.

So what is a <div>? The HTML specification (http://www.w3.org/TR/html401/struct/
global.html#edef-DIV) says that a <div> is “a generic mechanism for adding structure to
documents” that defines content to be block-level, but imposes “no other presentational
idioms.” Translating that into language that’s more friendly to ordinary human beings, a
<div> is a simple tool for grouping elements of a page that you want to keep together.
Moreover, it doesn’t have any default styles.

HTML treats every element on a page as being one of the following types:

Block-level: By default, a block-level element is always displayed on a new line,
and occupies the full width of available horizontal space. Examples of block-level
elements are headings, paragraphs, and tables. Unless you use CSS to change the
default behavior, two block-level elements cannot appear side by side.
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Inline: As long as there is enough room, an inline element appears alongside what-
ever precedes it. Examples of inline elements are <strong> and <em> tags. Images
are also treated as inline elements.

Many block-level elements have default styles. For example, most browsers display <h1>
elements in a bold font and twice the size of ordinary text. They also add a deep bottom
margin to separate the heading from the following content.

A <div>, on the other hand, has no styles whatsoever. It’s a blank canvas for you to style
however you like. In combination with the id attribute, it’s also a powerful way of apply-
ing consistent styles to everything within the same <div>. Once you have organized your
content into a logical structure using <div> tags and other block-level elements, you can
use CSS to style them visually, adding background images and colors, and altering their
position and relationship with other elements by adjusting margins and padding. CSS
styling offers a much more powerful tool set than tables, but of course, learning how to
master that tool set is something that comes only through experience.

Inexperienced web designers or those just making the transition to CSS layout tend to use
<div> tags to excess, wrapping a <div> around everything that would have been in a table cell
before (a phenomenon known as divitis). This isn’t necessary if the element is self-contained.
For example, a paragraph on its own doesn’t need to be wrapped in a <div> because it’s
already a block-level element and can be styled independently. However, a group of para-
graphs does need to be wrapped in a <div> for them to be treated as a single unit.

The HTML specification also defines the <span> tag as “a generic mechanism for adding
structure to documents.” The difference between <span> and <div> confuses a lot of peo-
ple, but it’s very simple. Browsers automatically put a line break before and after a <div>.
A <span> is an inline device typically used to add style to several words in the middle of a
paragraph. No line breaks are inserted around a <span>, nor should a <span> contain
block-level elements. You can put a <span> inside a paragraph or heading, but not the
other way round. You can put anything inside a <div>.

To insert a <div> tag, select the Insert Div Tag button on the Common tab of the Insert bar,
as shown in the following screenshot. Alternatively, use the Insert Div Tag button on the
Layout tab of the Insert bar, or select Insert ➤ Layout Objects ➤ Div Tag.

The main focus of this book is on using the tools in Dreamweaver CS4. It’s not a com-
plete guide to web design and CSS. To learn more about CSS best practice, read
Beginning CSS Web Development: From Novice to Professional by Simon Collison
(Apress, ISBN: 978-1-59059-689-0) or CSS Mastery: Advanced Web Standards Solutions
by Andy Budd et al. (friends of ED, ISBN: 978-1-59059-614-2). Also, any book by Eric
Meyer will give you a solid grounding in CSS.
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This opens the Insert Div Tag dialog box, as shown in Figure 3-29. In spite of its simple
looks, this dialog box is quite versatile and can be used to wrap the current selection in a
<div> or to insert a new <div> with considerable precision. And because the <div> tag
plays such an important role in CSS, you can define associated style rules directly from the
dialog box.

Figure 3-29. The Insert Div Tag dialog box makes it easy to group page 
elements and apply style rules.

You’ll get a better idea of how to use this dialog box in exercises throughout this book, but
here are brief descriptions of the options it offers:

Insert: This drop-down menu is context-sensitive. If content is selected in the
Document window, it displays Wrap around selection, as shown in Figure 3-29. If
nothing is selected, the default value is At insertion point. Both of these options are
self-explanatory.

Selecting one of the other options in the Insert menu activates the drop-down
menu alongside (it’s grayed out in Figure 3-29). Both menus work in conjunction
and insert a <div> with placeholder text as follows:

Before tag: This option is available only when elements on the page have id
attributes. It inserts the <div> immediately before the element selected in the
right drop-down menu.

After start of tag: This inserts the <div> immediately after the opening tag of the
element selected in the right drop-down menu. In addition to elements with id
attributes, the right menu lists the <body> tag.

Before end of tag: This inserts the <div> immediately before the closing tag of
the element selected in the right drop-down menu. In addition to elements with
id attributes, the right menu lists the <body> tag.

After tag: This option is available only when elements on the page have id attrib-
utes. It inserts the <div> immediately after the closing tag of the element
selected in the right drop-down menu.

Class: Enter the name of the CSS class you want to apply to the <div>. Existing
classes are listed as a drop-down menu.

ID: Enter the name of the id attribute you want to assign to the <div>. Existing IDs
defined in style sheets associated with the page are listed as a drop-down menu.
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Since an ID can be used only once on a page, the list displays only those IDs that
have not yet been assigned to another element.

New CSS Rule: This lets you define a new style rule that will be applied to the <div>.

Inserting a horizontal rule
A simple HTML device for adding structure to your web page is the horizontal rule
(<hr />). This is a block-level element that acts as a separator by drawing a line
across the width of its parent element. In a revamp of the Insert bar in

Dreamweaver CS3, it was accidentally left out. Fans of the horizontal rule will be pleased
to know that it has been given a reprieve. It’s the fourth button from the left in the
Common tab of the Insert bar (see alongside). Alternatively, select Insert ➤ HTML ➤

Horizontal Rule. You can also insert a horizontal rule by selecting Insert HTML from the
Design view context menu. Type hr and press Enter/Return.

Creating links
I’ll never forget my first experience of the Internet. It was in the very early days using a 
300 bit/second modem. There were no images; just text. Although it was fantastic to be
reading something I had just downloaded from a computer on the other side of the world,
what really amazed me was clicking a link and being transported to a completely different
article on a different computer in another part of the world. Forget the eye candy for a
moment. What made the Internet the success it is today is the ability to dig down to the
information you’re after by following hyperlinks. And it’s all done with the humble <a> tag.

Links can take you to other pages in the same site, jump to specific locations in a page, or
transfer you to a different site. You can also use links to send email. In addition to text links,
you can use images, or parts of them, as links. The following sections describe each in turn.

Using text to link to other pages

Creating a text link is very easy. Just select the text that you want to use as the link, and use
one of the following methods:

Select the HTML view in the Property inspector. In the Link field, type the address
of the page you want to link to.

If the page is in the current site, select the HTML view in the Property inspector and
use the Point to File tool to choose the target page in the Files panel (the Point to File
tool was described in the “Inserting placeholder images” section earlier in this
chapter; see Figure 3-15).

If the page is in the current site, hold down the Shift key and drag from the
selected text to the target page in the Files panel.

If the page is in the current site, select the HTML view in the Property inspector and
click the folder icon to the right of the Link field. Navigate to the target file in the
Select File dialog box (see Figure 3-30).
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Click the Hyperlink button in the Common tab of the Insert bar (shown 
alongside). This opens the Hyperlink dialog box (see Figure 3-31).

Select Hyperlink from the Insert menu. This opens the Hyperlink dialog box
(see Figure 3-31).

Right-click and select Make Link from the context menu. This option is available
only in Design view; it opens the Select File dialog box (see Figure 3-30).

With seven different ways of creating a link, you might wonder which to use. Although most
methods do exactly the same thing, there are some differences that might influence your
choice. When linking to an external web page, you need to type the URL manually in the
Link field of the Property inspector or Hyperlink dialog box. The Select File dialog box has a
URL field that you could use instead, but if you don’t want to use the Property inspector,
the Hyperlink dialog box has options that are more appropriate to an external link.

Using the Select File dialog box
The Select File dialog box has two options that tend to make it the best choice for creating
internal links. The dialog box always remembers the last folder you navigated to. Although
this is useful, it sometimes means a tortuous route to find the file you want this time.
That’s when the Site Root button is a huge time-saver. It’s at the top of the dialog box in
Windows (see Figure 3-30) and at the bottom right in the Mac version. Click it, and
Dreamweaver takes you directly to the root of the current site.

When creating a link to a page on an external website, don’t forget to add http:// or
https:// at the beginning of the URL. If you omit this, browsers attempt to link to a
page on your own site.
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The other great advantage of the Select File dialog box is the Relative to drop-down menu
just below the URL field. This defaults to the choice you made in your site definition
regarding links relative to the current document or to the site root (see Chapter 2). The
drop-down menu lets you override the default choice manually. This is particularly useful
when working with PHP sites. PHP commands that include other files into the current web
page or script expect links relative to the current document, but links inside include files
need to be relative to the site root.

If you decide to change the default setting for your site, there’s a link that takes you
directly to the relevant section of the site definition. Changing the setting in the site defi-
nition does not affect existing links; the new default applies only to links created after the
change.

Using the Hyperlink dialog box
The Hyperlink dialog box (shown in Figure 3-31) is useful if you want to set more options
for the link. It also takes a slightly different approach from other methods of creating a
link, in that you don’t need to select text beforehand. You can use the Text field in any of
the following ways:

If you haven’t selected any text, whatever you type directly into the Text field is
inserted into the page and used as the link.

If you selected text before launching the Hyperlink dialog box, you can edit it in the
Text field. The revised text is used as the link.

If you leave the Text field blank, Dreamweaver uses the value entered in the Link
field as the hyperlink. This is useful if you just want to display the URL of an exter-
nal site, as it saves you the effort of typing it twice.

The page you want to link to goes in the Link field. Clicking the folder icon to the right of
the field launches the Select File dialog box and returns you to the Hyperlink dialog box
once you have made your selection. The Target field lets you specify if the link should be
opened in a new window, as described in the next section. The Title, Access key, and Tab
index fields add accessibility attributes to the link. 

Figure 3-31.
The Hyperlink

dialog box lets you
set extra options.
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Opening a link in a new window
Normally, clicking a hyperlink opens the new page in the same browser window.
Sometimes, though, it’s desirable to open a new window. To do so, set the Target drop-
down menu alongside the Link field in the Property inspector to _blank, as shown in the
following screenshot (the same option is available in the Hyperlink dialog box). 

There are three other options in the drop-down menu (_parent, _self, and _top). These are
used only with framesets, which are considered bad practice and not covered in this book.

Some web designers use this technique on every external link in the mistaken belief that
opening the other website in a new window will prevent the user from leaving the current
site. Usually what happens is that the visitor’s screen gets filled with so many new windows
or browser tabs that the likelihood of returning is greatly reduced. It also annoys many
users so intensely they refuse to visit your site again anyway. Use this technique only when
it serves a useful purpose, such as opening a set of instructions to help the user fill in an
application form, or when the link leads to a large PDF file. In the latter case, tell visitors
how big the file is and that it will open in a new window. Alternatively, add a note along-
side the link suggesting that visitors right-click and save the file rather than opening it in a
browser.

Linking to a specific part of a page
When you have a page with a lot of content, it’s useful to be able to link directly to a spe-
cific part of a page, either from within the same page or from elsewhere. Originally, the
only way to do this was to create what’s known as a named anchor. This is an <a> tag with
a name attribute instead of an href one. Dreamweaver CS4 still allows you to insert named
anchors (using the icon shaped like a ship’s anchor on the Common tab of the Insert bar or
Insert ➤ Named Anchor). However, this is an old-fashioned technique that adds unneces-
sary code to your page. Instead, use IDs.

Simply insert your cursor in the element that you want to link to (usually a heading or a
paragraph), select the HTML view of the Property inspector, and enter a unique identifier
in the ID field (it mustn’t begin with a number or contain any spaces or special characters).

To link to that element from the same page, create a link, and enter the hash symbol (#)
followed by the ID. To link from another page, add the hash symbol and ID to the end of
the file name. For example, you might want to link to a section called “What We Do” that
begins with an <h2> heading. If you enter services in the ID field, the underlying code will
look like this:

<h2 id="services">What We Do</h2>
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To link to that section from within the same page, enter #services in the Link field. To link
from another page, add #services to the end of the file name in the Link field like this:
aboutus.html#services.

IDs are often used for CSS, so they serve a dual purpose. Remember, though, that the same
ID cannot be used more than once on a page. IDs identify, so they must be unique.

Using images as links

Links don’t always need to be text. You can use an image as a link, too. Just select the
image in Design view, and add the link in exactly the same way as you would add a text
link. However, don’t use any of the options that open the Hyperlink dialog box, because it
automatically creates a text link if the Text field is left blank. Consequently, you end up
with both an image and a text link.

Removing the link border
Using an image as a link wraps the <img> tag in a pair of <a> tags. By default, browsers add
a blue line under text links and a blue border around images used as links. Older versions
of Dreamweaver got rid of this blue border by adding border="0" to the <img> tag.
However, it no longer does so, because the border attribute for images is deprecated. To
get rid of the border, you can type 0 manually into the Border field of the Property inspec-
tor for each image used as a link. You can, but it’s a huge waste of effort. The far more
efficient way is to add the following style rule to your CSS:

a img {border:none;}

This tiny snippet of code removes the blue border from every single image used as a link
in your site (of course, a style sheet containing this rule needs to be linked to each page.
Creating style rules and attaching a style sheet are covered in the next chapter.

Creating an image map
Not only can you turn an entire image into a link, you can also add multiple links to an
image by creating invisible hotspots over different parts of the image and adding a link 
to each one. Figure 3-32 shows the search page of an online guide to Japanese gardens in
the U.K. and Ireland that I created several years ago (http://japan-interface.co.uk/
gardens/search.php). The map of the British Isles is a single image, but each region has a
hotspot that links to details of gardens in that area. Using an image like this is known as an
image map, not because this particular example uses a geographical map, but because the
details of the hotspots are wrapped in the HTML <map> tag and associated with the image
by the usemap attribute.

The underlying code for the South West region highlighted in Figure 3-32 looks like this:

<area shape="poly" coords="85,261,107,256,118,261,120,252,129,248, ➥

143,251,146,239,149,230,134,228,109,241" href="results.php? ➥

searchCrit=SWest" alt="South West" title="South West" />
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Figure 3-32.
Invisible hotspots
allow you to add
multiple links to
different parts of
an image.
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The code looks pretty horrendous, but Dreamweaver takes care of it all, making the cre-
ation of hotspots a breeze. This is what you do:

1. Insert the image you want to use as an image map in the normal way, and leave it
selected in Design view.

2. Enter a name for the map in the Map field at the bottom right of the Property
inspector (see Figure 3-33). The name must not begin with a number or contain
any spaces or special characters. If you forget to enter a name, Dreamweaver auto-
matically uses Map, Map2, Map3, and so on.

3. Depending on the shape of the hotspot you want to draw, select one of the
hotspot tools in the Property inspector (see Figure 3-33). To create a rectangular or
circular hotspot, click and drag across the area of the image that you want to use
as a link. The area of the hotspot is displayed as an aqua-colored mesh on top of
the image. Dreamweaver displays an alert reminding you to create alternative text
for the hotspot.



Figure 3-33. All the tools for creating an image map are in the Property inspector and Status bar.
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To create an irregularly shaped hotspot, choose the Polygon hotspot tool, and click
once at the edge of the shape you want to turn into a link. Dismiss the alert
reminding you to create alternative text, and click at another point around the
edge of the shape. Continue clicking around the edge of the shape. As soon as you
have three points, the hotspot area is displayed as an aqua-colored mesh on top of
the image.

4. If you need to adjust the shape, size, or position of the hotspot, select the Pointer
hotspot tool in the Property inspector. To move the hotspot, click in the center of
the mesh and drag it to the new position. To alter the shape or size, click one of the
square handles around the edge of the hotspot and drag.

5. As soon as you create a hotspot, the Property inspector changes to display options
related to it. Enter the details of the link in the Link field and set Target, if required.
Also enter some alternative text in the Alt field.

6. If you want the hotspot to display a tooltip in all browsers, as illustrated in
Figure 3-32, open the Tag Inspector panel, select the Attributes button, and enter
the tooltip text in the title field.

To edit a hotspot, select it in Design view and make any adjustments. To delete a hotspot,
select it in Design view and press Delete. All the related code is automatically removed.

You can practice creating image maps with the map in Figure 3-32, which
is provided as uk_map.gif in the images folder of the download files.
Creating irregular-shaped hotspots on a small image can be tricky. To get a
better view, select the Zoom tool in the Status bar (see Figure 3-33) and
drag it across the area of the image that you want to work with. After
changing the magnification, be sure to click the Select tool button in the
Status bar. To restore the magnification to normal, select 100% from the
drop-down menu alongside the Zoom tool. A version of the image map is in
image_map.html in examples/ch03.



Chapter review
This chapter has covered all the main techniques for getting content into a web page and
creating links in Dreamweaver, but the results in both Design view and a browser look
rough and unpolished. That’s the role of CSS, which we’ll begin to explore in the next
chapter. However, successful design with CSS depends on building a solid underlying struc-
ture with HTML. The quality of your HTML code is also vital to working with Spry and other
JavaScript libraries, as well as to the successful integration of PHP server-side code. Even if
you’re principally a graphic designer, it’s important to understand the code Dreamweaver
is generating on your behalf. Remember that Dreamweaver is a tool. If you use it correctly,
it will create clean, valid code. If you try to treat it like a drag-and-drop desktop publisher,
you’re likely to end up with a mess.
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