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Dreamweaver CS4 has a new look. At first glance, the changes might look superficial: a
slightly different default layout of panels and a charcoal-gray livery. The program now
shares the same user interface (UI) as other Creative Suite programs, making it easier for
designers to create their basic design in Photoshop or Illustrator, and then prepare it for the
Web in Dreamweaver.

Although the changes to the UI are important, it’s the underlying functionality that really
matters, and that’s where Dreamweaver CS4 has changed dramatically. New features, such
as Related Files, Live view, and the Code Navigator, make this the most significant release
of Dreamweaver since Dreamweaver MX in 2002. The changes are aimed at helping
designers and coders alike, and are likely to have a big impact on the workflow of existing
users. Whether you’re a newcomer to Dreamweaver or an old hand, to get the best out of
the program, you need to find your way around the UI and new features.

In this chapter, you’ll learn about the following:

Using the OWL 2.0 UI

Switching panels to iconic mode

Converting the Insert panel into a tabbed Insert bar

Using the Related Files feature to edit files linked to a web page

Selecting options for Split view

Previewing pages inside the Document window with Live view

Navigating directly to style rules with the Code Navigator

Editing HTML and Cascading Style Sheets (CSS) markup with the revamped
Property inspector

Another important change with Dreamweaver CS4 is that Bridge and Device Central have
become optional components. Bridge is a powerful file organizer (like Windows Explorer
or Mac Finder on steroids). It has many features designed to appeal to designers and pho-
tographers, such as file previews, and keyword and metadata management. Device Central
lets you see what your website will look like on a range of mobile devices. Both Bridge and
Device Central are integrated with other Creative Suite programs, but many Dreamweaver
users were unhappy that they had no choice whether to install them with the previous ver-
sion. Adobe listened to the complaints, and has made many programs bundled with
Dreamweaver CS4 optional. However, one optional program that you should install is
Extension Manager, which is used to install extensions that add extra features and func-
tionality to Dreamweaver. I’ll show you how to use Extension Manager in Chapter 8, but
the main emphasis throughout this book is, of course, on Dreamweaver CS4.

This chapter covers the nuts and bolts of the Dreamweaver interface. It’s written with both
newcomers and old hands in mind. If you’re upgrading from a previous version of
Dreamweaver, a lot of things will be instantly familiar; the UI is a subtle blend of old and
new. However, even when things look the same, they often work slightly differently. For
example, pressing F4 still hides most panels, but moving your mouse to the edge of the
screen brings back anything hidden on that side (read “Temporarily hiding panels,” if you
want to disable that behavior). Because there are so many features in the UI, you might
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want to skim quickly through this chapter to see what it contains, and come back later
when you need to find out how a particular feature works.

Let’s begin with an overview of the Dreamweaver CS4 interface.

Exploring the UI
The common interface shared by all programs in Adobe Creative Suite 4 is officially known
as OWL 2.0. OWL stands for OS (operating system) Widget Library. OWL not only gives a
common feel and look to CS4 programs, but it also eliminates most differences in the way
each program operates in Windows and Mac OS X. With only a few minor exceptions, the
Mac version of Dreamweaver now looks and works identically to its Windows counterpart.

Inspecting the default workspace

The Dreamweaver CS4 workspace is infinitely configurable, and you can save your own 
layouts. Figures 1-1 and 1-2 show what greets you when you first open the program in
Windows and Mac OS X, respectively.

Figure 1-1. The default layout when you first open Dreamweaver CS4 in Windows
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Figure 1-2. The Mac version of Dreamweaver CS4 is almost identical to the Windows one.

The only important differences between the two versions are that the Mac version retains
the main Dreamweaver menus in the Mac menu bar, whereas they’re integrated into the new
Application bar in Windows; and the Windows version blocks out the Desktop, while the Mac
version lets the Desktop show through when no document is loaded into the workspace. 

The Welcome screen in the center of the workspace shows a list of the ten most recently
opened pages, and provides shortcuts to opening new documents of the most commonly
used file types. Of course, the list of recently opened pages is empty the first time you
open the program. 

The first thing most experienced Dreamweaver users do after installing a new version of the
program is to select the Don’t show again checkbox at the bottom left of the Welcome screen.
Even if you’re tempted to do so on this occasion, I suggest you follow the Top Features (videos)
links on the right of the screen. These launch Adobe TV (http://tv.adobe.com/) videos
explaining and demonstrating the main new features in Dreamweaver CS4. As they say, a
picture is worth a thousand words, so the videos should give you a rapid introduction to the
program’s powerful new features. You need to be connected to the Internet to view the

The Mac version of some other programs in Creative Suite 4, such as Flash, emulates
Windows behavior by adding a gray background to the whole program. However, this
feature (known as the application frame) has not been implemented in Dreamweaver.
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videos. If you have already hidden the Welcome screen, you can restore it by selecting Edit
➤ Preferences (Dreamweaver ➤ Preferences on a Mac), selecting the General category, and
putting a check mark alongside Document options: Show Welcome Screen.

To activate all the panels, you need to open a document. If you’re new to Dreamweaver, click
HTML under the Create New heading in the Welcome screen. The default workspace layout
is called Designer. Figure 1-3 labels all the main parts of the workspace, and Table 1-1 pro-
vides brief descriptions of these parts. (Because the UI in both Windows and Mac is almost
identical, all screenshots in this book are taken from the Windows version, except where
important differences exist).
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Figure 1-3.
The default Designer
workspace in
Dreamweaver CS4

Table 1-1. The main elements of the Dreamweaver workspace

Feature Description

Application bar On Windows, this contains all the main Dreamweaver menus plus four menus
common to both Windows and Mac, and the Search for Help field. The common
menus control layout of the Document window, Dreamweaver extensions, site
management, and workspace layout. The Application bar can be closed on a Mac,
but it is a permanent fixture in Windows.

Workspace switcher This lets you choose from eight preset workspace layouts. It also has options to
reset the current layout and manage custom layouts. This is hidden on a Mac if
the Application bar is closed.

Continued



Table 1-1. Continued

Feature Description

Search for help In addition to the Help menu, you can now search for help directly through the
UI. Enter a search term and press Enter/Return. If you are currently connected
to the Internet, this launches the Adobe Community Help website, which
displays results not only from Adobe’s website, but also from selected blogs and
community tutorial sites. If you’re offline, the results come from Dreamweaver’s
local help files. This is hidden on a Mac if the Application bar is closed.

Document toolbar This controls the display of the current document in the Document window,
showing the page layout, underlying code, or a combination of the two. It also
contains a number of tools for previewing the page, uploading it to the remote
server, and checking the code for mistakes.

Document window This is the main editing area. Each document is opened in a separate tab.

Tag selector This displays where the current selection lies within the page’s document tree
structure. It can be used to select page elements and add attributes, such as an
ID or class, to a tag.

Property inspector This is Dreamweaver’s main control center for working with the underlying code
while viewing the web page in the Document window. It’s a context-sensitive
panel that displays all the main attributes of the current selection ready for
editing. An important change from previous versions of Dreamweaver is the
separation of the Property inspector into two views: HTML and CSS. Access to
these views is controlled by two buttons at the top left of the Property
inspector.

Status bar This shows details of the Document window and current page, such as
magnification, dimensions, size in kilobytes, and encoding.

Panel groups Specialized panels control working with different aspects of web pages, such as
styles, database connections (with a server-side language like PHP), and files in
the current site (site definition is covered in Chapter 2). The most commonly
used panels are displayed as a column on the right side of the screen, but they
can be rearranged, minimized, or closed to suit your workflow, as described in
this chapter.
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This looks very familiar to long-term Dreamweaver users. The main difference lies in the
large panel at the top right of the screen. This is the Insert panel, which was a much more
compact toolbar in previous versions. It has been redesigned with labels alongside each
icon to help newcomers to the program find tools easily. The other big change is that all
the icons in the Insert panel are grayscale and display in color only when you mouse over
them. The logic behind this is to reduce color noise—the theory being that colored icons
distract you from the main design in the Document window. If you don’t like either of
these defaults, they can be changed. 



I’ll deal with the Insert panel (including restoring the tabbed Insert bar from previous ver-
sions) in the “Using and configuring the Insert panel” section later in this chapter, but
switching to colored icons is something you might want to do immediately.

Switching between grayscale and colored icons

The idea of rendering all icons in grayscale makes a lot of sense in graphic design pro-
grams, such as Photoshop and Illustrator, because they have relatively few toolbars, and
muting the icons lets you concentrate on the design with a minimum of distraction.
Dreamweaver, on the other hand, has a lot of icons, many of which are very small. Without
color to act as a visual clue, the grayscale versions can be difficult to distinguish, slowing
down your workflow. However, in recognition of the way different people work, three of
the preset workspace layouts (Classic, Coder, and Coder Plus) display colored icons by
default, and you have the option to toggle colored icons on and off in all layouts. There
are three ways of doing so, as follows:

Select View ➤ Color Icons.

Right-click the Insert panel and select Color Icons from the context menu (a page
needs to be open in the Document window before you can do this).

Click the View options button in the Document toolbar and select Color Icons (see
the section “Exploring the Document toolbar” later in this chapter for a description
of the Document toolbar’s features).

Choosing a preset workspace layout

In addition to the default Designer workspace layout, Dreamweaver CS4
comes with seven other preset layouts. And if you don’t like any of them,
you can design and save your own personal layouts (as explained in the
section “Managing workspaces” later in this chapter). You access the pre-
set layouts and manage customized ones through the Workspace switcher
(on Windows, it’s at the right end of the Application bar; in the Mac ver-
sion, it’s much further to the left). Figure 1-4 shows the available options
on the Workspace switcher. 
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Table 1-2 provides a brief description of the preset layouts, but the best
way to understand them is to experiment by selecting each one in turn.

If you’re an experienced user of Dreamweaver, and just want to
get the UI back to its previous layout, select Classic from the
Workspace switcher. However, the new options can do a lot to
improve your workflow, so they’re well worth exploring.

Figure 1-4. The Workspace switcher
offers a wider choice of layouts than
previous versions.



Table 1-2. Preset workspace layouts in Dreamweaver CS4

Layout Panel groups Description

App Developer The panel groups are displayed fully expanded in a
column on the left. The Document window on the right is
split horizontally to show Code view at the top and Design
view below. The Property inspector is closed. Mainly suited
to developing dynamic websites with a server-side
technology.

App Developer Plus Three extra design-related panels are added in iconic
mode to the right of the Document window (the AP
Elements panel displays details of elements that use
absolute positioning). The Property inspector is displayed
at the bottom of the Document window. Not suitable for
a small monitor.

Classic This is the same layout as Dreamweaver CS3. The Insert
panel is converted to a toolbar at the top of the screen.
The Property inspector is at the bottom of the Document
window, and the panel groups are fully expanded on the
right. Icons are displayed in color. An all-purpose layout
suited to developers involved in both server-side
development and page design.

Coder Files, Assets, Snippets This is a minimalist layout for developers who prefer to
work in raw code. Just one panel group is displayed fully
expanded on the left, with the Document window in Code
view on the right. The Property inspector is closed. Icons
are displayed in color.

Coder Plus This adds three design-related panels in iconic mode to
the right of the Document window. Icons are displayed in
color.

Designer This is the layout shown in Figure 1-3. It provides the basic
tools for designing static websites. A good choice for
beginners.

Designer Compact Same as Designer The layout is the same as Designer, but the panels are
displayed in iconic mode.

Dual Screen This blows the UI apart, displaying nearly every available
panel ready for redistribution on a dual-monitor setup.
The Property inspector is initially attached to the
Document window, but like everything else, it can be
detached. It’s more of a starting point for a custom layout,
rather than something you would use on a regular basis.

Insert, CSS Styles,
AP Elements,
Databases, Bindings,
Server Behaviors,
Assets, Snippets,
Files, Properties,
Code Inspector

Insert, Properties, CSS
Styles, AP Elements,
Files, Assets

Same as Coder plus
Insert, CSS Styles,
AP Elements

Insert, Properties, CSS
Styles, AP Elements,
Tag Inspector,
Databases, Bindings,
Server Behaviors,
Files, Assets, Snippets

Same as App
Developer plus
Insert, CSS Styles,
AP Elements,
Properties

Databases, Bindings,
Server Behaviors,
Files, Assets,
Snippets
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Expanding and collapsing panels vertically
As you can see in Figures 1-1 through 1-3, the Insert and Files panels are open in the default
Designer workspace, but two panels in the middle (CSS Styles and AP Elements) are dis-
played as tabs only. All panels can be expanded vertically to give access to their contents,
and collapsed to tabs to give you more room to see the contents of a different panel.

The way you expand a panel that’s currently displayed only as a tab depends on its posi-
tion. If the tab is foremost in its group, you need to double-click it. Other tabs open with
a single mouse click. To contract a panel to its tab, either double-click the tab or click once
in the dark-gray area to the right of the last tab in the group. Panels that are grouped
together expand and contract as a group. Clicking once in the dark-gray area also expands
a closed group of panels.

Many panels also have keyboard shortcuts to expand and contract panels. Open the
Window menu to see the shortcuts available for your operating system.

Resizing panels
Panels can be resized vertically and horizontally by clicking and dragging the top, bottom,
or side of a panel or panel group. Dreamweaver remembers the new size until you change
it again.

Using panels in iconic mode

Long-term users of Dreamweaver will begin to see
the real differences in the UI by selecting one of the
workspace layouts that use iconic mode, such as
Designer Compact. The panel groups are identical to
the Designer layout, but instead of the panel groups
being fully expanded (as in Figure 1-3), they are col-
lapsed to icons with labels alongside, as shown in
Figure 1-5.

Click the icon or its label, and the panel pops out,
as shown in Figure 1-6. Once a panel is open, you
can resize it by dragging its sides or corners.
Dreamweaver remembers this size until you change
it again. Only one panel can be opened at a time,
and by default, the panel pops back in as soon as
you click anywhere outside it. This means you can switch rapidly between panels by click-
ing the icon or label of the next panel you want to access. It also tidies the workspace by
keeping the panel out of the way as soon as you start working in the Document window.

The AP in AP Elements stands for “absolutely positioned.” The panel displays
details of all page elements that have the CSS property position: absolute.
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Figure 1-5. Dreamweaver panels can now be collapsed to icons.



Figure 1-6. In iconic mode, panels pop out alongside their icons.

If this automatic disappearing act doesn’t suit your way of working, you can disable it by
right-clicking any of the panel icons and selecting Auto-Collapse Iconic Panels from the
context menu. A check mark alongside this option indicates that auto-collapse is enabled.
Clicking the option in the context menu toggles the behavior on and off.

Iconic mode is particularly useful on a small monitor, but Windows users might be annoyed
by the large expanse of empty gray space beneath the icons (on a Mac, the Desktop shows
through). There are two things you can do about that in both Windows and Mac:

Minimize the icons to hide their labels.

Float the icons.

Minimizing iconic panels
Once you’re familiar with the panel icons, you can save space by positioning your cursor
over the edge of a column of panels in iconic mode until it changes into a double-headed
arrow. Hold down the left mouse button, and drag toward the opposite edge of the col-
umn until the labels disappear and the icons snap to their minimized shape, as shown in
Figure 1-7.

The minimized icons work exactly the same as before. To help remind you what each icon
represents, Dreamweaver displays a tooltip when you hover your cursor over one.

Although this saves space, you still get the gray column on Windows or the Desktop show-
ing through on a Mac. If you don’t like that, you can turn the panels into a floating vertical
toolbar.
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Figure 1-7. The panels can be reduced to icons to save space.

Converting iconic panels into a floating toolbar
You can detach a column of iconic panels by clicking anywhere in the dark-gray strip at the
top of the column, and then dragging it away from the edge of the screen. (Don’t click the
double-arrow at the top right—that expands all the panels in the column to their default
width.) Once the panels have been detached from the edge of the screen, you can position
them anywhere you want. While dragging them, they turn semitransparent to make it eas-
ier to decide where to locate them. As an independent toolbar, the icons occupy the min-
imum amount of space, and the gray column disappears on Windows. Figure 1-8 shows the
minimized panels floating alongside part of a web page in the Document window.

Closing and restoring floating panels
Dreamweaver adds a close button to the dark-gray strip at the top of floating panels.
Figure 1-9 shows the close buttons added to a floating toolbar of minimized icons on
Windows and Mac. The close button follows the convention of the operating system, so it
remains at the top right or top left when the icons are expanded to panels. Simply click the
close button, and the panels are removed from the workspace.

Figure 1-8.
The minimized panels can be
floated anywhere in the workspace.
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To restore floating panels after closing them, open the Window menu and select the name
of one of the panels in the group that has been closed. This opens the panel, along with all
other panels (or icons) grouped with it. Many panels have keyboard shortcuts that toggle
them open and closed. Using one of these shortcuts also restores a closed floating group.
The keyboard shortcuts are listed on the Window menu.

Switching between panels and icons
A column of panels can be fully expanded or collapsed to icons by clicking the tiny pair of
arrowheads at the top right of the column (see Figure 1-10). Dreamweaver remembers the
width of both the expanded column and icons, so collapsing to icons displays them with
labels or minimized, depending on your previous choice.

Figure 1-10. Click the pair of arrowheads to switch between icons and panels.

Temporarily hiding panels

When you want to clear the on-screen clutter to see your work in its full glory, just press
F4. Most panels will disappear, leaving the Document window dominating the screen. You
still have access to the Document toolbar, Tag selector, and Status bar, as they are integral
parts of the Document window. The Application bar also remains visible at the top of the
screen, as does the Insert panel if you have converted it to the Insert bar (see “Using and
configuring the Insert panel” later in this chapter).

In Windows, the Document window expands to fill the entire workspace. On a Mac, the
Document window doesn’t change size. However, if you drag the resize handle at the bot-
tom right of the Document window, you can get it to fill the whole screen. The panels
return when you press F4 again, and on both Windows and Mac, the Document window
shrinks back to fit inside the workspace. The next time you press F4 on a Mac,
Dreamweaver remembers to fill the screen with the Document window.

Figure 1-9.
The close button is located in
the conventional position for

each operating system.
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Using Auto-Show
Pressing F4 to restore all the panels can get a bit tiresome if you want to spend most of
your time in the Document window, so Dreamweaver CS4 has added a new feature that
automatically shows hidden panels when you move your mouse pointer to the edge of the
screen. If you move your mouse to the right edge of the screen, any panels hidden on that
side automatically pop out. You can then work in the panels, and they automatically slide
back out of view as soon as you move back into the document window. This is the default
behavior. 

If you want the panels to remain hidden, right-click any panel and select Auto-Show Hidden
Panels. Like many options in context menus, a check mark alongside the item indicates
that the option is enabled; no check mark indicates it’s disabled. Clicking the option tog-
gles it on and off.

Hiding the Application bar (Mac only)
In the Windows version of Dreamweaver CS4, the Application bar (see Figure 1-3) contains
all the main Dreamweaver menus, so it cannot be turned off. 

In the Mac version, the main Dreamweaver menus remain part of the OS X interface, and
the Application bar contains only a small number of shortcut menus to options that can
also be accessed through the main menus. If the Application bar gets in the way on a Mac,
you can hide it by selecting Window ➤ Application Bar. Select the same menu option to
restore it.

Moving and regrouping panels

The preset workspace layouts organize panels in logical groups. For example, the CSS
Styles and AP Elements panels are grouped together because they both deal with style
rules. But these groups are only suggestions; you can reorganize the panels just about any
way you want.

Moving a single panel
To move a single panel, click its tab and drag it away from its current position towards the
Document window. When you release your mouse button, the panel floats independently.
You can move the panel anywhere you like by grabbing the dark-gray bar at the top of the
panel and dragging it to a new position. You can also collapse the panel to iconic mode
(with or without a label), dock it in a different location, group it with one or more other
panels, or close it.

Pressing F4 to hide the panels and using Auto-Show is a very convenient way of work-
ing. It gives you plenty of space to work in your document, but puts the panels quickly
at your disposal. However, it can be difficult to control if you auto-hide the Taskbar on
Windows or the Dock on a Mac. Moving your mouse pointer too far off the screen trig-
gers the Taskbar or Dock, rather than the Dreamweaver panels.
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Moving a panel to a different group
To change a panel grouping, grab the tab of a panel that you want to move and pull it
away from its current position. As you drag it, it becomes semitransparent. Drag it over the
target panel or panel group until a blue border appears around the target, as shown in
Figure 1-11, and release the mouse button. Although Figure 1-11 shows the target as a sin-
gle floating panel, the target can be an existing group; it doesn’t matter whether it’s float-
ing or docked within a column of panels.

Figure 1-11. It’s easy to regroup panels.

Changing the order of panels within a group
If you prefer to display the panels in a different order, just drag one of the tabs to the left
or right. Repeat this process until the tabs are in the order you want.

Moving a group of panels
Moving a group of panels is quite easy, but you need to take care where you click to drag
the group as a single unit. Click anywhere between the last tab on the right and the tab
group menu, as shown in Figure 1-12. With some groups, this leaves very little room in
which to position your cursor. A simple way of getting around this problem is to make the
panel column wider by dragging its open side. This opens up the clickable area. Once you
have reorganized the panels the way you want, drag them back to the desired width.
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Figure 1-12.
Selecting the right place

to drag a panel group
can sometimes be tricky.



Stacking and docking panels
In addition to grouping panels together, you can stack them together to form a new column,
or dock them to the edge of the screen or another group of panels. As you drag a panel or
group of panels, watch for a thick blue line to appear. This indicates a dockable target.

Using and configuring the Insert panel

As I mentioned earlier, by default, the Insert panel occupies a large amount of space because of
the labels next to the icons. The Insert panel is also unusual in that it’s really many panels in one. 

As its name suggests, the Insert panel’s role is to insert frequently used elements, such as
images, tables, <div> tags, form elements, and Spry widgets, into a web page. They won’t all fit
conveniently into a single panel, so they’re divided into categories, which can be accessed
through a drop-down menu just below the tab, as shown in Figure 1-13. Dreamweaver is
context-sensitive, so the menu sometimes displays more categories than shown in the figure
(for example, the PHP category is accessible in a PHP page). Table 1-3 describes briefly what
each category contains. For the benefit of readers upgrading from Dreamweaver CS3, I have
indicated the main changes.

Figure 1-13.
The Insert panel contains
several categories
accessed through an
internal menu.
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Table 1-3. The main features of Insert panel categories

Category Description Changes from Dreamweaver CS3

Common Horizontal Rule has been added. Flash
Button and Flash Text have been
removed from the Media submenu.

Layout No change.

Continued

Offers various tools for layout, including table
modification, frames, and Spry widgets, such
as menu bar (see Chapter 6), and tabbed and
collapsible panels (see Chapter 7).

Inserts the most commonly used objects, such
as tables, images, and <div> tags.



Table 1-3. Continued

Category Description Changes from Dreamweaver CS3

Forms Checkbox Group and three new
Spry validation widgets (Password,
Confirm, and Radio Group) have
been added.

Data Spry XML Data Set and Spry Table
have been removed and combined
in a vastly improved Spry Data Set
feature (see Chapter 19).

Spry Spry Data Set replaces Spry XML
Data Set and Spry Table. New
validation widgets and Spry Tooltip
have been added.

InContext Editing New category.

Text No change.

Favorites Provides a blank category for you to
customize (see “Customizing the Favorites
category” later in this section).

Provides an alternative to the Property
inspector for common formatting options. It’s
also home to definition list and HTML entities.

Offers tools for Adobe’s hosted online service
that permits authorized users to update web
pages through an ordinary browser (see
Chapter 13).

Presents all Spry features gathered in a single
category.

Offers access to most dynamic features,
including Spry data sets (see Chapter 19) and
PHP server behaviors (see Chapter 14 onward).
Also imports data from comma-separated
value (CSV) files into a static web page.

Creates forms and inserts all form elements,
including Spry validation widgets (forms and
Spry validation are covered in Chapter 9).
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Many icons on the Insert panel have a small downward facing arrow to the right,
as shown alongside. This indicates that it contains a submenu of related options.
The first time you click one of these icons, Dreamweaver displays the submenu

showing all options (Figure 1-14 shows the options when you click the Images icon).
Dreamweaver remembers your selection and always displays the most recently used
option. If you want to use the same option again, click the icon itself. To select a different
option, click the arrow to the right to reveal the menu again.

For many Dreamweaver users, the Insert panel is one of the heavily used parts of the UI. If
you’re happy working with just the icons, you can hide the labels. You can also convert the
panel into a tabbed toolbar like the Insert bar in previous versions of Dreamweaver.
Regardless of which layout you choose, you can populate the Favorites category with your
own selection of frequently used items.



Figure 1-14. Many icons on the Insert panel conceal submenus.

Hiding the labels
If you want to save space by hiding the label alongside each icon, select Hide Labels from
the bottom of the Insert panel’s drop-down menu (shown on the right side of Figure 1-13).
If you forget what an icon represents, just hover your mouse pointer over it to display a
tooltip.

Hiding the labels leaves you with a vast expanse of unused panel. To reduce the height of
the panel, click the bottom and drag it upwards, as shown in Figure 1-15.

Figure 1-15. Hiding the labels on the Insert panel saves a lot of screen real estate.
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If you do this with the Common category selected, you might notice that Dreamweaver
prevents you from making the bottom of the panel fit snugly underneath the bottom row
of icons. This is because other categories have more icons, so enough space if left to dis-
play the largest category without the need to resize the panel.

Although this saves space, you still need to activate the drop-down menu to switch cate-
gories. Converting the panel to a tabbed toolbar avoids this problem.

Converting the Insert panel to a tabbed toolbar 
The easiest way to convert the Insert panel to a toolbar like the Insert bar in previous ver-
sions is to select Classic from the Workspace switcher. This moves the panel from its cur-
rent location to the top of the screen and converts it into a tabbed toolbar. Each tab
represents a category from the panel menu, giving you quick and easy access to all its
tools. If the tabs aren’t displayed, activate the drop-down menu on the left of the Insert
bar and select Show as Tabs.

On Windows, the Insert bar is located beneath the Application bar and stretches the full
width of the screen, as shown in Figure 1-16.

Figure 1-16. The only position for the Insert bar in Windows is directly beneath the Application bar.

Mac users have two options. The default Classic workspace layout in the Mac version of
Dreamweaver attaches the Insert bar to the end of the Application bar, as shown at the top
of Figure 1-17. The Mac version of the Application bar contains only a few items, so con-
verting the Insert panel to a toolbar makes much better use of your screen real estate. As
noted earlier, if you don’t want the Application bar, you can turn it off in the Mac version
by selecting Window ➤ Application Bar. This shifts the Insert bar left to occupy the space
previously taken by the Application bar, as shown at the bottom of Figure 1-17. However,
it doesn’t offer any real benefit, as the full width of the screen is still reserved for the
tabbed Insert bar. Unlike the Windows version, with the Mac, the Insert bar’s background
doesn’t expand to fill the empty space on the right. Contrary to what you might expect,
you cannot dock other panels to the right of the Insert bar. However, if you want to fill this
empty space, you can float other panels over it.

Figure 1-17. In the Mac version, the Insert bar can be displayed with or without the Application bar.

If you have already reorganized your workspace layout and don’t want to use the Classic
preset, you can detach the Insert panel from its current location by dragging its tab toward
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the top of the screen. Release the tab when you see a thick blue line indicating where it
will be docked. On Windows, the only place you can dock the Insert panel and display the
tabbed interface is directly beneath the Application bar. On a Mac, you can dock it to the
right of the Application bar, underneath the Application bar, or if the Application bar is
hidden, at the top of the screen. 

The convenience of the tabbed Insert bar is somewhat marred by the fact that it’s not
resizable. Also, you cannot dock anything to the right of it on either Windows or Mac. On
my 1680 × 1050 monitor, the icons in the Insert bar never stretch even halfway across the
screen, so a lot of space is wasted. Apparently, this is because of constraints imposed by
the common UI shared by all programs in Creative Suite 4. In testing Dreamweaver CS4, 
I have found the tabbed Insert bar to be the most efficient because I can afford the space
on my large monitor. Unfortunately, if space is a consideration, undocking the tabbed
Insert bar won’t solve your problems. If you undock the Insert bar from the top of the
screen by dragging the double column of dots on its left side, it automatically converts
back into a panel, and the tabs are no longer accessible.

Switching between tabs and menu 
If you prefer the drop-down menu to switch between categories, you can use it instead of
the Insert bar’s tabbed interface. Right-click anywhere in the dark-gray strip to the right of
the last tab and select Show as Menu. This saves a few pixels of vertical space. To display
the tabbed interface again, open the drop-down menu on the left of the Insert bar and
select Show as Tabs.

Customizing the Favorites category 
If switching among categories becomes too time-consuming, you can populate the
Favorites category with your most frequently used items. This option is available regardless
of how you have configured the Insert panel.

Right-click anywhere in the light-gray area of the Insert panel or Insert bar and select
Customize Favorites from the context
menu. The drop-down menu at the top
left of the Customize Favorite Objects
dialog box (shown in Figure 1-18) lets
you choose from either a master list or
individual categories. In the left panel,
select one item at a time and click the
button with the double chevron to add
it to the Favorite objects panel on the
right. To remove an item, select it in the
right panel and click the trash can but-
ton at the top right. The up and down
arrows next to the trash can can be
used to change the position of the
selected item. The Add separator button
below the list inserts a separator after
the current item.
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Figure 1-18. Customize the Favorites category of the Insert panel or Insert
bar for quick access to frequently used options.



The Customize Favorite Objects dialog box gives access to all categories, including context-
sensitive ones, such as PHP. Dreamweaver stores details of your Favorites category in your
personal configuration folder, so different users on the same computer can have person-
alized selections (as long as they use different user accounts). You can copy your Favorites
category to another computer, as described in the “Migrating snippets and other personal
settings” section later in this chapter.

Using the Property inspector

The Property inspector is the wide panel at the bottom of several preset workspace lay-
outs, including the default Designer (see Figure 1-3). The tab actually reads Properties, so
many people refer to it as the Properties panel, but the official name is Property inspector,
and that’s how I’ll refer to it throughout this book.

The Property inspector is context-sensitive; it displays properties related to the current
selection in the Document window. Figure 1-19 shows the contents of the Property inspec-
tor when an image is selected. As you can see, it gives access to the main attributes of the
<img> tag, including src, alt, width, height, and class. It also contains a small number of
image editing tools.

Figure 1-19. The Property inspector gives access to the main attributes of the <img> tag when an
image is selected.

Selecting HTML and CSS view in the Property inspector
When the cursor is in an empty part of the Document window or text is selected, the
Property inspector displays a completely different set of options. Figure 1-20 shows what
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it looks like when the pull quote on the left of the Document window is selected. The
important thing to note is that there are two buttons on the left of the Property inspector:
HTML and CSS. These are new to Dreamweaver CS4, and you need to check carefully
which one is selected, as the options look very similar, but work in very different ways.

Figure 1-20. When editing text, the Property inspector has separate options for HTML and CSS.

With the HTML button selected, you can format text by applying Hypertext Markup
Language (HTML) tags such as paragraphs (<p>) and headings (<h1> through <h6>), bold
(<strong>), italic (<em>), and bulleted and numbered lists (<ul> and <ol>), as well as
applying hyperlinks (<a>). If you’re upgrading from a previous version of Dreamweaver,
selecting the HTML button in the Property inspector gives you most of the options that
you’re used to seeing. However, the options to select the font face, size, and color are
missing. To access them, you need to select the CSS button.

Modern web standards advocate the separation of content and presentation by marking
up the structure of the page with HTML, while leaving all stylistic elements, such as fonts,
colors, and backgrounds, to CSS. In keeping with this approach, Dreamweaver CS4 has
moved the tools for styling text and other elements to a separate view of the Property
inspector. Figure 1-21 shows what the Property inspector looks like when you select the
CSS button with the same pull quote selected as in Figure 1-20. As you can see, it has a
drop-down menu on the left labeled Targeted Rule. This automatically selects what
Dreamweaver judges to be the most appropriate rule to edit, but you can make your own
selection or use it to create a new rule. Using the CSS features of the Property inspector is
covered in Chapter 4.
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Figure 1-21. Selecting the CSS button in the Property inspector reveals options for creating style
rules for the current element.

Configuring the Property inspector 
The Property inspector is not as versatile as the Insert panel when it comes to rearranging
your workspace. You can cut its height in half by clicking the little upward-facing triangle
at the bottom right of the Property inspector (see Figure 1-21). However, this conceals all
the options in the lower half. There aren’t many options for text in the lower half (see
Figures 1-20 and 1-21), but as Figure 1-19 shows, there are many more for an image. To
restore the Property inspector to its full height, click the triangle again (it points down-
ward when the bottom half is concealed).

Unfortunately, the three icons on the right edge of the Property inspector have a nasty habit
of disappearing on monitors smaller than 1280 × 1024 pixels (the minimum specification for
Dreamweaver CS4 is 1024 × 768). The icons are hidden behind any panels to the right of the
Property inspector. This is a known bug that makes collapsing the Property inspector a risky
business and not recommended on small monitors. If you can’t access the expand triangle,
collapse any other panels to iconic mode. If that doesn’t work, detach the Property inspec-
tor from the bottom of the screen by dragging its tab into the Document window. This
should display the Property inspector full width, giving access to the expand triangle.

A better way to gain more room in the Document window is to click the dark-gray bar
alongside the tab of the Property inspector. This collapses the panel containing the
Property inspector to a narrow strip at the bottom of the screen. Click again, and the panel
is restored to its normal size. You can also save space by automatically hiding all panels
when not in use by pressing F4, as described earlier in the chapter.

A big complaint about the Property inspector is that it stretches horizon-
tally to fill the available space at the bottom of the screen, but all the text
fields remain the same size. On a large monitor, this results in a lot of
wasted space. You can detach the Property inspector from the bottom of

the screen and use it as a floating panel. Once floating, it can be collapsed to iconic
mode with or without a label, as shown alongside. When you expand the Property
inspector from iconic mode, it occupies 825 × 130 pixels and cannot be resized.

“Where has my Link field gone?” This was one of the most common cries for help during
the public beta of Dreamweaver CS4. Regular users of Dreamweaver are used to always
seeing the Link field in the same place in the Property inspector and panic when it’s not
there. It’s still where it always used to be, but it’s visible only when the HTML button is
selected. Dreamweaver always remembers your most recent selection, so if you have
been working with CSS, you need to switch back to access the HTML formatting
options, including creating a hyperlink.
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Using the Results panel group

By default, the Results panel group remains hidden in all preset workspace layouts. It
opens automatically at the bottom of the screen (below the Property inspector if that’s
already at the bottom) after performing certain operations, such as find and replace, vali-
dation, or link-checking. It also contains the Reference panel (Shift+F1), which has com-
prehensive guides to HTML, CSS, and other web technologies (unfortunately, the PHP
material is rather out-of-date). 

To minimize the Results panel group, press F7 or click the dark-gray bar to the right of the
tabs. This leaves the tabs visible at the bottom of the screen. Pressing F7 or clicking the
dark-gray bar toggles it open and closed. To get rid of this panel group completely, right-
click the dark-gray bar and select Close Tab Group. However, it automatically reopens
whenever prompted to do so by Dreamweaver. You cannot get rid of it permanently, nor
should you want to; it contains useful information.

The problem with the Results panel group is that it cannot be resized in its default loca-
tion, often making the contents difficult to read. The best way to use the Results panel
group is to turn it into a floating panel by dragging the dark-gray bar to the right of the
tabs into the Document window. Once it’s floating, you can resize it by dragging either of
the bottom two corners or any side except the top. Another benefit is that pressing F7
closes the panel group completely, rather than minimizing it. Alternatively, you can con-
vert it into an iconic panel.

Managing workspaces

Being able to configure the workspace in such a variety of ways makes Dreamweaver CS4
extremely versatile, but what if you don’t like the changes? Or what if you like the changes,
but don’t always want to work the same way? Adobe has provided for these cases by
including options to reset the current workspace to its original settings and save cus-
tomized ones.

At the bottom of the Workspace switcher (see Figure 1-4 earlier in the chapter) are the
following three options:

Reset ‘Workspace’: This resets the current workspace to its original settings
(Workspace is replaced by the actual name). It works with both the preset layouts
that ship with Dreamweaver and your own customized layouts.

New Workspace: This opens a dialog box that lets you save your own customized
layout. Once you have configured the workspace to your own liking, just select this
option, give the new workspace a name, and click OK. This adds the customized
layout to the Workspace switcher, allowing you to switch to it at any time.

Detaching the Property inspector from its default position can be a frustrating experi-
ence. Even if you drag it some distance, it stubbornly snaps back to the bottom of the
screen. The secret is to collapse other panels that are open, and then drag the Property
inspector to the top half of the screen.
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Manage Workspaces: This displays a list of customized layouts stored in the current
user’s configuration folder with options to rename or delete them. Once you
delete a customized layout, you cannot restore it.

The Workspace switcher is always visible in the Windows version of Dreamweaver CS4. If
you have hidden the Application bar on Mac OS X, you can access the Workspace switcher
options from the Workspace Layout submenu of the Window menu (the same options are
available on Windows).

Dreamweaver stores details of customized workspace layouts as Extensible Markup Language
(XML) files, a platform-neutral format, so you can share layouts with other users even if
you’re using different operating systems. For details, see the “Migrating snippets and other
personal settings” section later in this chapter.

Exploring the Document window
Whether you’re a designer, a coder, or a bit of both, the Document window is where you
do most of your work in Dreamweaver. Like the UI, it has a lot of new features. Some, like
Related Files and Live view, have a major impact on the Dreamweaver workflow. Others,
like Vertical Split view and Split Code view, are simple improvements that both newcom-
ers and old hands are likely to find welcome aids to productivity.

Figure 1-22 shows the main parts of the Document window (in Design view, showing a file
used later in the book). The following sections describe briefly the various options avail-
able in the Document window. How they’re used in the context of building a website is
covered in the rest of the book. 
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A web page displayed in

Design view.



Working with tabbed windows

By default, Dreamweaver displays web pages, JavaScript files, style sheets, and all other
web documents in a tabbed interface. Tabs are created from left to right in the same order
as the pages are opened, but you can drag and drop them into any order.

Viewing the file path
The physical file path of the currently selected document is displayed in the dark-gray bar
alongside the tabs. Unfortunately, if you have a large number of tabs open, this conceals
the file path. However, you can always see the file path by hovering your mouse pointer
over the document’s tab, where it is displayed as a tooltip. The Coding toolbar (described
in the “Using the Coding toolbar” section later in this chapter) also displays a list showing
the full path name of all open files.

Closing tabs
To close a document, click the close button on the right side of the tab. This is different
from previous versions of Dreamweaver, and is particularly likely to confuse Windows
users, who will need to get out of the habit of going to the top right of the Document win-
dow to close a document (where you’re likely to hit the restore down button by mistake).
Although this is different from previous versions, it brings Dreamweaver into line with the
way that browsers work, so the change is quite logical. Mac users might also feel a little
discomfort because the close button has moved from the left side of the tab to the right,
so it’s now on the opposite side from the Safari browser.

To close all tabs at once, right-click any tab and select Close All from the context menu.
Alternatively, use File ➤ Close All on the main menu system, or the keyboard shortcut
Ctrl+Shift+W/Shift+Cmd+W.

To close all documents except the selected tab, right-click the tab, and choose Close Other
Files from the context menu. The tab context menu offers other options for opening, sav-
ing, and comparing documents (file comparison depends on setting up a third-party util-
ity; see Chapter 2 for details).

Displaying documents outside the tabbed interface
If you decide you don’t want your documents displayed in the tabbed interface, you can
break them free. The method depends on your operating system.

On Windows, click the restore down button at the top right of the Document window to
display the document in what looks like a normal window. It has minimize, maximize, and
close buttons like any other window, but its movement is restricted to inside the
Document window. If you open a new document, it opens in a similar window. Clicking the
maximize button converts the window back to a Dreamweaver tab. 

The Mac version works considerably differently. By default, the first document opens in an
ordinary window. The tabbed interface appears only when you open two or more docu-
ments. If you prefer to open the first document in a tab as well, select Dreamweaver ➤
Preferences (Cmd+U), choose the General category, and enter a check mark in the Always
show tabs checkbox. If you don’t want tabs at all, make sure that both the Open documents
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in tabs and Always show tabs checkboxes are deselected. You can also move a document
from its tab into a separate window by right-clicking the tab and selecting Move to New
Window from the context menu.

Getting quick access to related files

Dreamweaver CS4 has two powerful new tools that give you instant access to style sheets,
external JavaScript files, and other documents linked to a web page. The Related Files fea-
ture supports all linked files, whereas the Code Navigator is dedicated to working with
style sheets.

Using the Related Files toolbar
If you work regularly with external style sheets, JavaScript files, or server-side includes, be
prepared for one of the biggest improvements to your workflow. The Related Files feature
automatically detects whether the current document has links to external files and lists
them in the Related Files toolbar just above the Document toolbar (see Figure 1-22).
Dreamweaver loads the code of each file into memory, giving you instant access just by
clicking the file name in the Related Files list. This means that you no longer need to
search in the Files panel to locate a style sheet or JavaScript file for editing; it’s there at the
click of your mouse.

The Related Files toolbar doesn’t list images, SWF files, or other visual assets, so it doesn’t
get cluttered with irrelevant files. Normally, Dreamweaver goes only one level deep, so just
the files that are directly linked to the page are listed. For example, if the main document
uses a server-side include called menu.inc.php, it’s listed, but any files included directly by
menu.inc.php are not listed. Style sheets are the only exception. All style sheets that affect
the main document are listed however deep they are in the site hierarchy. For example, if
styles.css uses @import to link to more_styles.css, both are listed, even though the
main document doesn’t have a direct link to more_styles.css.

If the main document has so many related files that the names won’t all fit in the Related
Files toolbar, a double chevron appears at the end of the list. Click it to reveal a list of the
remaining files. Files are listed in the order they are linked to the main document. You can-
not change the order in the Related Files toolbar. Files added to a page after it has been
opened in the Document window are added automatically to the Related Files toolbar. If a
file fails to appear in the toolbar, press F5. This is a keyboard shortcut for refreshing Design
view, which also has the effect of updating the Related Files toolbar.

When you click a file name in the Related Files toolbar, Dreamweaver opens Split view, dis-
playing the code of the related file in one half of the Document window, while leaving the
main document in Design view in the other half, as shown in Figure 1-23 (see the
“Switching between Code, Design, and Split views” section later in the chapter for details
on how to change the layout). The related file is editable, and you can see the results of
changes immediately by pressing F5 or clicking in the Design view half of the Document
window. There’s no need to save the related file first, so if you don’t like the result, you
can continue editing the file until you achieve the desired result. Dreamweaver puts an
asterisk (*) alongside the name of the file you have edited to indicate that the changes
haven’t been saved. To save the changes, make sure the focus is in Code view and press
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Ctrl+S/Cmd+S or select File ➤ Save. To reject the changes, click No when prompted to
save them when you close the main document.

Figure 1-23. The Related Files feature lets you edit style sheets in Code view and see the results
instantly in Design view.

Using the Code Navigator to edit style sheets
If the current page has style rules, either in an external style sheet or in the <head>
of the document, leave your cursor in the Document window for a few seconds
without any other activity, and a little icon like a ship’s wheel (as shown alongside)

pops up. It doesn’t matter whether you’re in Code view or Design view; it keeps on making
an appearance. If you don’t know what it is, it will probably drive you insane after a short
while. Even if you do know what it is, its persistence can be just as maddening. 

When upgrading to Dreamweaver CS4, you might find the Related Files feature disori-
enting to begin with, as there’s no longer any need to open style sheets and external
JavaScript files in separate tabs. If you open a related file in a tab of its own,
Dreamweaver keeps both versions in sync with each other, but keeping track of where
you’re working can be confusing. If you find the Related Files feature doesn’t fit into
your workflow, you can disable it by selecting Edit ➤ Preferences (Dreamweaver ➤

Preferences on a Mac), choosing the General category, and deselecting Enable Related
Files. You need to restart Dreamweaver for the change to take effect. The Related Files
feature cannot be turned on and off on the fly.
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The icon has been put there for discoverability (if it doesn’t appear, don’t worry, because
I’m going to recommend that you disable it and use a keyboard and mouse shortcut
instead). The idea is to get you to discover the wonders of the Code Navigator. 

Figure 1-24 shows what happened when I placed my cursor inside the pull quote to the
left of the image, waited for the icon to pop up, and then clicked it. The Code Navigator
displayed a list of style rules affecting the pull quote, showing the details of each one in a
pop-up window as I moused over the name of the rule. As if that isn’t impressive enough,
each style rule is a hyperlink. Just click, and Dreamweaver opens the style sheet as a
related file in Split view, with your cursor inside the selected rule ready for editing.

Figure 1-24. The Code Navigator is a powerful tool for inspecting and editing CSS.

If your web page is created from a Dreamweaver template or contains a library item, the
Code Navigator also provides a link to the master template or library file (templates are
covered in Chapter 13; library items are not covered in this book, as PHP includes—covered
in Chapter 12—are more efficient). Similarly, if the page contains an <iframe>, the Code
Navigator provides a link to the source document. When you click one of these links, the
file opens in a new tab, ready for editing.

Once you have discovered the Code Navigator, I recommend that you get rid of the
annoying icon popping up every few seconds. Just put a check mark in the Disable indica-
tor checkbox at the bottom right of the Code Navigator (see Figure 1-24). After disabling
the icon, you can display the Code Navigator by holding down the Alt key (Opt+Cmd on a
Mac) while clicking anywhere in the Document window. 

Although you can resize the Code Navigator, you can’t move it to a different position. If
you find that it’s blocking your view of the page, keep in mind that where you click while
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holding down Alt or Opt+Cmd key doesn’t change the current selection or position of the
cursor in Design view. It simply determines the location of the top-left corner of the Code
Navigator (if there’s insufficient space, it goes for the nearest position).

If you prefer to use a keyboard shortcut to invoke the Code Navigator, it’s Ctrl+Alt+N on
Windows and Opt+Cmd+N on a Mac. The Code Navigator is also accessible through the
View menu, the context menu in any view, and the Coding toolbar (see Figure 1-31, later
in the chapter). There are so many ways to access the Code Navigator, something tells me
Adobe doesn’t want you to miss it!

To dismiss the Code Navigator, just click anywhere else on the screen.

Exploring the Document toolbar

Running across the top of the Document window is the Document toolbar, which is mainly
concerned with controlling how your main work environment looks (see Figure 1-25). The
first three buttons on the left let you switch quickly between Code view, Design view, and
a combination of both called Split view, as shown earlier in Figure 1-23. The next button,
labeled Live View, toggles on and off another major innovation in Dreamweaver CS4, which
renders the page as it will look in a standards-compliant browser without the need to
leave Design view.

Figure 1-25. The Document toolbar mainly controls the look of the Document window

The following sections describe each of these features briefly.

Switching between Code, Design, and Split views
Some web designers, particularly those from a graphic design background, never want to
see the HTML, CSS, or JavaScript code that lies behind Design view. This is a recipe for dis-
aster with Dreamweaver. Although it’s a visual design environment, you can’t treat it like a
word processor or desktop publishing program. You need to have a good understanding
of where you’re inserting elements into a page—something that’s particularly important
when you mix dynamic elements into a page using a server-side technology like PHP or
JavaScript widgets. You don’t need to know every tag and property, but you do need to
have a good understanding of the technologies that lie behind the creation of a standards-
compliant web page. Dreamweaver helps you by making it easy to switch quickly between
the Code view and Design view, as well as displaying both in Split view.
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The labels on the three buttons at the left end of the Document toolbar are fairly self-
explanatory:

Code: This displays the raw code. When the document is a static web page, it gives
access to the code as you might see it in a browser’s source view. If the page uses
a server-side technology, such as PHP, it displays the server-side code before it has
been processed. Pages that contain only code, such as JavaScript files and style
sheets, are always displayed in Code view.

Split: This displays Code view in one half of the screen and Design view in the
other half.

Design: This is Dreamweaver’s visual environment for creating and editing web
pages. It displays a very close approximation of what the page should look like in a
browser.

The default setting for Split view is to split the page horizontally with Code view on top, as
shown earlier in Figure 1-23. You can reverse the layout by displaying Design view at the
top and Code view at the bottom. Even better, you can now split the screen vertically, as
shown in Figure 1-26. This layout works best on a large monitor (the screenshot was taken
in the Classic workspace layout with Dreamweaver maximized on a 1680 × 1050 monitor
and all the panels hidden). The default is to show Design view on the right, but you can
reverse this.
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Vertical Split view has long been requested by regular Dreamweaver users. Another of
their requests has also been granted: Split Code view, which enables you to see different
sections of code from the same document. Split Code view can be displayed with the
screen split horizontally or vertically. Each section of screen scrolls independently. You can
cut and paste from one section to the other, but you cannot drag and drop.

Access to all these Split view options is either through the View menu or the Layout control
on the Application bar, as shown in Figure 1-27. Unless you have hidden the Application bar
on the Mac version, using the Layout control is easier because there are fewer options to
choose from. If the Split Vertically and Design View on Left options are grayed out, switch 
to Split view by selecting Code and Design. (When the screen is split horizontally, Design
View on Left changes to Design View on Top.)

Figure 1-27. You can use the Layout control on the Application bar to switch to Vertical Split view.

If you have more than one document open, the Split view options are specific to each tab.
To set your preferred Split view layout as a default, close all documents except one. Set
your desired options, and then close the document. Dreamweaver remembers your pref-
erences and applies them to all future documents, but you can switch to a different layout
at any time. 

Using Live view to test pages
Yet another major change in Dreamweaver CS4 is the introduction of Live view. This uses
the open source WebKit browser engine (http://webkit.org/) to display the current doc-
ument exactly as it will look in a standards-compliant browser. Dreamweaver uses essen-
tially the same version of WebKit as Safari 3, but with certain modifications to provide
extra functionality within Design view. Dynamic features, such as rollovers, JavaScript
menus, and server-side code, work as you would expect in a browser. Although this is no
substitute for testing the page in all your target browsers, used in combination with the
Related Files feature, it makes editing dynamic features a breeze. Figures 1-28 and 1-29
show Live view in action.
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Figure 1-28. Using Live view makes it possible to view the effect of changes to style rules for dynamic features.
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Live view makes a huge difference when working with Ajax or Spry (Adobe’s implementa-
tion of Ajax). The screenshot in Figure 1-28 shows how you can test the rollover effect 
in a Spry menu bar (see Chapter 6) without needing to leave the Document window.
I turned on Live view, activated the menu bar in Design view, invoked the Code Navigator,
and then selected the :hover style rule for menu items. This opened the style sheet as a
related file in Split view, ready for me to edit. After changing the color property, I pressed
F5 to refresh Design view and moused over the menu bar to see the results of the
change. I didn’t like the result, so I clicked No when prompted to save the changes when
closing the document.

Ajax stands for Asynchronous JavaScript and XML (see http://en.wikipedia.org/
wiki/AJAX). Originally, Ajax referred to using JavaScript to communicate with the web
server and redraw parts of the page without the need to reload the whole page. Since
then, its meaning has broadened to encompass just about any technique that uses one
of the popular JavaScript libraries such as Prototype (http://www.prototypejs.org),
script.aculo.us (http://script.aculo.us/), and jQuery (http://jquery.com/). Spry is
Adobe’s JavaScript library that powers the Spry menu bar (Chapter 6), various effects
and widgets (Chapters 7, 8, and 9), and Spry data sets (Chapter 19).



The top screenshot in Figure 1-29 shows what an image gallery built with a Spry data set
looks like in Design view. In Dreamweaver CS3, you needed to load the page into an
external browser every time you wanted to see the finished page. Live view makes that a
thing of the past (the data must come from a static source; Spry data sets that use
dynamically generated data still need to be viewed in a browser). The bottom screenshot
in Figure 1-29 shows the same page with Live view turned on. Not only do you see the
page as it will look in a browser, but also the main image changes when you click one of
the thumbnails.

Live view also works with server-side pages, such as PHP, as long as you have defined a
testing server in the site definition (see Chapter 2). If you’re upgrading from a previous
version of Dreamweaver, this effectively replaces Live Data view (the next section explains
the difference). Even if you don’t have a testing server, Live view still displays the static
HTML parts of the page.
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Figure 1-29. Working with Ajax and Spry data sets is transformed by Live view.



The down arrow to the right of the Live View button opens a menu controlling the follow-
ing options:

Freeze JavaScript: The menu option is mainly a reminder of the keyboard shortcut
(F6) to freeze dynamic effects controlled by JavaScript. For example, rollovers
depend on the position of your mouse. If you press F6, the rollover remains frozen
even when you move the mouse away to work on a related file.

Disable JavaScript: This option lets you see what the page looks like in a browser
that doesn’t support JavaScript or where JavaScript has been turned off.

Disable Plugins: This disables plugins, such as Flash Player, so you can see the effect
in a browser that doesn’t have the plugin.

Use Testing Server For Document Source: This applies only to pages that use a
server-side technology, such as PHP. A testing server needs to be set up in the site
definition (see Chapter 2) for server-side code to be processed. When you click
the Live View button in a PHP page, Dreamweaver automatically asks if you want to
update the page on the testing server. You must click Yes for the dynamic code to
be processed. If you click No, it asks if you want to use the local source files
instead. Using the local source files results in only the static HTML elements being
displayed.

Use Local Files For Document Links: This does not mean that you can use hyperlinks
in Live view to navigate to other pages in your site. It refers to using local versions
of style sheets and external JavaScript files, rather than using those on the testing
server.

HTTP Request Settings: This opens a dialog box that lets you set POST and GET vari-
ables to be passed to the page when displayed in Live view.

With the exception of HTTP Request Settings, all Live view menu options are toggled on
and off by clicking them. A check mark alongside an option indicates that it has been
turned on. 

What happened to Live Data and how does Live view differ? 
If you’re upgrading from a previous version of Dreamweaver, you might be confused by
the difference between Live view and Live Data view.

In previous versions, Live Data made it easy to envisage the output of pages using server-
side code, such as PHP and Active Server Pages (ASP), by processing the code through a
testing server and displaying it in Design view. Live view, on the other hand, works for all
web pages, not just ones that use server-side technology; and it uses a real browser engine
to display the content of your page. You still need a testing server to display dynamic out-
put from server-side code, but Live view renders the page far more accurately than Live
Data. For most purposes, Live view replaces Live Data view. 

Although Live view is much more accurate, a potential drawback is that you cannot edit
directly in Design view when Live view is turned on. You must either switch off Live view or
edit the source code in the Code view section of Split view. However, there are times when
it can be useful to edit the HTML elements of a page while viewing the output of server-side
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code. For example, you might want to edit the static header cells of a dynamically gener-
ated table. For this reason, Live Data view has been retained in Dreamweaver CS4. However,
it’s no longer accessible from the Document toolbar. To activate Live Data, use the menu
option View ➤ Live Data or the keyboard shortcut Ctrl+Shift+R/Shift+Cmd+R (the menu
option is visible only when the current document is a dynamic page).

Inspecting dynamically generated code with Live Code
The resurgence of interest in JavaScript stemming from the popularity of Ajax and libraries
such as jQuery and Spry has undoubtedly brought benefits. JavaScript sees a web page in
terms of a hierarchical structure known as the Document Object Model (DOM), which can
be manipulated to produce dynamic effects, including rollovers and sliding panels, and to
rearrange the content of the page. The difficulty, from the developer’s perspective, is that
JavaScript manipulates the DOM behind the scenes inside the browser, so it can be very
difficult to troubleshoot if anything goes wrong. If only you could see the HTML code gen-
erated by the JavaScript . . . Well, now you can, thanks to the Live Code button on the
Document toolbar.

The Live Code feature lets you inspect the HTML generated not only by JavaScript, but also
by server-side languages such as PHP (as long as you have defined a testing server). It relies
on Live view, so the Live Code button remains grayed out on the Document toolbar until
Live view is invoked. When you click the Live Code button, Dreamweaver opens Split view
(if it’s not already open) and displays the generated code in Split view. As a visual reminder
that you’re viewing the generated code rather than the original, the background color of
Split view turns yellow. Figure 1-30 shows part of the script from the Spry image gallery in
Figure 1-29 as seen in Code view normally (top screenshot) and with Live Code turned on
(bottom screenshot). The JavaScript commands highlighted in gray in the top screenshot
are interpreted by the Live Code engine to generate two <option> tags with values drawn
from a Spry data set.

Only static HTML can be edited in Live Data view. Output generated by server-
side code cannot be altered except by editing the underlying code directly in
Code view.
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Figure 1-30. Live Code lets you see the HTML generated by JavaScript and server-side languages.



Live Code is a useful addition to a developer’s arsenal of debugging tools. However, don’t
confuse it with a real debugger like the FireBug plugin for the Firefox browser
(http://www.joehewitt.com/software/firebug/). It won’t tell you about syntax errors in
your code. But by showing you exactly what is being output by the JavaScript or server-side
code, Live Code provides confirmation (or otherwise) that your script is doing what you
intended. Live Code displays generated content, so you cannot edit Code view when it’s
turned on.

Other options on the Document toolbar
The following list briefly describes the other options on the Document toolbar:

Title: This is where you enter the document title that is displayed in the browser
title bar.

File management: This offers a quick way of uploading and downloading the current
file to and from your remote server. Setting the connection details is covered in
Chapter 2.

Preview in browser: This displays the current page in an external browser or Device
Central. Dreamweaver automatically detects the browsers installed on your com-
puter and lists them in a drop-down menu. Device Central is an emulator that lets
you see what your web page will look like in a mobile device. It’s a separate pro-
gram automatically installed with Dreamweaver, unless you deselect it during the
installation process.

Refresh: This refreshes Design view. It’s used only when you’re working in the
underlying code in Split view. Otherwise, Design view refreshes automatically. You
can also use F5.

If you find the bright-yellow background color of Live Code too much to bear, you need
to dive into the bowels of your computer to change it. 

On Windows, you need to modify the Windows Registry. This is not difficult, but it could
affect the operation of your computer if you’re not careful. On Windows Vista, click the
Start button and type regedit in the search field. This should display regedit.exe at the
top of the result list. Click it to open the Registry Editor. On Windows XP, launch the
Registry Editor by clicking Start ➤ Run, typing regedit in the Run dialog box, and click-
ing OK. In the Registry Editor, select this entry in the left pane: HKEY_CURRENT_USER\
Software\Adobe\Dreamweaver CS4\Tag Colors. In the right pane, select Background
Color – Live Code, right-click, and choose Modify from the context menu. Type a new
color in hexadecimal notation (e.g., #FFC for a lighter yellow) into the Value data field
and click OK. Close the Registry Editor and restart Dreamweaver.

On a Mac, open Macintosh HD:Users:<username>:Library:Preferences:Adobe
Dreamweaver 10 Prefs in a text editor such as BBEdit or TextWrangler (both from
http://www.barebones.com). Locate this line: background color – live code=#FF7.
Change the #FF7 to a new color in hexadecimal notation. Then save the file and restart
Dreamweaver.

THE ESSENTIAL GUIDE TO DREAMWEAVER CS4 WITH CSS,  AJAX,  AND PHP

36



View options: This turns rulers and guides on and off in Design view. It also controls
Code view features, such as line numbering and word wrap.

Visual aids: This controls the CSS visual aids described in Chapter 4.

Validate: This option checks your document, selected files, or the entire site against
World Wide Web Consortium (W3C) standards. However, it doesn’t work on PHP
pages, and Dreamweaver’s validator misses some errors, particularly when checking
against a Strict Document Type Definition (DTD). Double-check against the official
W3C Markup Validation Service at http://validator.w3.org.

Check page: This runs checks on the current page for browser compatibility and
accessibility. The results are shown in the Results panel group. It checks only static
code, so it might not always produce meaningful results on pages that generate
output dynamically with Spry or PHP. The browser-compatibility check provides
links to more detailed explanations and suggested solutions on the Adobe website.
You can also access the CSS Advisor website (http://www.adobe.com/go/bccdw)
directly from the Check page menu.

Getting the best out of Code view

Code view is not just for inspecting the underlying code. It’s a great editing environment
with many features, such as code hinting, syntax coloring, and automatic code comple-
tion, designed to make coding a pleasure rather than a chore. In fact, some regular
Dreamweaver users confess to spending 100 percent of their time here. Regardless of
whether you’re a coder or a designer, it’s useful to know your way around Code view.

Two new features that will be of particular interest to readers upgrading from a previous
version of Dreamweaver are code introspection for JavaScript and the ability to print code
in color.

Using the Coding toolbar
The Coding toolbar is displayed on the left side of Code view by default. It’s also available
in the Code Inspector (F10/Opt+F10), which allows you to view the underlying code of a
page in a separate window. The Coding toolbar can’t be undocked, but you can hide it in
Code view by deselecting it from the View ➤ Toolbars menu (or from the context menu of
any toolbar). In the Code Inspector, it’s controlled independently by the View Options
menu at the top of the inspector.

Don’t confuse the Code Inspector with the Code Navigator, which is new to
Dreamweaver CS4 and was described earlier in the chapter. The Code Navigator is ded-
icated to working with CSS, whereas the Code Inspector displays the underlying code of
the current document in a separate panel. It’s normally used only in a dual-monitor
workspace layout, effectively letting you see Code view and Design view full screen on
separate monitors. To launch the Code Inspector, press F10/Opt+F10 or select Window
➤ Code Inspector.
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Figure 1-31 shows the purpose of each button on the Coding toolbar; the same informa-
tion is displayed as a tooltip whenever you hover your mouse pointer over one of these
buttons. If there’s not enough room to display all the buttons, a double chevron appears
after the last button that can fit into the available space. Click it to display the rest of the
toolbar along the bottom of Code view.

Two buttons have been added since Dreamweaver CS3: Show Code Navigator and Syntax
Error Alerts in Info Bar. Also, the icon of Move or Convert CSS has been changed to match
the CSS Styles panel in iconic mode.

Let’s take a quick look at what each button does:

Open Documents: This displays a list of currently open documents together with the
full pathname of each file. This is very useful if you have several pages open, all
with the same name (such as index.php from different folders or sites). Click the
name of a file, and it comes to the front—no more guessing whether you have the
correct file open.

Show Code Navigator: This displays the Code Navigator, which was described ear-
lier in this chapter. The style rules displayed by the Code Navigator depend on the
current location of the cursor. The ability to identify the appropriate style rules
seems to be less accurate in Code view. When working in Split view, it is advisable
to select elements in the Design view half of the Document window before click-
ing this button.

Collapse Full Tag: This selects the code block in which your cursor is currently
located and collapses everything inside, including the opening and closing tags.
Unfortunately, it cannot be used to select a PHP code block. To collapse everything

Figure 1-31.
The Coding toolbar
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outside a full tag, hold down the Alt/Opt key while clicking the Collapse Full Tag
button. This is useful for isolating a block of code and hiding the rest of the page.

Collapse Selection: This collapses the currently selected code. To collapse all code out-
side the selection, hold down Alt/Opt while clicking the Collapse Selection button.

Expand All: Click this to expand all collapsed sections.

Select Parent Tag: This selects the parent tag of the current selection or wherever
the insertion point is currently located. For example, if your cursor is inside a para-
graph, it selects the entire paragraph and the enclosing <p> tags. Clicking again
moves up the document hierarchy, always selecting the parent element of the cur-
rent selection.

Balance Braces: This selects all code between matching curly braces, brackets, or
parentheses. This button will help maintain your sanity when working with JavaScript
and PHP code.

Line Numbers: This toggles on and off the display of line numbers in Code view.

Highlight Invalid Code: Dreamweaver highlights incorrectly nested tags in yellow. This
can be distracting in Code view, particularly when working with PHP, where condi-
tional structures might result in code that Dreamweaver incorrectly interprets as
invalid. This button toggles the yellow highlighting on and off in Code view. The
default is off.

Syntax Error Alerts in Info Bar: This pops up a yellow bar at the top of Code view
whenever Dreamweaver discovers what it thinks is a syntax error in JavaScript. As
you can see in Figure 1-32, Dreamweaver treats any incomplete statement as an
error. It doesn’t remove the warning until you type the closing brace of the func-
tion block. If you write your own JavaScript, you’ll find the constant nagging
extremely annoying. Turn off the alerts by clicking this button, and just use it to
check your script when you have finished. Clicking the button toggles it on and off,
and Dreamweaver remembers your last selection.

Apply Comment Tags: This lets you apply different types of comment tags to the
current line or selection. PHP comments are covered in Chapter 10.

Remove Comment Tags: This removes comment tags from the current line or
selection.

Wrap Tag: This provides a quick way to wrap the current selection in an HTML tag.
Dreamweaver lets you select any tag, even if it’s inappropriate in the current con-
text. This is based on the principle that, if you’re working in Code view, you should
know what you’re doing. When mixed with PHP conditional logic, apparently invalid
code is often perfectly OK, so Dreamweaver makes no attempt to intervene.

Figure 1-32.
The JavaScript syntax
checker tends to be
overzealous in what it
regards as errors.
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Recent Snippets: This displays a list of the most recently used items from the
Snippets panel, providing quick access to frequently used code snippets.

Move or Convert CSS: This provides a quick way to move style rules, as described in
Chapter 4.

Indent Code: This moves the opening tag of the current selection to the right. If
nothing is selected, Dreamweaver automatically selects the parent tag and moves
it. The Tab key performs the same function.

Outdent Code: This moves the opening tag to the left. You can also use Shift+Tab.

Format Source Code: This reveals a menu that lets you apply default formatting to
the entire page or the current selection. It also provides quick access to the Code
Format category of the Preferences panel and to the Tag Library Editor. The Tag
Library Editor gives you control over how every single HTML tag is formatted in your
underlying code. It’s mainly of interest to advanced users, but the interface is intu-
itive and easy to use.

In addition to using the Coding toolbar to collapse sections of code, you can use the key-
board shortcuts listed in Table 1-4. When you collapse a section of code, it affects only
what you see in Code view; the contents remain fully expanded in Design view.
Dreamweaver remembers which sections of code are collapsed when a page is saved, so
the same layout is visible in Code view the next time you open a document.

Table 1-4. Keyboard shortcuts for collapsing code

Action Windows shortcut Mac shortcut

Collapse full tag Ctrl+Shift+J Shift+Cmd+J

Collapse outside tag Ctrl+Alt+J Opt+Cmd+J

Collapse selection Ctri+Shift+C Shift+Cmd+C

Collapse outside selection Ctrl+Alt+C Opt+Cmd+C

Expand all Ctrl+Alt+E Opt+Cmd+E

To inspect a collapsed section, highlight it and use the plus button in the left margin (it’s a
triangle in the Mac version) to expand it, or hover your mouse pointer over it and view the
content as a tooltip.

To select sections of code in Code view, use the Select Parent Tag or Balance Braces but-
tons. Alternatively, use your mouse or keyboard in the same way as with any text editor.
Double-clicking selects the current word. Triple-clicking selects the parent tag. (The GoLive
selection shortcuts do not work in Dreamweaver.)
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Setting Code view options
Code view has a number of options that you can set by accessing View ➤
Code View Options or from the View Options menu on the Document toolbar
(see Figure 1-25 and the screenshot alongside). You toggle the options on
and off by clicking them. A check mark alongside an option indicates that
it’s active. These options work as follows:

Word Wrap: The way Dreamweaver wraps text in Code view confuses
many people. There are two options: soft and hard wrapping. Soft
wrapping is on by default and works like a word processor. When
code would normally extend beyond the right edge of Code view,
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Dreamweaver automatically wraps it to the next line. If you resize the Code view
window, the code reorganizes itself to fit the viewport. No new line characters are
inserted into the code until you hit Enter/Return. If you prefer your code to be in a
single line and don’t mind scrolling horizontally, deselect Word Wrap. Hard wrap-
ping is off by default. When turned on, it automatically inserts a new line character
a preset distance from the left margin. Although this makes code look tidy, it
causes serious problems with JavaScript and is not recommended. It’s controlled by
the Automatic wrapping option in the Code Format category of the Preferences panel
(Edit ➤ Preferences or Dreamweaver ➤ Preferences). If you have turned this option
on, I strongly recommend that you turn it off and rely on soft wrapping instead.

Line Numbers: Dreamweaver displays line numbers in the left margin of Code view.
They are generated automatically and don’t become part of your code. The line
numbers are particularly useful for locating problems with PHP code. You can also
toggle them on and off from the Coding toolbar. Lines that are soft-wrapped have
only one line number, even if they span several lines on the screen.

Hidden Characters: This option reveals characters that aren’t normally visible in
your code. It should normally be turned off, but can be useful for debugging prob-
lems caused by unwanted newline characters in PHP or JavaScript.

Highlight Invalid Code: This menu option does the same as the button on the Coding
toolbar described in the preceding section.

Syntax Coloring: Dreamweaver highlights HTML, PHP, and other code in preset col-
ors according to the role it fulfils, making it easy to identify key sections of code
quickly. Forgetting to close a pair of quotes results in the subsequent code being
displayed in the wrong color, alerting you to the mistake. In normal circumstances,
this option should always be on. You can adjust the colors to your liking by going
to Edit ➤ Preferences (Dreamweaver ➤ Preferences on a Mac) and selecting Code
Coloring. Choose the appropriate Document type, and click Edit Coloring Scheme.

Auto Indent: With this option selected, Dreamweaver automatically indents your
code according to the settings in the Code Format category of the Preferences panel
and the Tag Library Editor.

Syntax Error Alerts in Info Bar: This option does the same as the button on the
Coding toolbar described in the preceding section. 

Design View on Left: This option is available only in Vertical Split view; in the default
Split view, it changes to Design View on Top. In both cases, it controls on which side
Design view is displayed in Split view.

Color Icons: This toggles icons between grayscale and color.



Using code hints and auto completion
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By default, Dreamweaver displays context-sensitive code hints in Code view.
For example, if you type an opening angle bracket after the <body> tag of an
HTML page, a context menu pops up, displaying all valid HTML tags, as shown
in the screenshot alongside. You can scroll down to find the tag you want and
double-click to insert it, or just continue typing. As soon as you type di, the
context menu highlights <>div. Press Enter/Return, and Dreamweaver com-
pletes the tag name.

When you press the spacebar, another context menu springs up, this time
showing you all the valid attributes for the tag. Again, scroll down to select

the one you want or continue typing. If you type id and press
Enter/Return, Dreamweaver enters id="" and positions the inser-
tion point between the quotes, ready for you to insert the ID
value. Even better, if your page already has a style sheet attached
to it, Dreamweaver populates a list of defined IDs, as shown in 
the screenshot alongside. Use your keyboard arrow keys and
Enter/Return to insert your choice. Alternatively, select it with
your mouse pointer and double-click.

These context menus continue to appear until you type the closing angle bracket of the
tag. If you lose the context menu, just press Ctrl+spacebar anywhere between the opening
and closing brackets of a tag. 

Dreamweaver is smart enough to keep track of which tags are open. As soon as you type
</ in Code view, it automatically inserts the correct closing tag. For example, let’s say you
have the following code in a page:

<p>This text is <strong>bold and <em>italicized

If you type </ three times, Dreamweaver automatically completes the open tags in the cor-
rect order like this:

<p>This text is <strong>bold and <em>italicized</em></strong></p>

For compatibility with older versions, you can get Dreamweaver to insert the matching
closing tag as soon as you type the closing angle bracket of an opening tag. So, if you enter
<p>, Dreamweaver inserts </p> and places the insertion point between the opening and
closing tags. This setting can be useful when working with PHP because Dreamweaver

The only exception to this automatic completion of the closing tag is with <script>.
This is to prevent Dreamweaver from closing the <script> tag incorrectly inside a block
of JavaScript.

The keyboard shortcut for code hints on the Mac version is the same as Windows
(Ctrl+spacebar) to avoid a conflict with Spotlight, which uses Cmd+spacebar.



sometimes gets confused as to which tag should be completed if dynamic code lies in
between. You can also tell Dreamweaver never to complete tags. To change the default
settings, select Edit ➤ Preferences (Dreamweaver ➤ Preferences on a Mac) and choose the
Code Hints category.

Most people find code hints invaluable, but if they annoy you or get in your way, you can
delay their appearance by up to five seconds or turn them off altogether. However,
Dreamweaver is much more responsive if you leave the delay at its default setting of zero.
The Menus option in the Code Hints category of the Preferences panel lets you turn off
code hints for individual categories. For example, you may decide that you want code hints
only for HTML tags and CSS properties. All categories are enabled by default.

Introducing improved support for JavaScript code hints
Previous versions of Dreamweaver have offered only limited support for JavaScript code
hints. Not only were the code hints incomplete, they were also available only in external
JavaScript files. JavaScript code hints are now also available in <script> blocks in web pages.
Moreover, the range of code hints now means serious JavaScript programmers can continue
working inside Dreamweaver CS4 without needing to switch to a different program.

Dreamweaver now has code hints for properties and methods of the following primitive
data types: Object, Array, Boolean, Date, Number, RegExp, and String. It also has support
for the main built-in DOM object. The code hints are triggered as soon as you type a
period after a variable or object.

The most welcome news of all for programmers is that Dreamweaver CS4 is also capable
of code introspection. This means that Dreamweaver scans your own functions, classes,
and JavaScript Object Notation (JSON) objects and provides code hints for them, too. Your
custom definitions can be either in the same document or in an external file (as long as it’s
linked to the document you’re working in). Figure 1-33 shows an example of a code hint
being displayed for a custom function defined in the <head> of a web page.

Figure 1-33. Dreamweaver CS4 now provides code hints for 
your own JavaScript functions, classes, and JSON.

Printing code in color
This is something that has been requested for many years: Dreamweaver CS4 finally prints
code in color. To print the code of the current document, select File ➤ Print Code, right-
click in Code view and select Print Code from the context menu, or press Ctrl+P/Cmd+P.

Dreamweaver uses the same colors as in Code view. However, it does not print the back-
ground color, even if you have changed it from the default white; any parts of code that
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are white or nearly white are converted to black. To print code in black and white, dese-
lect Syntax Coloring in View ➤ Code View Options or the View Options menu of the
Document toolbar.

Line numbers are included in the printout. To turn them off, deselect Line Numbers in View
➤ Code View Options or the View options menu of the Document toolbar.

A quick look at other changes in
Dreamweaver CS4

The main focus of this chapter has been an in-depth tour of the UI for both newcomers and
old hands. But so much has changed in Dreamweaver CS4, it has also been a guide to what’s
new. So I think it’s worth spending a little time looking at the remaining new features, most
of which are covered in greater depth in later chapters. It’s also important to note that
some features have been removed from Dreamweaver, so I’ll also cover what’s gone.

Screen sharing

It’s often a lot quicker and more effective to show a client or colleague how to do something
than try to explain the procedure in words. Thanks to a new feature called Creative Suites
Extended Services (CSXS), you can do that with Dreamweaver and most other CS4 applica-
tions, even if the other person is on the other side of the world. In fact, you can invite up to
three others to participate in the demonstration. All you need is an Adobe ID, which involves
registering a few basic details on the Adobe website (http://www.adobe.com). If you don’t
already have an ID, you can apply for one the first time you access CSXS.

At the time of Dreamweaver CS4’s initial release, only two services were available: the
Search for help feature (see Figure 1-3 and Table 1-1) and Share My Screen, which pro-
vides instant desktop sharing through an Internet connection. There is currently no charge
for the screen-sharing service, so why not give it a try?

Why is screen sharing free? No doubt because Adobe hopes the experience of using this
type of desktop conferencing will encourage businesses to subscribe to the paid-for ver-
sion, which can host up to 15, 500, or 1,500 participants, depending on the level of sub-
scription (http://www.adobe.com/products/acrobatconnect/).

Using the keyboard shortcut Ctrl+P/Cmd+P prints the underlying code even if you
invoke it while in Design view. It does not print the page layout. To print what the page
looks like, you need to launch the web page in a browser and print it from there.
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Setting up a screen-sharing session
The following instructions guide you through the basic process of sharing your screen with
up to three other people. The screen-sharing service is hosted through Adobe ConnectNow,
so you need to be connected to the Internet to use it.

1. Inside Dreamweaver CS4, select File ➤ Share My Screen.

2. Dreamweaver communicates with the ConnectNow server, and when it establishes
a connection, you should see the login panel shown in Figure 1-34.
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Figure 1-34. To share your screen with up to three others, you need to log in to Adobe ConnectNow.

If you don’t have an Adobe ID, click the Create a free Adobe ID link, and follow the
on-screen instructions.

If you already have an Adobe ID, enter your email address and Adobe password in
the appropriate fields.

If you select the checkbox labeled Remember me on this computer, the next time
you access File ➤ Share My Screen, the login panel disappears as soon as
Dreamweaver has connected with the Adobe server.

If this is the first time you are logging in, or if you prefer not to be logged in auto-
matically, click the Sign In button (it’s grayed out in Figure 1-34 because the
required fields haven’t been filled in yet).



3. Once you have logged in, you will be presented with the exclusive URL that enables
others to view your screen, as shown in Figure 1-35. Adobe ConnectNow automat-
ically assigns the URL based on your name. If you want to change it, click the
Customize Your Meeting URL link. There’s also a link that creates email invitations to
send to the people you want to join the session.

4. When you click the Close button, ConnectNow launches your browser. If this is the
first time you have participated in a session using ConnectNow or the paid-for ver-
sion, Connect, you might be prompted to install a special plugin. This is necessary
for screen sharing to work. It should normally be a very quick process.

5. Once the browser has connected successfully to ConnectNow, it launches the
screen shown in Figure 1-36. This is your online meeting room, which is actually a
desktop application that runs in the Adobe Integrated Runtime (AIR). 

Figure 1-36. The ConnectNow meeting room lets you control what others see.

Figure 1-35.
Adobe ConnectNow gives you a

personalized URL for your screen-
sharing sessions.
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At this stage, no one can see your screen. The ConnectNow window has a chat
panel that works just like instant messaging. In the center is a button labeled Share
My Computer Screen. Before clicking this, you should be aware that once you start
sharing, other participants will be able to see everything on your desktop, not just
Dreamweaver. So make sure there’s nothing there that you wouldn’t want your
mother or the taxman to see. You can minimize the ConnectNow window to tidy
things up, if necessary.

6. When your guests access your personal URL, they will be asked to sign in either as
a guest, or using their Adobe ID. Once they sign in, they will be presented with a
screen telling them that the meeting is private, and that a message has been sent to
the host.

As the host, a pop-up window will appear at the bottom of your screen, informing
you that Mickey Mouse, Bill Gates, or whoever you invited would like permission to
join. When you accept, the other person gets to see the same ConnectNow window
as in Figure 1-36. Again, it might be necessary to install a plugin if it’s the first time
the guest has accessed a Connect or ConnectNow session.

7. When you’re ready to share, click Share My Computer Screen. You will be asked to
confirm that you’re ready to start sharing. Click Share (or Cancel, if you’re not
ready). You’ll then be presented with the short message shown in Figure 1-37,
telling you the difference between what you see as host and what others see.

Figure 1-37. The host of the meeting sees a different screen layout from other participants.

8. Click OK to start sharing. As soon as you do so, the ConnectNow window shrinks to
show just a list of attendees and the chat window, exposing the rest of your desk-
top, as shown in Figure 1-38. Everyone else sees your desktop framed in the Screen
Sharing section of the maximized ConnectNow window. The only thing the others
can’t see is your small version of the ConnectNow window. Unless you want to
keep an eye on the chat window, it’s probably a good idea to minimize the
ConnectNow window while sharing your screen.
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Figure 1-38. Once you start sharing, your whole desktop is exposed.
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9. To stop sharing, click the x button at the top right of the host’s ConnectNow
window, as shown in Figure 1-39.

Figure 1-39.
While sharing, the host’s

ConnectNow window
shows attendees, a chat

window, and tools to
control the session.



10. To end a meeting, select Meeting ➤ End Meeting in the maximized ConnectNow
window. You cannot end a meeting while still sharing your screen. You will be pre-
sented with a suggested farewell message, which you can edit or simply send as is
to all participants. Once the meeting is over, close the ConnectNow window.

This has been only a brief overview of screen sharing. The best way to find out more is to
try it out for yourself, and launch the Help menu inside the ConnectNow window. As you’ll
discover, the service supports the use of webcams, speech through Voice over Internet
Protocol (VoIP), and telephone conferencing. Although the ConnectNow service is free,
telephone conferencing is charged at long-distance rates.

Managing CSXS
Other hosted services will become available after the release of Dreamweaver CS4. To pre-
pare for them, there is a new Connections panel, shown in Figure 1-40. To open it, select
Window ➤ Extensions ➤ Connections.

Figure 1-40. The Connections panel is intended to provide 
access to future hosted services.

The Extensions item on the Window menu is confusingly named. It has nothing to do
with extensions to the program’s functionality that have been a major feature of
Dreamweaver ever since the first version. To install Dreamweaver extensions, launch
Extension Manager 2 directly from the Start menu on Windows or Finder on a Mac.
Alternatively, use Manage Extensions on the Commands or Help menus.

The screen-sharing service lets others take over control of your screen—as long as you
give them permission first. This is both very useful and potentially dangerous. Make sure
you know who the other person is before handing over control of your computer.
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If you log into the Connections panel with your Adobe ID, Dreamweaver will automatically
check the server for updates to CSXS and install them. If you want to disable this default
behavior, click the panel options menu button at the top right of the panel, as shown in
Figure 1-40. The Update preferences menu item lets you choose whether Dreamweaver
automatically checks for updates and installs them. The Offline options menu item lets you
choose to be kept offline. Selecting this option disables the Share My Screen feature
described in the preceding section.

Other new features

In addition to the CSXS features already described, the following features have been
added or significantly changed:

JavaScript extractor: This identifies most or all of the JavaScript in a web page and
moves it to an external file. Its use is described in Chapter 8.

Spry data sets: The interface for creating Spry data sets has been completely
redesigned. It now generates data sets from HTML sources as well as XML. Its use is
covered in Chapter 19.

New Spry widgets: Four new Spry widgets have been added. Three of them han-
dle the validation of form elements (radio button groups, password fields, and
password confirmation fields). These are covered in Chapter 9. The other widget
creates tooltips and disjointed rollovers, and is covered in Chapter 7.

JavaScript widgets galore: You’re no longer restricted to using Spry widgets in
Dreamweaver CS4. Adobe has sought the cooperation of leading developers of
JavaScript widgets, including members of the Yahoo! User Interface (YUI) and
jQuery teams, to create versions of their widgets that can be directly integrated
into Dreamweaver. See Chapter 8 for details.

Subversion integration: Subversion (http://subversion.tigris.org/) is one of
the most popular open source version control systems. Dreamweaver now provides
direct access to a Subversion repository through the Files panel. This feature is
described in the next chapter.

Cloaking of individual files: Cloaking excludes certain files from being uploaded to
your remote server. In previous versions of Dreamweaver, cloaking was restricted 
to all files with specified file name extensions and whole directories (folders). You
can now cloak individual files as well. Cloaking is covered in the next chapter.

A related improvement excludes cloaked files from reports on orphaned files (files
that have no incoming links). To run a check for orphaned files, select Site ➤ Check
Links Sitewide. When the Link Checker tab opens in the Results panel group, choose
Orphaned Files from the Show drop-down menu at the top left of the panel.

Photoshop Smart Objects: Photoshop integration has been improved by the addi-
tion of support for Smart Objects (images that are directly linked to the original
Photoshop file). This is covered in Chapter 3. Dreamweaver does not support Smart
Objects imported from other Creative Suite programs, such as Illustrator.

Inserting Flash and Flex movies: The way that Flash and Flex movies are embed-
ded in a web page has changed. Pages created in Dreamweaver CS4 use the new
method, which includes an express installer that updates the version of Flash Player
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if necessary. Pages created in previous versions of Dreamweaver are not updated,
but can be edited without problems. See Chapter 3 for details.

InContext Editing: This is an Adobe online hosted service that permits authorized
users to edit web pages through a web browser. What can and cannot be changed
is determined by the developer creating editable regions and setting rules through
Dreamweaver CS4. InContext Editing is covered in Chapter 13.

Online help: Most of Dreamweaver’s help files are now hosted online. When you
access Dreamweaver Help from the Help menu (or press F1), Dreamweaver detects
whether you are online and launches the help system in your default browser.
Adobe says it has adopted this system so that the content can be updated more
easily and corrected if necessary. A limited set of help files is included in the pro-
gram for use when you are offline.

The new Search for help field in the Application bar also brings up online help
from relevant community sites. The search is powered by Google, but Adobe mon-
itors the content to make sure only reliable articles are referenced.

Considerable disappointment was voiced by many people at the lack of new features for
PHP and other server-side technologies when the public beta of Dreamweaver CS4 was
released in May 2008. This disappointment is understandable, as the server behaviors have
remained essentially unchanged since Dreamweaver MX came out in 2002. Speaking per-
sonally, my disappointment is more than compensated for by the other changes in
Dreamweaver CS4. As I said at the beginning of this chapter, I consider this to be the most
significant upgrade to the program since Dreamweaver MX. Making significant changes to
the server-side features would have involved either dropping other features or risking
more buggy implementation.

However, it’s not true to say that nothing has changed with regard to support for PHP. The
PHP code hints have been cleaned up by adding many new PHP 5 functions and removing
incorrect and deprecated items. Changes have also been made to some of the server
behavior code to ensure it doesn’t break in PHP 6. The changes might seem small, but
they’re important; they have also been done in a way that remains compatible with pages
developed in earlier versions of Dreamweaver.

What is no longer there

Adobe took the unusual step of announcing more than a year before the release of
Dreamweaver CS4 that certain features would be removed. If you missed that announce-
ment and can’t find some of your favorite features, here’s a list of what has been removed:

Layout mode

Timelines

Flash elements, Flash buttons, and Flash text

Site map

ASP.NET and JavaServer Pages (JSP) server behaviors and recordsets

JavaBeans

Web Services panel
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The removal of some of these items is likely to upset some people, but the first three have
been removed in the interests of creating more standards-compliant web pages. Layout
mode and timelines generated horrendously complex code that has no place in a modern
website. Also, the Flash elements created by Dreamweaver were rather crudely built and
made websites inaccessible. Their removal doesn’t mean you can’t use Flash elements in
Dreamweaver any longer—just that you need to build them in Flash; Dreamweaver won’t
create them for you.

The decision to remove support for ASP.NET and JSP is more controversial, but it appears
to be due to Adobe’s recognition that it was fighting a losing battle trying to support five
server-side technologies. It will be interesting to see what approach it takes to server-side
support in future versions.

Changing default settings
In addition to the features already described, Dreamweaver has many other preferences
that can be configured to suit your workflow. The default settings are fine for most peo-
ple, but if you want to change the way Dreamweaver looks or works—and it hasn’t already
been covered in this chapter—the first place to look is in the Preferences panel (see
Figure 1-41), which you access from the Edit menu in the Windows version and the
Dreamweaver menu on a Mac. The keyboard shortcut is Ctrl+U/Cmd+U.

Figure 1-41. The Preferences panel controls most other aspects of how Dreamweaver looks and works.
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As you can see from Figure 1-41, the Preferences panel contains 19 categories, the names
of which are mostly self-explanatory. AP Elements controls the look of absolutely posi-
tioned <div> elements, which older versions of Dreamweaver refer to as layers. Although
CSS absolute positioning can be useful, many inexperienced users misunderstood the
interaction between Dreamweaver layers and other page elements, so their use is now
generally discouraged.

I’ll describe the most important categories at the appropriate point in later chapters. Here,
I’ll just touch on other important categories that don’t fit in naturally elsewhere.

Code Coloring: This lets you edit the syntax coloring scheme for different types of
documents and code.

Code Format: One of the most important settings in this category lets you choose
whether to indent code for ease of reading and whether to use spaces or tabs for
indentation. If you find your web pages display with unusual spacing, check that
Line break type is set to LF (Unix). This is the most reliable setting even if you’re
working in Windows or on a Mac.

Fonts: This controls the default size and style of fonts in Design and Code views. By
default, Dreamweaver uses Unicode (utf-8). If you use a different encoding for
your pages, you need to select the appropriate one from the Font settings list.
Dreamweaver calls Latin-1 (iso-8859-1) encoding Western European on Windows
and Western on a Mac.

Migrating snippets and other personal
settings 

Moving your collection of snippets, workspace layouts, or favorites simply involves copy-
ing and pasting a file or folder from your Dreamweaver configuration files. 

Locating the Dreamweaver configuration files

The Dreamweaver configuration files are hidden on Windows, so you need to enable the
option to view hidden files and folders in order to locate them, as follows.

In Windows Vista, select Start ➤ Computer ➤ Organize ➤ Folder and Search Options
➤ View. In Advanced settings, choose Show hidden files and folders.

In Windows XP, select Start ➤ My Computer ➤ Tools ➤ Folder Options ➤ View. In
Advanced settings, choose Show hidden files and folders.

Once you turn on this option, hidden folders are displayed as dimmed icons to remind you
to treat them with care.

Dreamweaver CS4 creates at least three configuration folders on your computer. Two of
them control how the program works for everyone on the computer. In Windows, they’re
located in Program Files; on a Mac, they’re in Applications. You should not attempt to
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touch them unless you know what you’re doing. If you make a mistake, Dreamweaver
could stop working completely.

Each time it starts up, Dreamweaver looks for another configuration folder that stores the
personal settings for the current user. Editing this folder is relatively harmless. Because a
separate folder is created for each user account on the computer, changing your own set-
tings doesn’t affect anyone else and vice versa. Even if you make a complete mess of
things, all that’s necessary is to delete the folder and all its contents. If Dreamweaver can’t
find your personal settings, it creates a new configuration folder loaded with all the
default settings. 

The location of the personal configuration folder depends on your operating system and
version of Dreamweaver. For Dreamweaver CS4, it’s as follows:

Windows Vista: C:\Users\<username>\AppData\Roaming\Adobe\Dreamweaver
CS4\<language>\Configuration

Windows XP: C:\Documents and Settings\<username>\Application Data\
Adobe\Dreamweaver CS4\<language>\Configuration

Mac OS X: Macintosh HD:<username>:Library:Application Support:Adobe:
Dreamweaver CS4:<language>:Configuration

In all cases, <username> is the name of your user account on the computer and 
<language> indicates the language of your operating system. The language is usually rep-
resented by two pairs of characters separated by an underscore, as in en_US (English),
es_ES (Spanish), or fr_FR (French).

Earlier versions of Dreamweaver located the personal configuration folder in a slightly dif-
ferent location. This is where it can be found in Dreamweaver CS3:

Windows Vista: C:\Users\<username>\AppData\Roaming\Adobe\Dreamweaver
9\Configuration

Windows XP: C:\Documents and Settings\<username>\Application Data\
Adobe\Dreamweaver 9\Configuration

Mac OS X: Macintosh HD:Users:<username>:Library:Application Support:
Adobe:Dreamweaver 9:Configuration

Migrating snippets

Dreamweaver does a very good job of migrating site definitions from an existing version of
Dreamweaver to a new one located on the same computer (migrating them to another
computer is covered in the next chapter), but it leaves behind any snippets that you have
installed. (As the name suggests, snippets are short sections of useful or frequently used
code ready to drop directly into a page.) 

To migrate your snippets from one version of Dreamweaver to another, close
Dreamweaver, and open your personal configuration folder in the version that contains
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the snippets. Inside, you should find a folder named Snippets. Just copy it and all its 
contents, and paste it into your personal configuration folder in the new version of
Dreamweaver. When you start the program, your snippets should be ready for use.

Transferring workspace layouts

As mentioned earlier, you can transfer your workspace layouts from one computer to
another. Dreamweaver CS3 workspace layouts are different from CS4, so you shouldn’t try
to mix them.

Your workspace layouts are stored in your personal configuration folder in a folder called,
logically enough, Workspace. The files have the same name that you used to save the lay-
out. Simply copy them to the Workspace folder in the other version, and restart
Dreamweaver. Since the files are written in XML, you can share them among Windows and
Mac users. 

Moving favorites

As with workspace layout migration, changes between Dreamweaver CS3 and CS4 mean
you shouldn’t attempt to migrate your Insert bar favorites from one version to another.
However, if you want to move your Favorites category from Dreamweaver CS4 on one
computer to another, copy insertbar.xml from the Objects folder of your personal con-
figuration folder to the same location on the other computer. If the target computer
doesn’t have an Objects folder inside your personal configuration folder, create one.

Troubleshooting mysterious Dreamweaver
errors

The previous section described how to find your personal configuration folder, for the
purpose of migrating personal settings. Another file in this folder happens to be the
source of some unexplained Dreamweaver errors. 

To speed up its operation, Dreamweaver creates a file called WinFileCache-********.dat
on Windows and MacFileCache-********.dat on Mac OS X (the ******** represents a
series of numbers and letters). Occasionally, this file gets corrupted, causing Dreamweaver
to act in an unpredictable way. The most common problem is for Dreamweaver to display
alerts about JavaScript errors or about “translators not found.” If this happens, close
Dreamweaver, delete WinFileCache-********.dat or its Mac equivalent from your per-
sonal configuration folder, and restart the program.

Deleting the cache file is normally sufficient. However, sometimes the cause lies with a
third-party extension that you have installed in Dreamweaver. If you have installed any
extensions, the only solution is to disable all of them and reinstall them one by one until
you can identify the culprit (extensions are covered in Chapter 8).
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Chapter review
This has been a marathon tour of the Dreamweaver CS4 UI and new features. Familiarity
with the UI and features of any program is essential to using it successfully. Most of us are
creatures of habit, so readers who have upgraded from a previous version of Dreamweaver
or migrated from a different program might find the new environment difficult to get used
to. Dreamweaver has a very rich feature set, but not everyone needs the same ones, and
very few people are likely to need all of them. Experiment with the different aspects of the
UI and find those that suit you best.

In the next chapter, I’ll cover everything you need to know about setting up a website in
Dreamweaver. If you’re an experienced Dreamweaver user, most of it will be familiar to
you, although there are some new features. If you’re new to Dreamweaver, it’s essential
reading. Without an understanding of the role of site definition, you’ll run into a lot of
avoidable problems.
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