This project creates a Payroll Spreadsheet with the following features:

- **Calculates** Regular Pay, Over Time Hours, Overtime Rate, Overtime Pay and Gross Pay using **Formulas** and **Functions** such as the **Sum** and **IF** functions.
- **Counts** the number of employees and tallies the number of Males and Females.
- Calculates **Totals**, **Minimum**, **Maximum**, and **Average** values.
- Formulas, titles, and headers are professionally **Formatted** and **Justified**.
- Non-printing **Comments** are included for help and clarification.
- **Data Validation**, **Conditional Formatting**, and cell **Protection** assure data integrity.

**Background:**

- **Spreadsheets** are tables used for quick and reliable calculations and data manipulation.
- Spreadsheets can have thousands of **Rows** (see row labels numbered 1-16 below-left).
- Spreadsheets can have hundreds of **Columns** (see column headers labeled A-J below-top).
- The junction of a Row and a Column is called a **Cell** (see cell B7 below labeled **First**).

The finished sample project is shown in the figure below:

![Fig. 1](Image)

Your project will contain your own data.
Step 1: Enter Titles, Headings and Data in Worksheet

- In cell B1, enter the name of your company
- In B2, type Payroll Report
- In B3, type Prepared by: followed by your own name
- In B4, enter the last day of the pay period
- In rows 6 and 7, type in headings as shown:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Your</td>
<td>Company</td>
<td>in</td>
<td>Your</td>
<td>Theme</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Payroll</td>
<td>Report</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Prepared</td>
<td>by:</td>
<td>Your</td>
<td>Name</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>1/31/2009</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Last</td>
<td>First</td>
<td>G</td>
<td>Rate</td>
<td>Hours</td>
<td>Weekly</td>
<td>Regular</td>
<td>OT</td>
<td>OT</td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Fig. 2

Possible Problem: After typing a date, formula, or numeric field, the cell displays pound signs:

Fig. 3

Cause: The cell is not wide enough to display the entire contents. If you have not changed the default width of a column, Excel automatically widens the column as numeric data is entered. Once you have changed a column width, however, you must readjust the width yourself.

Solution: Use one of the resizing methods described in Step 9.

To merge and center the title lines:

- Highlight cell B1 and drag the pointer through J1
- Click the Merge & Center icon in the Alignment group on the Home tab

Cells B1 through J1 are merged into one cell and the company name is centered in the cell:

Fig. 4
Follow the above steps to center the remaining title lines from column B through column J in rows 2, 3, and 4.
Excel automatically left justifies alphanumeric data and right justifies numeric data. Right justifying the text in numeric field headers provides a more balanced appearance.

- Click cell D6 (Hourly) and drag the pointer through cell J7
  This highlights the numeric field headers, from Hourly Rate through Gross Pay.
- Click the Align Text Right icon in the Alignment group on the Home tab to insure that the header text above numeric columns is appropriately lined up.

![Fig. 5](image)

- Enter eight (8) to twelve (12) employees from your own adopted business
  Include your own data for Last, First, Gender, Hourly Rate, and Weekly Hours.
- Enter Total labels in the row immediately below the last employee as shown:

![Fig. 6](image)

Possible Problem: When entering numeric data, the entries are left justified.
Cause: You inadvertently typed a non-numeric character or a space in the cell.
Solution: Remove any non-numeric characters, such as the letter O instead of a zero (0).

Save your workbook giving it a descriptive name such as *CompanyNamePayroll*.

**Step 2: Format the Title Lines**
In this section, you personalize the titles using the built-in styles and using individual font icons.
For a professional project, keep the styles consistent throughout each worksheet and workbook within the company.

- Click Colors in the Themes group on the Page Layout tab
  The sample uses a custom user-created color theme:

![Color Theme](image1)

Fig. 7

- Select one of the built-in color themes
- Highlight the title area in cells A1 through J5
- Click Cell Styles in the Styles group on the Home tab

![Cell Styles](image2)

Fig. 8

- Select an Accent color in the Themed Cell Styles section
  This fills the highlighted cells with the selected color.
**Possible Problem:** When formatting using Cell Styles, the selected Title and Headings style is undone when you add an Accent.

**Solution:** Select the Accent first; then select your Title and Headings style.
- Highlight the four (4) title lines (A1-J4)
- Click the arrow on the right-hand side of the Font icon and select a Font Face (The sample uses Copperplate Gothic Bold)

![Fig. 9](image1)

- Highlight the first two (2) title lines and click the arrow on the Font Size icon

![Fig. 10](image2)
• Scroll down the list and select a larger size, such as 16 point
• Click the Bold icon in the Font group on the Home tab
  You can also bold cell contents by pressing the [Ctrl] key and tapping the [B] key.
• Select a complementary font size for the two (2) remaining title lines

Possible Problem: When you select a size for your font, the text doesn’t fit in the cell.
Solution: Select a different Font Face, reduce the size, or widen the cell.
• Click the arrow on the Font Color icon
• Select a color that contrasts well with the accent/fill color

Step 3: Format the Column Headers
  Format the Total Labels
• Highlight the two (2) heading rows (A6-J7)
• Click the arrow on the Fill Color icon in the Font group on the Home tab
- Select a contrasting Fill color for the heading lines
- Highlight the Heading lines and Bold the text
- Highlight the second row of headers (A7-J7)
- Click the Borders icon in the Font group

![Fig. 13](image)

- Select Thick Bottom Border
  Note: Using the Underline feature only underlines the actual contents of each cell.
- Highlight and Bold the *Males*, *Females*, and *Total* labels in column B
- Highlight, Bold, and Right Justify the remaining total labels in column D and column I

![Fig. 14](image)

**Step 4: Format Numeric Fields**
In the sample, Hourly Rate, Regular Pay, OT Rate, and OT Pay are in the Accounting format with two (2) decimal places and no dollar sign. Weekly Hours and OT Hours are in the Number category with one (1) decimal place and no dollar sign. Gross Pay is Accounting format with two (2) decimal positions and a dollar sign.
- Highlight the Hourly Rate amounts (D8-D12)
- Click the Dialog Box Launcher in the Number group on the Home tab
Select the Accounting Category and leave Decimal places set to 2
Click the arrow in the Symbol list box and select None
Apply the same Accounting, Decimal place, and Symbol format to the OTRate and OTPay cells
Apply the same format to the RegularPay cells; include the RegularPay Totals cell (F13)
Format the GrossPay cells including the Avg cell (J16) as Accounting with 2 Decimal places and a dollar sign
Format WeeklyHours including the Avg cell and OTHours including the Totals cell, as Number, with the 1000 Separator (,) and 1 Decimal place:
Step 5: Create Formula for Regular Pay

If we were not calculating overtime, the Regular Pay formula would simply be \( =D8 \times E8 \) (or Hourly Rate times Weekly Hours). But if we consider overtime, Regular Pay is calculated using weekly hours up to 40. Anything above 40 goes into the OT Hours field.

- Highlight the first Regular Pay cell, F8
- Click in the Formula Bar and type:
  \( =IF(E8 \leq 40, D8 \times E8, D8 \times 40) \)

As you start typing a formula, Excel lists possible entries and displays a screen tip for each entry:

As you type in the formula, Excel color codes operands and corresponding cell(s).
(Notice the screen tip, which shows the correct format of an IF statement):

**Alternative:** For a faster, more reliable way to enter a formula, instead of typing \( E8 \), just click in cell E8, and instead of typing \( D8 \), just click in D8. In other words, start typing the formula with an equal sign, but in place of typing the cell name, click the cell to automatically insert the cell name in the formula.

Once you tap [Enter], the color coding disappears unless you edit the cell contents. To show the formula in a cell rather than its result, double-click the cell containing a formula.

- With cell F8 highlighted, click the small square fill handle in the lower right corner of the cell and drag down through the remaining Employees’ Regular Pay rows

This copies the cell contents (in this case a formula) through the selected cells, changing the cell references to correspond relative to the row and column (a “relative copy”)
After dragging the formula through the data range, Excel gives you three (3) Auto Fill options:

Copy Cells copies the cell contents and whatever formatting the cell being copied has.

Fill Formatting Only copies only the formatting of the source cell into the destination cells.

Fill Without Formatting copies the cell contents but doesn’t change the destination cells’ format.

Possible Problems: Excel indicates an error with a symbol ( or ) beside the cell. Some common errors include: #VALUE! #NAME? and #DIV/0!

Cause: There are different causes for each type of error. Rest the mouse pointer over the error indicator to see a screen tip that identifies the type of error.

Solution: With the offending cell selected, click the error indicator and select Help on this error to open Excel Help. If the problem is caused by non-numeric data (#VALUE!) in the source cells, correctly reenter the data. If a formula attempts to divide by a 0, you will get a #DIV/0! Error. The #NAME? error indicates that a range name (such as HourlyRate, see below) is either not defined, is misspelled, or has special characters in it.

Step 6: Create Range Names for Data

When entering formulas, using names rather than cell references makes them easier to read.

- Highlight all the Hourly Rate amounts that you have entered, (D8-D12)
- Click in the Name box, (above column A) and type HourlyRate, then tap [Enter]

Possible Problem: When you refer to a named range, you get an invalid name error.

Causes: You may have mistyped the name or used a reserved word as a range name. A name must begin with a letter, an underscore (_), or a backslash (\). The rest of the name can be letters, numbers, periods, and underscore characters. You cannot have spaces in a name.
**Solutions:** Check your spelling, change any range names that are reserved words.

**Alternative:** Another method for naming ranges is to open the Formulas tab and click Define Name. The New Name dialog box opens defaulting to the text that is in the cell immediately before the selected cell range. In this case, the default name is *Rate*. *Rate* is a “reserved word” used for financial functions, so you must enter another name in the Name box or you will get an error message if you use it in a formula.

- Repeat the range naming process individually for WeeklyHours, RegularPay, OTHours, OTRate, OTPay, and GrossPay
- Click the arrow in the Name box
  Excel lists the named data ranges in alphabetical order:
Step 7: Calculate Overtime Fields and Gross Pay
Anything above 40 in WeeklyHours goes into the OTHours field.

- Highlight the first OTHours cell, G8
- Click in the Formula Bar and type:
  \[=IF(Weekly\text{Hours}>40, \text{Weekly\text{Hours}-40}, 0)\]
- Drag the fill handle to copy the formula through the remaining OTHours rows

![Fig. 24](image1)

- Enter and copy down the OT Rate, which is time and a half in the sample
  \[=\text{HourlyRate} \times 1.5\]
- Calculate the OT Pay and copy it down through the remaining OTPay range
  \[=\text{OTHours} \times \text{OTRate}\]
- Add Regular Pay and OT Pay to calculate Gross Pay and copy it through the range

![Fig. 25](image2)

Step 8: Count Males, Females and Total Employees
In this step, you use the COUNTIF and COUNTA functions to count male, female, and total employees.
• Highlight the cell to the right of the Males: total label, C14
• In the Formula bar, type: \(=\text{CountIF}(C8:C12, \text{"M"})\)
  If a cell in the Gender column contains an “M”, it will add one (1) to the counter.

![Fig. 26](image)

• Follow the above steps to count the number of females
  \(= \text{CountIF}(C8:C12, \text{"F"})\)
• Count the total employees (CountA is for Alphanumeric data; Count for numeric data)
  \(= \text{COUNTA}(C8:C12)\)

![Fig. 27](image)

**Step 9: Calculate Totals for Hours and Pay Fields**

**Resize Columns**

In this step, you use the SUM function to calculate total Weekly Hours, Regular Pay, OT Hours, and Gross Pay. You start by adding a border line to separate the detail amounts from the totals, then calculate the total fields, and finish by formatting the fields and resizing the columns.

• Highlight the last entry under the Weekly Hours header, E12
• Click the Borders icon in the Font group on the Home tab
• Select Bottom Border
Follow the above steps to place a border line under Regular Pay, OTHours, and Gross Pay.
Highlight the Totals row under Weekly Hours and click the Sum icon in the Editing group on the Home tab, or manually type =SUM(Weekly Hours).
Excel makes an assumption about what range you want to sum—in this case, the named range WeeklyHours.

- If the correct range automatically appears in the SUM formula, just tap [Enter]
- Repeat to total Regular Pay, OT Hours, and Gross Pay

![Fig. 30](image)

- Highlight the cell to the right of the Min label in the Weekly Hours column, E14
- Click the arrow next to the Sum icon and select Min

![Fig. 31](image)

In the sample below, Excel has included the total weekly hours amount in the MIN formula:

![Fig. 32](image)

**Possible Problem:** Excel selects an incorrect range for a formula.

**Solution:** You can highlight the correct range with the pointer; you can click in the Formula bar and type in the correct range; you can click in the cell and type in the correction.

- Select the correct range and press [Enter].
- Use the **Max** function for the maximum weekly hours
- Use the **Average** function for the average weekly hours
- Repeat these steps for the gross pay minimum, maximum, and average

![Fig. 33](image)

- **Bold** the Weekly Hours total, minimum, and maximum amounts, the Regular Pay and OT Hours totals, and the Gross Pay total, minimum, and maximum amounts

<table>
<thead>
<tr>
<th>Last</th>
<th>First</th>
<th>G</th>
<th>Hourly Rate</th>
<th>Weekly Hours</th>
<th>Regular Pay</th>
<th>OT Hours</th>
<th>OT Rate</th>
<th>OT Pay</th>
<th>Gross Pay</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adams</td>
<td>Al</td>
<td>M</td>
<td>11.00</td>
<td>30.0</td>
<td>330.00</td>
<td>0.0</td>
<td>16.50</td>
<td></td>
<td>-</td>
</tr>
<tr>
<td>Baker</td>
<td>Bob</td>
<td>M</td>
<td>10.00</td>
<td>40.0</td>
<td>400.00</td>
<td>1.0</td>
<td>15.00</td>
<td>15.00</td>
<td>$415.00</td>
</tr>
<tr>
<td>Reilla</td>
<td>Cindy</td>
<td>F</td>
<td>8.00</td>
<td>50.0</td>
<td>320.00</td>
<td>10.0</td>
<td>12.00</td>
<td>120.00</td>
<td>$440.00</td>
</tr>
<tr>
<td>Douglas</td>
<td>Debbie</td>
<td>F</td>
<td>12.00</td>
<td>20.5</td>
<td>246.00</td>
<td>0.0</td>
<td>18.00</td>
<td></td>
<td>-</td>
</tr>
<tr>
<td>Elgin</td>
<td>Emie</td>
<td>M</td>
<td>10.00</td>
<td>40.0</td>
<td>400.00</td>
<td>0.0</td>
<td>15.00</td>
<td></td>
<td>-</td>
</tr>
</tbody>
</table>

**Total:** 181.5 1,696.00 11.0  
**Totals:** $1,831.00

- **Males:** 3  **Min:** 20.5  **Max:**
- **Females:** 2  **Max:** 50.0  **Avg:**
- **Total:** 5  **Avg:** 36.3

![Fig. 34](image)

Resize columns, starting with the G (gender) column:
- Hover the pointer between columns C and D until the cursor forms a crosshair (➕)
- Click the crosshair and drag it to the left (A screen tip tells you the width of the column.)

![Fig. 35](image)
You can double-click the crosshair to have Excel resize the column for you, or click in the column, select Format in the Cells group on the Home tab, and choose AutoFit Column Width.

![Image](image.png)

Fig. 36

Next, you preview the printed output to see how the report will look on the page.
- Open the Page Layout tab and click the dialog box launcher in the Page Setup group
- In the Page Setup dialog box, click Print Preview

![Image](image.png)

Fig. 37

**Possible Problems:** The full worksheet does not fit on one page.
Cause: The print area is not wide enough to hold every column.
Solution: Reduce the size of columns until everything fits on one page, reduce the width of the left and right margins, or try the Landscape orientation.

In the sample, we adjust the column widths.

- Close the Print Preview
  Excel marks the print area with dotted lines.
- Reduce the width of columns that contain shorter data until the report fits on the page
- Select the Gender totals and left justify them
  The Gender column contains a single letter in the body and a single number in the totals, so we left justify them for a more balanced appearance.
Step 10: Apply Conditional Formatting to WeeklyHours

Add Company Logo

The Payroll Report will display Weekly Hours that exceed 40 in red font.

- Highlight the WeeklyHours data range
- Click Conditional Formatting in the Styles group on the Home tab
- Select Highlight Cells Rules and click Greater Than…

![Fig. 40](image)

- Type 40 under Format cells that are GREATER THAN:
- Click the arrow in the format list box and select Red Text

![Fig. 41](image)

In the sample, we created a custom format to use a brighter shade of red using the Custom Format... option.
Next, you add and format your company logo.

- Highlight cell A1
- Click Picture in the Illustrations group on the Insert tab

The Insert Picture dialog box opens.
- Find your company logo and click Insert
When a picture is highlighted in a worksheet, a Format tab appears to the right of the View tab. This tab provides features for enhancing pictures, such as adding a border or a shadow effect.

**Step 11: Add Comments**

- **Apply Data Validation**
- **Protect Worksheet**

You now add a non-printing comment to inform the user of the upper limit of the Weekly Hours field.

- Highlight the first WeeklyHours cell
- Click New Comment in the Comments group on the Review tab

Alternatively, you can right-click in the cell to open a shortcut menu; then select Insert Comment from the menu.

- A red triangle appears in the upper right corner of the cell and comment box opens with an arrow pointing to the triangle.
- Type *Hours must not exceed 60* in the comment box.
Next, add a validation test for the Weekly Hours data.

- Click Data Validation in the Data Tools group on the Data tab
  This opens the Data Validation dialog box.

On the Settings tab,

- Select Decimal from the Allow list box
- Select less than or equal to in the Data list box
- Enter 60 as the Maximum value

On the Error Alert tab

- Choose Stop from the Style list box
  Stop prohibits the user from entering an invalid error. The other styles (Warning and Information) allow erroneous data to remain in a cell.
- Type Invalid Entry as the Title
- Enter Value must not exceed 60 as the Error Message
If the user tries to enter a value greater than 60, your error message will display.

![Data Validation Error Message]

We finish the project by protecting the worksheet so that users can only modify the employee name and gender and the Hourly Rate and Weekly Hours fields.

- Highlight from the first Last name cell (A8) through the last Weekly Hours cell (E12)
- Click Format in the Cells group on the Home tab
Click **Lock Cell** to toggle it off so that it is not locked and users can enter data in the selected cells.

Click **Protect Sheet**

Clear the **Select locked cells** checkbox

Alternatively, you can open the Protect Sheet dialog box by clicking **Protect Sheet** in the Changes group on the Review tab.

If you try to enter data in a protected cell, Excel displays an error message:

You are now done with your Payroll project!